You are here: Home » Topic » Invalid web_root when starting

Invalid web_root when starting

This topic contains 25 replies, has 4 voices, and was last updated by  Anonymous 8 years, 6 months ago.

Viewing 15 posts - 1 through 15 (of 26 total)
  • Author
    Posts
  • #2807

    evandena
    Participant

    Hello,
    I’ve just installed from tarball without –prefix=/usr, and used the default location. I’ve checked that /usr/local/share/mt-daapd/admin-root contains the web files.

    When I try and start the server, I get:
    Invalid web_root
    Error reading config file (/etc/mt-daapd.conf)

    Any help would be appreciated.
    Thanks,
    Eric

    #18201

    evandena
    Participant

    Anyone able to offer a suggestion?

    #18200

    fizze
    Participant

    Whats the relevant line in your config file?
    What are the permissions of the webroot?
    What user do you run mt-daapd as?

    #18202

    evandena
    Participant

    Thanks for the reply.

    I’ve tried various settings to get it to to work, but am always presented with the same error.

    The webroot line from the config is:
    web_root /usr/local/share/mt-daapd/admin-root

    I’ve tried running as root, a service account, nobody. I’ve also tried a slew of permissions on admin-root.

    What exactly is required? What permissions etc work for everyone else?

    #18203

    fizze
    Participant

    you’re missing an equals sign πŸ˜‰
    it should read:

    web_root = /usr/local/share/mt-daapd/admin-root

    Well, my admin-root is owned by root and is world readable for instance.

    #18204

    evandena
    Participant

    That’s strange about the = sign.
    I added the = sign like you suggested, but it still says:
    Invalid web_root
    Error reading config file (/etc/mt-daapd.conf)

    There are no other = signs in my config… all I did was edit the default config, which uses tabs and not equal signs.

    #18205

    fizze
    Participant

    Only in 0.2.4 you don’t need the tabs. In the recent nightly builds you need the equal signs.
    Did you grab the source off nightlies.fireflymediaserver.org ?
    πŸ™„

    Which version is it, anyway?

    #18206

    evandena
    Participant

    I have 2.4.2, build from source on CentOS 5.2

    #18207

    fizze
    Participant

    May I humbly suggest that you grab one of the nightlies from the aforementioned page.
    the 0.2.4 branch is ridiculously outdated.
    Despite them being called nightly builds, they are actually very stable, and boast a lot more features and performance than 0.2.4.x.

    #18208

    evandena
    Participant

    @fizze wrote:

    May I humbly suggest that you grab one of the nightlies from the aforementioned page.
    the 0.2.4 branch is ridiculously outdated.
    Despite them being called nightly builds, they are actually very stable, and boast a lot more features and performance than 0.2.4.x.

    I’ll give that a try. Thanks for all your help thus far.

    #18210

    evandena
    Participant

    Well, now I’m stuck with another issue:
    Invalid config directive: db_type
    Error reading config file (/etc/mt-daapd.conf)

    My config contains:
    db_type = sqlite3

    I compiled:
    ./configure –prefix=/usr –enable-sqlite3 –with-sqlite3-includes=/usr/include –with-sqlite3-libs=/usr/lib

    Not quite sure what to do now πŸ˜•

    #18209

    fizze
    Participant

    does it work with just “sqlite”? that should enable sqlite2, actually.

    Did you get any build warnings related to sqlite?

    #18211

    evandena
    Participant

    Both Sqlite and Sqlite3 are returning the same error. I didn’t see any build errors related to Sqlite, but it wasn’t a very clean install due to some remnants of the previous version.

    Is there a best practice on how to completely uninstall (from source) so I can start over fresh?

    #18212

    Anonymous

    evandena,

    I have taken the exact same path that you have…and am now in the exact same boat. I was having the same problem getting mt-daapd to read my MP3 PATH (similar to your admin path). I started using a stable version of mt-daapd….and now am using the latest nightly. I have successfully compiled sqlite3…..and am now having the same “db_type” problem that you are. I will post here if I find a solution….and you please do the same.

    I would also like to try compiling the nightly with sqlite (not sqlite3, but I am unable to locate a source download for sqlite).

    Wish I had good news for you, perhaps the problem is with the nightly. Will keep you posted.

    Curt

    #18213

    Anonymous

    More feedback:

    Just tried the latest svn-1696 build…..and no difference. πŸ™

    I think next step is to try a complete uninstall and start from scatch as you mentioned before.\

Viewing 15 posts - 1 through 15 (of 26 total)

You must be logged in to reply to this topic.