You are here: Home » Topic » installing problem of nightly-firefly at NSLU2

installing problem of nightly-firefly at NSLU2

FireFly Media Server (formerly mt-daapd) Firefly Media Server Forums Firefly Media Server Setup Issues installing problem of nightly-firefly at NSLU2

This topic contains 15 replies, has 6 voices, and was last updated by  fizze 10 years, 6 months ago.

Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #1151

    goana
    Participant

    hi,

    I am a newbie and try to install the firefly mediaserver (I have a NSLU2-unslung-6.8-beta and a soundbridge M1001). I have also unsling the NSLU.

    My problem is now to install the mediaserver. As described in http://www.nslu2-linux.org/wiki/Optware/Mt-daapd?from=Unslung.Mt-daapd, I have done as follows in telnet:

    1. echo “src firefly http://ipkg.fireflymediaserver.org/armeb” > /etc/ipkg/firefly.conf
    2. ipkg update
    3. ipkg install mt-daapd

    However, after ipkg update there is a failure resulting in different text as follows:

    Downloading http://ipkg.nslu2-linux.org/feeds/optware/nslu2/cross/stable/Packages.gz
    wget: ipkg.nslu2-linux.org: Host name lookup failure
    Downloading http://ipkg.fireflymediaserver.org/armeb/Packages
    wget: ipkg.fireflymediaserver.org: Host name lookup failure
    Downloading http://ipkg.nslu2-linux.org/feeds/optware/nslu2/native/stable/Packages.gz
    wget: ipkg.nslu2-linux.org: Host name lookup failure
    Downloading http://ipkg.nslu2-linux.org/feeds/unslung/modules/cross/6.8-beta/Packages.gz
    wget: ipkg.nslu2-linux.org: Host name lookup failure
    An error ocurred, return value: 4.
    Collected errors:
    ipkg_download: ERROR: Command failed with return value 1: `wget –passive-ftp -q -P /tmp/ipkg-pZ6dko http://ipkg.nslu2-linux.org/feeds/optware/nslu2/cross/stable/Packages.gz
    ipkg_download: ERROR: Command failed with return value 1: `wget –passive-ftp -q -P /tmp/ipkg-pZ6dko http://ipkg.fireflymediaserver.org/armeb/Packages
    ipkg_download: ERROR: Command failed with return value 1: `wget –passive-ftp -q -P /tmp/ipkg-pZ6dko http://ipkg.nslu2-linux.org/feeds/optware/nslu2/native/stable/Packages.gz
    ipkg_download: ERROR: Command failed with return value 1: `wget –passive-ftp -q -P /tmp/ipkg-pZ6dko http://ipkg.nslu2-linux.org/feeds/unslung/modules/cross/6.8-beta/Packages.gz

    Where is the failure…..please help I am a newbie and I am very happy for each help.

    goana

    #9407

    BubbaDog
    Participant

    Been there, done that 🙄 . Check this thread, I had the same issue and Ron, Rich and others hooked me up 😀 ….

    B’Dog

    P.S. – Ron, I still need a PM with an address to send you some morning and evening brews 😉 ….

    #9408

    S80_UK
    Participant

    @bubbadog wrote:

    Been there, done that 🙄 . Check this thread, I had the same issue and Ron, Rich and others hooked me up 😀 ….

    B’Dog

    P.S. – Ron, I still need a PM with an address to send you some morning and evening brews 😉 ….

    This is the one…

    http://forums.fireflymediaserver.org/viewtopic.php?t=5606

    #9409

    BubbaDog
    Participant

    S80,

    Thanks, I guess I clicked too soon without the link 😳 ….

    B’Dog

    #9410

    goana
    Participant

    thanks for the reply.

    I have a few points not solved yet:

    – I have changed the settings in the NSLU2 but nothing has changed. The same errors are coming.
    Where is the bottleneck?
    By the way, there is also a strange thing. When I have connected the NSLU via ethernet cable I have no internet connection via the wlan. First, I have to stop the NSLU than I have internet connection via the wlan. I guess I have changed something wrong?

    – Nevertheless I have downloaded the mt-daapd_svn-1498-1_armek.ipk and has put it into the tmp folder. Then I have installed the file via telnet by ipkg install mt-daapdxxxxx.ipk. It work but at the end it say: “cannot satisfy the followin dependencies for mt-daapd (libid3tag, libogg, ivorbis-tools, flac, sqlite2, bash, alac-decoder, sqlite).
    I guess, this is due to the failed internet-connection and thus, no ipkg update can be done.

    Need help to install the firefly server, please

    goana

    #9411

    rpedde
    Participant

    @goana wrote:

    thanks for the reply.

    I have a few points not solved yet:

    – I have changed the settings in the NSLU2 but nothing has changed. The same errors are coming.
    Where is the bottleneck?

    You have some kind of fundamental ip problem. Your NSLU2 either doesn’t have a default gateway set, or it doesn’t have a dns server set.

    Check your settings on the web admin for the nslu2. If it’s set up with a manual IP address, then make sure that your dns server settings and your gateway settings are set to the same value that your PC is.

    You can check your PC settings by doing “ipconfig /all” from a command prompt. Write down dns server and the default gateway from your PC and enter them in the interface for your nslu2 via the web config.

    — Ron

    #9412

    goana
    Participant

    thanks for your reply.

    I have set the gateway and DNS of my NSLU2 via web admin as prompted with “ipconfig/all. The connection from the PC to the NSLU2 via LAN works. But when I disconnect the ethernet cable I have no access from the PC to the NSLU2 by WLAN.
    Maybe I should post the ipconfig/all prompt to see what is wrong? Is this secure?

    I hope anybody can help me.

    goana

    #9413

    sonichouse
    Participant

    You will need to have something like this


    192.168.1.1 192.168.1.2
    +
    + +
    +
    | Router | ======= | Your PC |
    +
    + +
    +
    ||
    ||
    +
    +
    | SLUG |
    +
    +
    192.168.1.77

    The Default gateway and DNS on the Slug point to your router (192.168.1.1) in this example.

    Hope this helps.

    #9414

    goana
    Participant

    @sonichouse

    my settings are like this:

    router: 192.168.2.1
    PC: 192.168.2.101 (for WLAN) and 192.168.2.25 (LAN)
    SLUG: 192.168.2.77

    The connection of the PC and SLUG via LAN works but not via WLAN.

    goana

    #9415

    sonichouse
    Participant

    @goana wrote:

    @sonichouse

    my settings are like this:

    router: 192.168.2.1
    PC: 192.168.2.101 (for WLAN) and 192.168.2.25 (LAN)
    SLUG: 192.168.2.77

    The connection of the PC and SLUG via LAN works but not via WLAN.

    goana

    OK all looks good, you need to do run

    ipconfig /all

    and check that for your wireless card, you have 192.168.2.1 as the default gateway.

    Steve

    #9416

    goana
    Participant

    thanks all for your help.

    I guess I have a fundamental error. My setup is as following:

    | Router | < ====> | PC | < ====> | SLUG |

    Is it possible to make any updates, such as “ipkg update” by a telnet session with this setup.
    Is this the failure…..do I have to put the SLUG directly into the router?

    My router is in the first floor and my SLUG and PC in the second floor, this is the reason, why I have connected the SLUG not directly to the router.
    My PC has a WLAN-USB stick to get a connection to the WLAN.

    I am really no expert, but I am very happy for any help.

    #9417

    sonichouse
    Participant

    You will probably need to do something like this



    192.168.1.1 192.168.1.101
    +
    + W W +
    +
    | Router | ---+ +---| Your PC |
    +
    + +
    +
    ||
    ||
    +
    +
    | SLUG |
    +
    +
    192.168.1.77

    The alternative is to put a wireless access point and switch in the same room as your PC and Slug.

    #9418

    goana
    Participant

    hi sonichouse,

    “The alternative is to put a wireless access point and switch in the same room as your PC and Slug.”

    Sorry, for that stupid questions, but I do not understand this? Can I put a WLAN-USB stick into the SLUG to get connetion to the router?

    #9419

    sonichouse
    Participant

    @goana wrote:

    Can I put a WLAN-USB stick into the SLUG to get connetion to the router?

    I have never tried but the nslu2 wiki suggests that this is possible

    #9420

    rpedde
    Participant

    @sonichouse wrote:

    @goana wrote:

    Can I put a WLAN-USB stick into the SLUG to get connetion to the router?

    I have never tried but the nslu2 wiki suggests that this is possible

    Another possibility would be to use connection sharing on the pc, and let the slug pick up an address with dhcp. That should work, too.

Viewing 15 posts - 1 through 15 (of 16 total)

You must be logged in to reply to this topic.