You are here: Home » Topic » Installed but not started up

Installed but not started up

This topic contains 2 replies, has 2 voices, and was last updated by  Anonymous 8 years, 11 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #2660

    steev182

    Hi, I installed firefly, but whenever I try to run it, it comes up with this error:

    [email protected]:/$ sudo mt-daapd -f
    Firefly Version svn-1696: Starting with debuglevel 2
    Error loading plugin /usr/lib/mt-daapd/plugins/ssc-script.so: plugin declined to load
    Plugin loaded: rsp/svn-1696
    Plugin loaded: ssc-ffmpeg/svn-1696
    Plugin loaded: daap/svn-1696
    Starting rendezvous daemon
    Starting signal handler
    *** WARNING *** The program 'mt-daapd' uses the HOWL compatibility layer of Avahi.
    *** WARNING *** Please fix your application to use the native API of Avahi!
    *** WARNING *** For more information see
    db_sqlite3_open: Misc SQL Error: unable to open database file (/usr/var/cache/mt-daapd/songs3.db)
    Error opening db: Misc SQL Error: unable to open database file
    Rendezvous socket closed (daap server crashed?) Aborting.
    Aborting

    Does anyone know how I can fix this?

    Thanks,

    Steve

    #17772

    EVILRipper
    Participant

    db_sqlite3_open: Misc SQL Error: unable to open database file (/usr/var/cache/mt-daapd/songs3.db)

    Have you thought of any causes for this problem?
    My first guess would be permission problems.
    Check which user runs firefly, and if it has read (and write!) access to the file.


    Edit: OK, my bad. I see you used sudo so it’s root. Another possibility is that the database got corrupted. (it happens).
    Delete it, and restart firefly. It will create a new database from scratch.

    #17773

    Anonymous

    Search the forum for “howl compatibility” for solutions to this problem, eg

    RESOLVED! The Debian package was compiled with –enable-howl, so I recompiled it with –enable-avahi instead and this did the trick.

    Awesome. Clearing out the DB file indeed forced it to rebuild the DB and everything’s hunky dory now. Thanks!

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.