Installation on AMS 150 (Fujitsu Siemens)

Viewing 15 posts - 1 through 15 (of 21 total)
  • Author
    Posts
  • #1811
    qwertzy0815
    Participant

    Hi,

    First of all thank you for this really nice suitable software!!!

    I bought the Activity Media Server AMS 150 from Fujitsu Siemens. It’s a NAS with the following values

    processor       : 0
    cpu : 82xx
    revision : 16.20 (pvr 8081 1014)
    bogomips : 176.94
    vendor : Motorola
    machine : MPC8241
    processor : PVID: 0x80811014, vendor: Motorola

    Linux version 2.4.32 ([email protected]) (gcc version 3.2.3) #1 Mon Aug 28 20:13:32 CST 2006

    The NAS comes originally without telnet, but the gents from the FS AMS 150 forum found a way to install some tools like telnet, ssh a.s.o. with some help from the DSM-G600 friends.
    I unpacked their for the DSM compiled version (http://download.dsmg600.info/mt-daapd-0.2.4.tar.bz2) and copied it into the recommended directories, hopefully.

    drwxrwxrwx    3 501      501          4096 Jun 30 08:59 mt-daapd

    Amongst others I did

    mkdir -p /mnt/HD_a2/mt-daapd/cache
    ln -s /mnt/HD_a2/mt-daapd/libz.so.1 /lib/
    ln -s /mnt/HD_a2/mt-daapd/libgdbm.so.3 /lib/
    ln -s /mnt/HD_a2/mt-daapd/libid3tag.so.0 /lib/ /mnt/HD_a2/mt-daapd
    mt-daapd -c /mnt/HD_a2/mt-daapd/mt-daapd.conf

    with the mt-daapd.conf

    web_root	/mnt/HD_a2/mt-daapd/admin-root
    port 3689
    admin_pw mt-daapd
    db_dir /mnt/HD_a2/mt-daapd/cache
    mp3_dir /mnt/Music
    servername mt-daapd
    runas nobody
    extensions .mp3,.m4a,.m4p

    After manual starting

    /mnt/HD_a2/mt-daapd/mt-daapd -c /mnt/HD_a2/mt-daapd/mt-daapd.conf

    I receive the following error message

    /mnt/HD_a2/mt-daapd/mt-daapd: can't resolve symbol '__ctype_b'

    I googled a bit and found out that this is supposed to be a compiling error caused by a wrong lib.

    Here it ends for me so far.
    Any idea? Do I have to cross compile (Oh god, how?) mt-daapd for the AMS 150 or is there any other solution? Thank you.

    #12886
    fizze
    Participant

    Care to try a newer version?
    http://nightlies.mt-daapd.org holds quite a few flavours 😉

    #12887
    qwertzy0815
    Participant

    Thank you for the Link, but i don’t know which one?

    How do i compile the .tar.gz for the Linux version on my AMS 150?

    #12888
    fizze
    Participant

    Not without a complete toolchain. Which is tough.

    Whats the

    uname -a

    output of your machine?

    Depending on your model being RevA or RevB, and according to http://dsmg600.info/ its a PPC, so you could always give it a try with one of the PPC binaries or ipkgs from that site.

    If there is no ipkg available, the ipk is just a tar-gz’d file that has a data and config archive within. You can extract them manually and try to run the binary to see wether its compatible.

    #12889
    qwertzy0815
    Participant

    Hi fizze,

    uname -a gives a failure. The program is not installed …

    And it is_not_ a DSM-G600! I read in the Siemens Forum that the AMS 150 is more or less similar to the DSM.

    Ahhh. Ok. I see. I clicked your link.

    Ok. How do i manually extract the ipk file?

    Mmmh. Google says tar xvzf blabla.ipk.

    Let me try …

    #12890
    qwertzy0815
    Participant

    So. I could manually extract mt-daapd_svn-1673-1ds101g_powerpc.ipk and received 3 different files.

    Oct 4 05:14 control.tar.gz
    791162 Oct 4 05:14 data.tar.gz
    4 Oct 4 05:14 debian-binary

    I extracted data.tar.gz and get a directory named /opt.

    What am I do with this?

    #12891
    fizze
    Participant

    Well browse into that directory, somewhere within resides the binary 😉

    usually in /opt/bin or /opt/usr/bin.

    #12892
    qwertzy0815
    Participant

    Do i just have to replace the old binary on the AMS 150 or do i need the whole directory structure?

    #12893
    fizze
    Participant

    As the binary is newer and requires generally new libs, you probably have to replace a lot more.

    As there is no guarantee this will work, just a tryout, just +x the new binary and try to fire it up and see what happens 🙂

    if it works, go ahead and replace the existing one, if not, tough luck.

    #12894
    qwertzy0815
    Participant

    fizze, i replaced just the binary and reboot. It seems to run.

    Whats about the libraries? Any need for that?

    #12895
    qwertzy0815
    Participant

    Jo, Jo. I am a bit stupid. The mt-daapd server that was running, was the one i installed on my Macbook (gnagnagna).

    It seems i need a kittle more support 😉

    #12896
    qwertzy0815
    Participant

    With help of fizze I downloaded mt-daapd_svn-1673-1ds101g_powerpc.ipk, manually extracted it to my Macbook and copied the expanded /opt directory to the AMS 150 into /mnt.

    I changed the related scripts and conf files to the new path /mnt/opt.

    When I try to start with

    /mnt/opt/etc/init.d/S60mt-daapd

    i receive

    /mnt/opt/etc/init.d/S60mt-daapd: 13: /mnt/opt/sbin/mt-daapd: not found

    My S60mt-daapd is this

    #!/bin/sh

    # make sure our shared libraries are in the path.
    # if we get /etc/ld.so.conf working, this export
    # can be removed
    export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/mnt/opt/lib

    if [ -n "`pidof mt-daapd`" ] ; then
    killall mt-daapd 2>/dev/null
    fi

    sleep 2
    /mnt/opt/sbin/mt-daapd -c /mnt/opt/etc/mt-daapd/mt-daapd.conf

    The exports is

    export HOME='/root'
    export LD_LIBRARY_PATH=':/mnt/opt/lib'
    export LOGNAME='root'
    export OLDPWD='/mnt/opt/etc/mt-daapd'
    export PWD='/mnt/opt/etc'
    export SHELL='/bin/sh'
    export TERM='xterm-color'
    export USER='root'

    Even when i try to start in

    /mnt/opt/sbin

    i receive

    -sh: ./mt-daapd: not found

    Is this just wrong configuration from my side?

    #12897
    fizze
    Participant

    You need to tell your system that this file is executable.

    Try


    chmod +x /mnt/opt/sbin/mt-daapd

    and to the init-script as well, if thats not set already.

    #12898
    qwertzy0815
    Participant

    Hi fizze.

    They are executable

    -rwxrwxrwx    1 0        0             325 Jul  2  2006 S60mt-daapd

    and

    -rwxrwxrwx    1 0        0          441248 Jul  2  2006 mt-daapd

    I restarted the NAS, but still the same message

    /mnt/opt/etc/init.d/S60mt-daapd: 13: /mnt/opt/sbin/mt-daapd: not found

    Any idea?

    #12899
    fizze
    Participant

    Forget the init script and try to start the binary manually.
    Is your /bin/sh an existing and working shell?

    Tried to run

    /mnt/opt/sbin/mt-daapd -c /mnt/opt/etc/mt-daapd/mt-daapd.conf

    as root as well?

    Ownership with 0 0 should be root:root, but maybe this is just busybox’s ls command acting up.

    If its not working Id expect some error message from the kernel or whatnot, but not “not found”. So this indicates its not even loading the binary.

Viewing 15 posts - 1 through 15 (of 21 total)
  • The forum ‘Setup Issues’ is closed to new topics and replies.