You are here: Home » Topic » install latest nightlies with ipkg on synology, help needed

install latest nightlies with ipkg on synology, help needed

FireFly Media Server (formerly mt-daapd) Firefly Media Server Forums Firefly Media Server Setup Issues install latest nightlies with ipkg on synology, help needed

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #2209
    Anonymous
    Inactive

    Hi,

    I’m trying to install version 1586 on my synology DS207+, but I think it’s installing on old version instead. It is installing the version on the NSLU website which is labeled mt-daapd 0.2.4.1-1.
    I tried to install 1696 which produced the same result.

    Here is what I’ve been doing to install the package. As you can see it downloads the 1586 package but then decides to download and install mt-daapd 0.2.4.1-1.

    Am I doing something wrong?
    I tried to remove the NSLU ipkg feed, but ipkg then complains it can’t find the mt-daapd package and stops the installation.

    Can someone help me please? I’m lost…


    DiskStation> ipkg -V 3 -verbose_wget install http://nightlies.fireflymediaserver.org/nightlies/svn-1586/mt-daapd_svn-1586-1_armeb.ipk
    Downloading http://nightlies.fireflymediaserver.org/nightlies/svn-1586/mt-daapd_svn-1586-1_armeb.ipk
    --14:22:05-- http://nightlies.fireflymediaserver.org/nightlies/svn-1586/mt-daapd_svn-1586-1_armeb.ipk
    => `/opt/ipkg-jaXqha/mt-daapd_svn-1586-1_armeb.ipk'
    Resolving nightlies.fireflymediaserver.org... 64.49.219.215
    Connecting to nightlies.fireflymediaserver.org|64.49.219.215|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 704,098 (688K) [text/plain]

    100%[=========================================================================================================>] 704,098 649.87K/s

    14:22:26 (648.80 KB/s) - `/opt/ipkg-jaXqha/mt-daapd_svn-1586-1_armeb.ipk' saved [704098/704098]

    pkg_info_preinstall_check: updating arch priority for each package
    Clearing state_want and state_flag for pkg=mt-daapd (arch_priority=0 flag=16 want=2)
    pkg_info_preinstall_check: update file owner list
    best installation candidate for mt-daapd
    adding mt-daapd to providers
    mt-daapd arch=armeb arch_priority=0 version=svn-1586-1
    mt-daapd arch=arm arch_priority=10 version=0.2.4.1-1
    Found a valid candidate for the install: mt-daapd 0.2.4.1-1
    arch arm (priority 10) supported for pkg mt-daapd
    Installing mt-daapd (0.2.4.1-1) to root...
    Downloading http://ipkg.nslu2-linux.org/feeds/optware/syno-x07/cross/unstable/mt-daapd_0.2.4.1-1_arm.ipk
    --14:22:28-- http://ipkg.nslu2-linux.org/feeds/optware/syno-x07/cross/unstable/mt-daapd_0.2.4.1-1_arm.ipk
    => `/opt/ipkg-jaXqha/mt-daapd_0.2.4.1-1_arm.ipk'
    Resolving ipkg.nslu2-linux.org... 140.211.167.165
    Connecting to ipkg.nslu2-linux.org|140.211.167.165|:80... connected.
    HTTP request sent, awaiting response... 302 Found
    Location: http://ipkg.nslu2-linux.org/feeds-redirect.php?f=optware/syno-x07/cross/unstable/mt-daapd_0.2.4.1-1_arm.ipk [following]
    --14:22:48-- http://ipkg.nslu2-linux.org/feeds-redirect.php?f=optware/syno-x07/cross/unstable/mt-daapd_0.2.4.1-1_arm.ipk
    => `/opt/ipkg-jaXqha/feeds-redirect.php?f=optware%2Fsyno-x07%2Fcross%2Funstable%2Fmt-daapd_0.2.4.1-1_arm.ipk'
    Reusing existing connection to ipkg.nslu2-linux.org:80.
    HTTP request sent, awaiting response... 302 Found
    Location: http://ftp.osuosl.org/pub/nslu2/feeds/optware/syno-x07/cross/unstable/mt-daapd_0.2.4.1-1_arm.ipk [following]
    --14:22:48-- http://ftp.osuosl.org/pub/nslu2/feeds/optware/syno-x07/cross/unstable/mt-daapd_0.2.4.1-1_arm.ipk
    => `/opt/ipkg-jaXqha/mt-daapd_0.2.4.1-1_arm.ipk'
    Resolving ftp.osuosl.org... 140.211.166.134
    Connecting to ftp.osuosl.org|140.211.166.134|:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 144,476 (141K) [text/plain]

    100%[=========================================================================================================>] 144,476 146.55K/s

    14:23:09 (146.45 KB/s) - `/opt/ipkg-jaXqha/mt-daapd_0.2.4.1-1_arm.ipk' saved [144476/144476]

    best installation candidate for gdbm
    adding gdbm to providers
    gdbm arch=arm arch_priority=10 version=1.8.3-2
    Found a valid candidate for the install: gdbm 1.8.3-2
    pkg_depends.c:183: satisfying_pkg=0xe5620
    best installation candidate for libid3tag
    adding libid3tag to providers
    libid3tag arch=arm arch_priority=10 version=0.15.1b-1
    Found a valid candidate for the install: libid3tag 0.15.1b-1
    pkg_depends.c:183: satisfying_pkg=0xfdb00
    Running script /opt/ipkg-jaXqha/mt-daapd-s5hAk6/preinst
    installing maintainer scripts
    installing data files
    extracting data files to /
    Calling pkg_write_filelist from install_data_files
    creating mt-daapd.list file
    creating //usr/lib/ipkg/info/mt-daapd.list file for pkg mt-daapd
    resolving conf files
    pkg=mt-daapd old_state_flag=180 state_flag=180
    cleanup temp files
    cleanup_temporary_files: pkg=mt-daapd local_filename=/opt/ipkg-jaXqha/mt-daapd_0.2.4.1-1_arm.ipk tmp_dir=/opt/ipkg-jaXqha
    Done.
    Configuring unpacked packages
    Configuring mt-daapd
    Running script //usr/lib/ipkg/info/mt-daapd.postinst



    To complete this installation, make any necessary changes
    to the config file in /opt/etc/mt-daapd/mt-daapd.conf, and
    start the daemon by running /opt/etc/init.d/S60mt-daapd

    writing status file
    pkg_write_changed_filelists: saving changed filelists
    Calling pkg_write_filelist for pkg=mt-daapd from pkg_write_changed_filelists
    creating mt-daapd.list file
    creating //usr/lib/ipkg/info/mt-daapd.list file for pkg mt-daapd
    Successfully terminated.
    hash_table[pkg-hash] n_buckets=0 n_elements=1033 max_conflicts=0 n_conflicts=0
    hash_table[file-hash] n_buckets=0 n_elements=3096 max_conflicts=0 n_conflicts=0
    hash_table[obs-file-hash] n_buckets=0 n_elements=0 max_conflicts=0 n_conflicts=0
    DiskStation>

    #16254
    rpedde
    Participant

    @dpnero wrote:

    Hi,

    I’m trying to install version 1586 on my synology DS207+, but I think it’s installing on old version instead. It is installing the version on the NSLU website which is labeled mt-daapd 0.2.4.1-1.
    I tried to install 1696 which produced the same result.

    It is. The version you are trying to install is big-endian arm, which only works on the DS-101 and DS-101j. The ds-x07 models are little-endian arm.

    Won’t work.

    Synology has a wiki with pre-compiled stuff here: http://www.synology.com/wiki/index.php/Compiled_programs_for_Marvell_mv5281_ARM-based_Synology_Products, which includes firefly.

    — Ron

    #16255
    Anonymous
    Inactive

    Thank you!

    I’ve been able to install 1696 🙂

    The version on the synology’s wiki page is still an old version. I found the 1696 nightly in this thread http://www.synology.com/enu/forum/viewtopic.php?f=55&t=5240&st=0&sk=t&sd=a

    I appreciate your help. Thanks again!

Viewing 3 posts - 1 through 3 (of 3 total)
  • The forum ‘Setup Issues’ is closed to new topics and replies.