You are here: Home » Topic » I think I have it setup correctly, but…

I think I have it setup correctly, but…

This topic contains 7 replies, has 2 voices, and was last updated by  rpedde 12 years, 7 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #1017

    bbjonz
    Participant

    Hi,

    I think I have mt-daapd setup correctly but iTunes 7 can’t see the share. From what I’ve read, iTunes 7 might be the problem. If so, stop me here! If not, here’s my setup:

    Server:

    Ubuntu Server Dapper Drake
    Most recent nightly build of mt-daapd (can see it and modify it in my browser. Says the server is running but that bonjour is not–I’ve read that this might be a bug. Configured correctly, as far as I know.)
    Firestarter firewall disabled (for now)
    Avahi daemon that seems to be running (might this conflict with pre-installed bonjour daemon?)

    Client:

    Powerbook G4 (10.4.8)
    iTunes 7.0.2
    Firewall disabled (for now)

    Please let me know if I’ve missed anything here. Thanks in advance for any and all help.

    Joe

    #8621

    rpedde
    Participant

    @bbjonz wrote:

    Hi,

    I think I have mt-daapd setup correctly but iTunes 7 can’t see the share. From what I’ve read, iTunes 7 might be the problem. If so, stop me here! If not, here’s my setup:

    Server:

    Ubuntu Server Dapper Drake
    Most recent nightly build of mt-daapd (can see it and modify it in my browser. Says the server is running but that bonjour is not–I’ve read that this might be a bug. Configured correctly, as far as I know.)
    Firestarter firewall disabled (for now)
    Avahi daemon that seems to be running (might this conflict with pre-installed bonjour daemon?)

    Client:

    Powerbook G4 (10.4.8)
    iTunes 7.0.2
    Firewall disabled (for now)

    Please let me know if I’ve missed anything here. Thanks in advance for any and all help.

    Joe

    You should be able to configure with –enable-avahi to get it working with avahi, that would be better than using the built-in one.

    That should probably do it.

    #8622

    bbjonz
    Participant

    Thanks. I tried several different versions of installing with dpkg but none work with –enable-avahi. Could I trouble you for the complete installation statement?

    BTW, that’s 10.4.8–don’t know that face got there…

    Joe

    #8623

    rpedde
    Participant

    @bbjonz wrote:

    Thanks. I tried several different versions of installing with dpkg but none work with –enable-avahi. Could I trouble you for the complete installation statement?

    BTW, that’s 10.4.8–don’t know that face got there…

    Joe

    I don’t have binary packages for avahi and dapper. The packages that are installed with binaries are with the built-in mdns.

    But we can still probably make it work.

    one thing to check is that you didn’t upgrade from a 0.2.4 install to the nightlies. If so, you’ll need to fix your config file to make it pick up the output plugins.

    If your /etc/mt-daapd.conf looks like this:


    servername blah
    mp3_dir /path/to/somewhere

    Then you have the old config style. You should be able to convert that by doing this (as root):


    mt-daapd -v /etc/mt-daapd.conf

    That will convert your config from the old form to the new form. It will look something like this, then:


    [general]
    servername=blah
    mp3_dir=/path/to/blah

    Once it’s in a good form, then you can add a section that looks like this:


    [plugins]
    plugin_dir = /usr/share/mt-daapd/plugins

    Or wherever your plugins are. Check that directory, and look for an “out-daap.so” or a “rsp.so”. Just throw that whole section label and parameter at the bottom of the file (unless it already exists there).

    Then start the server. That’s one of the possible problems is that it isn’t loading the plugins, so it doesn’t bother advertising anything, since you don’t have a daap server or a rsp server running, so no point in advertising anything. :-/

    If that doesn’t go, or if everything was already set up okay, then the problem must be the mdns stepping on each other.

    You can change the startup script for mt-daapd to start with a “-m”, which turns off multcast. Then you can edit the avahi config file to advertise “_daap._tcp” on port 3689, and “_rsp._tcp” on port 3689 as well.

    Then you should be able to see it.

    I’m not sure how to manually advertise stuff with avahi, but I’m sure it’s possible.

    — Ron

    #8624

    bbjonz
    Participant

    Thanks for taking the time to respond. It looks like I have the old config file with the new nightly build. I tried to create the new version with the command you provided, but I got “error writing file.” Permissions seem fine and I was the root at the time, so I don’t know what went wrong. The plugins are where you said they’d be. I guess it’s that config file holding me up.

    Joe

    #8625

    bbjonz
    Participant

    I ran mt-daapd -f and got this:

    Firefly Version svn-1489: Starting with debuglevel 2
    Starting rendezvous daemon
    Starting signal handler
    Initializing database
    Starting web server from /usr/share/mt-daapd/admin-root on port 3689
    Listen port: Address already in use
    Error staring web server: Address already in use
    Aborting
    Rendezvous socket closed (daap server crashed?) Aborting.
    Aborting

    Looks like another service has that port locked up. What could it be?

    Joe

    #8626

    bbjonz
    Participant

    Thanks for your help. I had several mt-daapd processes running. Killed them all, restarted, and there it was. Absolutely beautiful!

    Joe

    #8627

    rpedde
    Participant

    @bbjonz wrote:

    Thanks for your help. I had several mt-daapd processes running. Killed them all, restarted, and there it was. Absolutely beautiful!

    Joe

    Whew. 🙂

    Glad you got it going.

    — Ron

Viewing 8 posts - 1 through 8 (of 8 total)

The forum ‘Setup Issues’ is closed to new topics and replies.