You are here: Home » Topic » How to stream or play mp4-videos with mt-daapd and itunes ?

How to stream or play mp4-videos with mt-daapd and itunes ?

FireFly Media Server (formerly mt-daapd) Firefly Media Server Forums Firefly Media Server General Discussion How to stream or play mp4-videos with mt-daapd and itunes ?

This topic contains 10 replies, has 3 voices, and was last updated by  Garibaldi 9 years, 10 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #1516

    Alhifi
    Participant

    Good morning!

    I have searched and read this forum up and down, but i am not sure about that what i have found:

    Can mt-daapd (Nighly Version 1519) stream videos?

    I have one for testing and it works fine if i import and play it with itunes. If i save this one in the folder with the mp3-files and do a scan, nothing happens. Then i added the extension .mp4 to the list behind the variable “extensions”, do another scan and it appears when i connect my itunes to mt-daapd … but it will not played in itunes.

    What must i do or configure that it works … if it is possible …

    Bye
    Alhifi

    BTW: Sorry for my bad english, it’s very early in the morning (here) and i am very tired after hours of testing that.

    #11464

    rpedde
    Participant

    @alhifi wrote:

    Good morning!

    I have searched and read this forum up and down, but i am not sure about that what i have found:

    Can mt-daapd (Nighly Version 1519) stream videos?

    I have one for testing and it works fine if i import and play it with itunes. If i save this one in the folder with the mp3-files and do a scan, nothing happens. Then i added the extension .mp4 to the list behind the variable “extensions”, do another scan and it appears when i connect my itunes to mt-daapd … but it will not played in itunes.

    What must i do or configure that it works … if it is possible …

    Bye
    Alhifi

    BTW: Sorry for my bad english, it’s very early in the morning (here) and i am very tired after hours of testing that.

    It should work. If you have iTunes 2Gb. Other than that, it should work though.

    I have found it works better with iTunes 7.2.

    — Ron

    #11465

    Alhifi
    Participant

    hi ron,

    thank you for your quick answer … but it doen’t really help.

    Now i’ve installed iTunes 7.3 as client to be sure that it works, you wrote, i need min. version 7.2. But the video is still shown in the songlist of iTunes, but when i want to start (and view) it, nothings happen. Have i somthing forgotten to config? i compiled my svn-1519 (for the art_filename-feature) only with –enable-sqlite3 and that was it. Have i to install more to get this work?

    my mt-daapd.conf is the following:

    [general]
    web_root = /usr/local/share/mt-daapd/admin-root
    port = 3689
    admin_pw = mypassword
    db_type = sqlite3
    db_parms = /usr/local/var/cache/mt-daapd
    mp3_dir = /SAN/MP3
    servername = Server (%v)
    runas = mt-daapd
    playlist = /usr/local/etc/mt-daapd.playlist
    #password = mp3
    extensions = .mp3,.m4a,.m4p,.mp4
    ssc_codectypes = ogg,flac,alac
    ssc_prog = /usr/local/bin/mt-daapd-ssc.sh
    logfile = /var/log/mt-daapd.log
    rescan_interval = 0
    # always_scan = 0
    # process_m3u = 0
    scan_type = 2
    #compress = 0
    art_filename = _folderOpenImage.jpg

    [plugins]
    plugin_dir = /usr/local/share/mt-daapd/plugins

    my testvideo is called “Zeitung.mp4”, stored in /SAN/MP3/Video and has the same access-rights in the filesystem like the other (working) MP3-Files. After a manual started scan mt-daapd recognize the file, the logfile-entry says

    2007-06-30 11:49:39 (bc9c1b6b): Scanned 95 songs (was 94) in 1 seconds

    I also tried

    ssc_codectypes = ogg,flac,alac,mp4a

    Is there something wrong … or am i only to stupid to unterstand what to do?

    Thank you very much …

    Bye
    Alhifi

    #11466

    Alhifi
    Participant

    No one any ideas?

    Bye
    Alhifi

    #11467

    rpedde
    Participant

    @alhifi wrote:

    No one any ideas?

    Bye
    Alhifi

    Sorry, was out of town.

    Try adding .mp4 to the extensions. Also, turn on your logfile in the web admin, and turn the debuglevel up to 9 and try to play it and see what errors the log file generates.

    What size is the file? Is it over 2G?

    #11468

    Alhifi
    Participant

    Hi Ron,

    look above, i’ve already add .mp4 to the extensions, didn’t work.

    The file-size is 5 MB.

    With these settings above i have no entry in the logfile, i will try to set the debug level higher, but how?

    mt-daapd.conf:

    debuglevel = 9

    ?

    Bye
    Alhifi

    #11469

    rpedde
    Participant

    @alhifi wrote:

    Hi Ron,

    look above, i’ve already add .mp4 to the extensions, didn’t work.

    The file-size is 5 MB.

    With these settings above i have no entry in the logfile, i will try to set the debug level higher, but how?

    mt-daapd.conf:

    debuglevel = 9

    ?

    Bye
    Alhifi

    You also need “logfile” to set your logfile. If you aren’t getting a logfile with those set, then you either aren’t reading that configuration (but a different one), or you aren’t running the version you think you are (like maybe an older version is in a different path).

    What does your web admin page say the version is? And what does the config page say your config file is?

    #11470

    Alhifi
    Participant

    Hi Ron,

    here are the results:

    server:/var/log # ps -ef | grep daapd
    mt-daapd 9161 1 0 00:20 pts/0 00:00:00 /usr/local/sbin/mt-daapd -c /etc/mt-daapd.conf -d 1
    mt-daapd 9162 1 0 00:20 pts/0 00:00:00 /usr/local/sbin/mt-daapd -c /etc/mt-daapd.conf -d 1

    After the test i switched back to Loglevel 0 which is shown above … the configuration-file is correct and the content posted above in an erlier reply of mine.

    Logfile:

    2007-07-04 00:00:17 (0f68c66f): Session 0: Streaming file ‘Zeitung.mp4’ to 192.168.0.2 (offset 0)
    2007-07-04 00:00:17 (0f68c66f): Write error: Connection reset by peer
    2007-07-04 00:00:17 (0f68c66f): Finished streaming file to remote: 20480 bytes

    Version shown in the administration-web-interface is “svn-1519” and also correct.

    The complete logfile until my test to view file “Zeitung.mp4” is about 160 kB and to big to post here, if you want, i can mail it to you.

    Bye
    Alhifi

    #11471

    rpedde
    Participant

    @alhifi wrote:

    Hi Ron,

    here are the results:

    server:/var/log # ps -ef | grep daapd
    mt-daapd 9161 1 0 00:20 pts/0 00:00:00 /usr/local/sbin/mt-daapd -c /etc/mt-daapd.conf -d 1
    mt-daapd 9162 1 0 00:20 pts/0 00:00:00 /usr/local/sbin/mt-daapd -c /etc/mt-daapd.conf -d 1

    After the test i switched back to Loglevel 0 which is shown above … the configuration-file is correct and the content posted above in an erlier reply of mine.

    Logfile:

    2007-07-04 00:00:17 (0f68c66f): Session 0: Streaming file ‘Zeitung.mp4’ to 192.168.0.2 (offset 0)
    2007-07-04 00:00:17 (0f68c66f): Write error: Connection reset by peer
    2007-07-04 00:00:17 (0f68c66f): Finished streaming file to remote: 20480 bytes

    Version shown in the administration-web-interface is “svn-1519” and also correct.

    The complete logfile until my test to view file “Zeitung.mp4” is about 160 kB and to big to post here, if you want, i can mail it to you.

    Bye
    Alhifi

    You can mail it to me at [email protected]

    #11472

    Anonymous

    I know I’m resurrecting an old thread, but I’ve got the same question now.

    I added .mp4 to the extensions list, and I see the .mp4 files in my iTunes, and I can even play them. But there’s no video, they just play as audio. Get info in iTunes shows them as .mp4, but there’s no video when I play, no matter what I try. It’s very odd, any ideas?

    #11473

    Garibaldi

    Hi,

    same problem here. I have a mp4 video file. If I tray to play it I only get sound. To get the Video I have to klick on the place where the cover art is supposed to be. But this seems to be extremly buggy. I can’t go into fullscreen for example. However, the same video file on another ITunes is served well and as expected. What am I doing wrong?

    Thank you.

    Regards,
    Garibaldi.

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.