You are here: Home » Topic » Getting error -39

Getting error -39

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #2522
    Anonymous
    Inactive

    I am using Windows Home Server with FireFly media server. I have 4 computers in the house. Three of them work flawlessly with FMS. The last one does not. When I try to access Firefly in Itunes I get error:

    The shared library “Firefly” is not responding (-39)
    Check that any firewall software running on either the shared computer or this computer has been set to allow communication on port 9999

    I can see the shared folders on the WHS. I have a ‘green’ connection to the WHS. I am using Norton but I disabled and it still does not work. Windows firewall is off.

    Firefly installed on Windows Media Server
    Firefly version: Firefly Service 1.0 svn-1696
    Shared computer that is not working: Vista Ultimate
    Tried with wireless and wired

    I am not a newbie but either I am missing something stupid or something is truly wrong.

    Please help.

    #17304
    Anonymous
    Inactive

    I want to add a few notes…
    – On the computer that does not work, I can get see Firefly in Itunes but get the error when I click on Firefly
    – All the other computers see Firefly and load the songs when clicked
    – On the computer that does not work, I can get to the config page for Firefly on port 9999 (i.e. http://192.168.1.77:9999/index.html) – even when the Norton firewall is active

    I’d love some help as I ripped a bunch of CDs and want to add them to my kids Ipods before a trip later this week.

    Thanks in advance.

    #17305
    Anonymous
    Inactive

    Nobody? Bummer.

    I reinstalled Bonjour on the server. I removed and reinstalled Firefly 1586. Still not working.

    Anyone have any suggestions?

    #17306
    Anonymous
    Inactive

    Okay, I have ignored this issue for quite a long time. Today, I tried again. I noticed an important piece of information…

    There are two accounts on this computer. The administrator account and a standard user account. This is a Vista computer.

    – The administrator account works!!
    – The standard user account does not work BUT if I change to a administrator, it works.

    So, is there a way to make Firefly work when the account is a ‘Standard User’

    #17307
    stretch
    Participant

    lets see if I’m reading this correctly…

    Firefly on server runs fine and 3 other computers (presumably something other than Vista) can happily connect to it.
    4th PC running Vista can’t connect unless you log in as an administrator.

    If I got that correct then it sound like you have to check the network access privileges for the general user account on the Vista box.
    I’m not familiar with Vista so i can’t help you with specifics.
    XP has a “Power User” access level. Does Vista also have this & can you access Firefly as a power user?

    #17308
    EVILRipper
    Participant

    This is an issue which has occurred before.
    IIRC there was a simple option to tick to fix this.

    A quick search on the forums doesn’t get my any results I wanted.
    I believe it was something about users in vista, restricted to ask the user before allowing network access. However, firefly did not support this prompting for access, which caused it to fail.

    I do know of one option in Control Panel -> Users that turns off all warning messages before opening a program. Maybe that option is the one causing trouble.

Viewing 6 posts - 1 through 6 (of 6 total)
  • The forum ‘Setup Issues’ is closed to new topics and replies.