You are here: Home » Topic » Gentoo nightlies ebuild

Gentoo nightlies ebuild

This topic contains 4 replies, has 2 voices, and was last updated by  uncleremus 10 years, 4 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #1317

    uncleremus
    Participant

    Anyone who has an ebuild/overlay for mt-daapd nightlies?

    I think I need to run a later package than the latest unstable in portage to get mt-daapd to run with the Roku Soundbridge, that’s why I’m asking. It is called “pre1376” so I guess it is quite old.

    #10310

    rpedde
    Participant

    @uncleremus wrote:

    Anyone who has an ebuild/overlay for mt-daapd nightlies?

    I think I need to run a later package than the latest unstable in portage to get mt-daapd to run with the Roku Soundbridge, that’s why I’m asking. It is called “pre1376” so I guess it is quite old.

    1376 will run with the soundbridge.

    You should be able to use the same ebuild you were using before, only updated for latest version — change the download path, etc.

    Guess this is what happens when Diego leaves.

    — Ron

    #10311

    uncleremus
    Participant

    @rpedde wrote:

    @uncleremus wrote:

    Anyone who has an ebuild/overlay for mt-daapd nightlies?

    I think I need to run a later package than the latest unstable in portage to get mt-daapd to run with the Roku Soundbridge, that’s why I’m asking. It is called “pre1376” so I guess it is quite old.

    1376 will run with the soundbridge.

    You should be able to use the same ebuild you were using before, only updated for latest version — change the download path, etc.

    Guess this is what happens when Diego leaves.

    — Ron

    Thanks a lot for your input. If I can harass you just a little bit more, Gentoo has their USE-flags as you probably know. For this particular package they are

      howl vorbis avahi sqlite3 flac ffmpeg

    Do you have any idea which I should use? I have tried some permutations, but when I have “howl” I get “incompatible servers” on my Soundbridge and when I use “avahi” (first I must uninstall howl) and then I have trouble starting everything (I guess I can resolve the latter issue, but since I didn’t know if this was the real cause yesterday I didn’t pursue this line).

    My setup is now
    Enabled:

      howl sqlite3 flac ffmpeg

    Disabled:

      vorbis avahi

    Oh, and I may also add that the server is wired. I can try the same configuration on another WiFi’d machine. Also I’ve got everything working on my NSLU2, but I was thinking of moving firefly to a more capable machine to speed up matters.

    (Last, but not least: Thanks for your wonderful program.)

    EDIT: Thought that I might add that I see this in the build output with the above USE-flags:

    ./configure --prefix=/usr --host=i686-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --disable-oggvorbis --enable-flac --disable-sqlite --enable-sqlite3 --enable-ffmpeg --with-ffmpeg-includes=/usr/include/ffmpeg --enable-howl --with-howl-libs=/usr/lib --with-howl-includes=/usr/include/howl --build=i686-pc-linux-gnu
    #10312

    uncleremus
    Participant

    OK, after trying awhile with avahi and howl to no success, I decided to let the gentoo ebuild take the latest nightlie 1549. Suddenly, the server came up on my Soundbridge! So, I was very happy with that. But, then came new trouble, but I have a feeling it is easier to resolve. The trouble now is that firefly only want to stream my mp3’s and not my flac’s. I can see in the log that it is missing some plugins

    2007-04-21 22:53:09 (b73998c0): Got shutdown signal.
    2007-04-21 22:53:09 (b73998c0): Stopping gracefully
    2007-04-21 22:53:09 (b73998c0): Stopping rendezvous daemon
    2007-04-21 22:53:09 (b73998c0): Callback: Memory Free
    2007-04-21 22:53:09 (b73998c0): Callback: Memory Free
    2007-04-21 22:53:09 (b73998c0): Callback: Memory Free
    2007-04-21 22:53:09 (b73998c0): Closing database
    2007-04-21 22:53:09 (b73998c0): Done!
    2007-04-21 22:53:09 (b735d8c0): Firefly Version svn-1549: Starting with debuglevel 2
    2007-04-21 22:53:09 (b735d8c0): Error opening plugin dir /usr/lib/firefly. Ignoring
    2007-04-21 22:53:09 (b735d8c0): Error opening plugin dir /usr/lib/mt-daapd. Ignoring
    2007-04-21 22:53:09 (b735d8c0): Error opening plugin dir /usr/share/firefly/plugins. Ignoring
    2007-04-21 22:53:09 (b735d8c0): Plugin loaded: rsp/svn-1549
    2007-04-21 22:53:09 (b735d8c0): Plugin loaded: ssc-script/svn-1549
    2007-04-21 22:53:09 (b735d8c0): Plugin loaded: daap/svn-1549
    2007-04-21 22:53:09 (b735d8c0): Plugin loaded: ssc-ffmpeg/svn-1549
    2007-04-21 22:53:09 (b735d8c0): Starting rendezvous daemon

    This results in mp3’s playing fine, but when I play my flac-files says “unable to play” on the Soundbridge and in the logs something like

    2007-04-21 22:08:58 (b6b9ab90): Session 0: Streaming file 'fratres_for_violin_strings_and_percussion.flac' to 192.168.0.100 (offset 0)
    2007-04-21 22:08:58 (b73e58c0): Got CLD signal. Reaping

    Can I create the directories firefly wants and links to flac or something like that?

    #10313

    uncleremus
    Participant

    Finally got that working as well, I specified the correct plugin directory and also the ssc_script was pointing to the wrong location

    #ssc_prog = /etc/mt-daapd-ssc-script
    ssc_prog = /usr/bin/mt-daapd-ssc.sh

    Now I can play my .flac-files also. 😀

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.