You are here: Home » Topic » FreeBSD issues i.c.m. Firefly

FreeBSD issues i.c.m. Firefly

This topic contains 7 replies, has 5 voices, and was last updated by  Anonymous 7 years, 4 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #2845

    Anonymous

    Hello, i’ve installed the new firefly port on freebsd but i only experience problems ๐Ÿ™
    This is some info:

    [[email protected] /usr/home/bram]# pkg_version -v | grep firefly
    firefly-1696_1 = up-to-date with port

    [[email protected] /usr/local/var/cache/mt-daapd]# uname -a
    FreeBSD nas.telenet.be 7.0-RELEASE-p4 FreeBSD 7.0-RELEASE-p4 #0: Sat Nov 15 12:48:01 CET 2008 :/data/usr/obj/data/usr/src/sys/GENERIC amd64

    Server hardware:

      4 x 500GB Samsung Spinpoint T166 with ZFS filesystem (for my data + music for firefly)
      AMD 3800+
      1GB DDR2 @ 666MHz
      CF-card for booting the OS ( this is where the port is installed)
      Intel Gigabit PRO nic

    But the hardware hasn’t been a problem in the past so this would really surprise me that this is hardware related ๐Ÿ˜›

    Client devices:

      Vista Business 64 bit with Itunes
      XP Pro with itunes
      Ubuntu 8.10 64bit and 32 bit with Banshee and Rhythmbox

    Connections:
    Wireless and Ethernet

    Log’s:
    This is my log file for a small library and a fresh database:
    http://pastebin.com/m734ba8b5
    I did this because if i haven’t got a new database it said:

    2009-01-03 19:26:45 (db3f1ccf): Initializing database
    2009-01-03 19:26:45 (db3f1ccf): Executing: select count(*) FROM songs
    2009-01-03 19:26:45 (db3f1ccf): Executing: select value from config where term='rescan'
    2009-01-03 19:26:45 (db3f1ccf): Executing: vacuum
    2009-01-03 19:27:51 (db3f1ccf): Rows: 0
    2009-01-03 19:27:51 (db3f1ccf): Executing: create index idx_path on songs(path,idx)
    2009-01-03 19:27:51 (db3f1ccf): Query: create index idx_path on songs(path,idx)
    2009-01-03 19:27:51 (db3f1ccf): Error: index idx_path already exists
    2009-01-03 19:27:51 (db3f1ccf): Executing: create index idx_songid on playlistitems(songid)
    2009-01-03 19:27:51 (db3f1ccf): Query: create index idx_songid on playlistitems(songid)
    2009-01-03 19:27:51 (db3f1ccf): Error: index idx_songid already exists
    2009-01-03 19:27:51 (db3f1ccf): Executing: create index idx_playlistid on playlistitems(playlistid,songid)
    2009-01-03 19:27:51 (db3f1ccf): Query: create index idx_playlistid on playlistitems(playlistid,songid)
    2009-01-03 19:27:51 (db3f1ccf): Error: index idx_playlistid already exists
    2009-01-03 19:27:51 (db3f1ccf): Executing: select count(*) FROM songs

    But apparently that’s normal?

    config file:
    http://pastebin.com/m60b7eee0

    Now what’s the problem exactly?
    Well, when i start the deamon everything looks fine in the log (?) so i go on the web page of the deamon. That i can read this:

    Service  	Status  	Control
    Bonjour Stopped
    Firefly Media Server Running
    File scanner Idle


    Plugin Version
    ssc-script svn-1696
    rsp svn-1696
    daap svn-1696

    Uptime 58 minutes, 2 seconds
    Songs 58
    Songs Served 0
    DB Version 2

    Client IP Action
    192.168.0.2 Serving xml-rpc method

    So he doesn’t serve songs he saids, while in the logs there is this:
    2009-01-05 19:00:59 (db3f1ccf): Serving 58 songs. Startup complete in 7 seconds
    That’s already very weird. Also not one single client can see the daap share. While when trying the deamon for windows all client detect the daap share without a problem, so my network isn’t the problem.
    Are there any thoughts? I’m really desperate ๐Ÿ™

    #18335

    Anonymous

    really nobody who has an idea?

    #18336

    stretch
    Participant

    I’m no expert but I suspect it’s an mDNS problem.

    Are you using avahi / howl / something else?
    What ever you’re using, check the settings, check that it’s working & not conflicting with something else.

    #18337

    Anonymous

    These ports are installed on my system:

    [[email protected] /usr/home/bram]# pkg_version -v
    ataidle-2.4 = up-to-date with port
    autoconf-2.62 = up-to-date with port
    autoconf-wrapper-20071109 = up-to-date with port
    automake-1.9.6_3 = up-to-date with port
    automake-wrapper-20071109 = up-to-date with port
    bash-3.2.39_1 = up-to-date with port
    bigreqsproto-1.0.2 = up-to-date with port
    cups-base-1.3.8_1 < needs updating (port has 1.3.9_2)
    curl-7.18.0 = up-to-date with port
    db41-4.1.25_4 = up-to-date with port
    dbus-1.2.1 = up-to-date with port
    dbus-glib-0.76 = up-to-date with port
    expat-2.0.1 = up-to-date with port
    firefly-1696_1 = up-to-date with port
    flac-1.2.1 = up-to-date with port
    gamin-0.1.9_2 = up-to-date with port
    gdbm-1.8.3_3 = up-to-date with port
    gettext-0.17_1 = up-to-date with port
    gio-fam-backend-2.16.5 = up-to-date with port
    glib-2.16.5 < needs updating (port has 2.16.5_1)
    gmake-3.81_3 = up-to-date with port
    gnome_subr-1.0 = up-to-date with port
    gnutls-2.4.1_1 < needs updating (port has 2.4.2_1)
    help2man-1.36.4_2 = up-to-date with port
    inputproto-1.4.2.1 = up-to-date with port
    intltool-0.37.1 = up-to-date with port
    jpeg-6b_7 = up-to-date with port
    kbproto-1.0.3 = up-to-date with port
    libX11-1.1.3_1,1 = up-to-date with port
    libXau-1.0.3_2 = up-to-date with port
    libXdmcp-1.0.2_1 = up-to-date with port
    libao-0.8.8_1 = up-to-date with port
    libdaemon-0.12 = up-to-date with port
    libexecinfo-1.1_2 < needs updating (port has 1.1_3)
    libgcrypt-1.4.1_1 = up-to-date with port
    libgpg-error-1.6_1 = up-to-date with port
    libiconv-1.11_1 = up-to-date with port
    libid3tag-0.15.1b = up-to-date with port
    libogg-1.1.3,4 = up-to-date with port
    libtool-1.5.26 = up-to-date with port
    libvorbis-1.2.0_2,3 = up-to-date with port
    libxml2-2.6.32 < needs updating (port has 2.6.32_2)
    m4-1.4.11,1 = up-to-date with port
    openldap-client-2.3.43 = up-to-date with port
    p5-XML-Parser-2.36 = up-to-date with port
    p5-gettext-1.05_2 = up-to-date with port
    pcre-7.7_1 < needs updating (port has 7.8)
    perl-5.8.8_1 = up-to-date with port
    pkg-config-0.23_1 = up-to-date with port
    png-1.2.31 < needs updating (port has 1.2.33)
    popt-1.7_5 = up-to-date with port
    portupgrade-2.4.6,2 = up-to-date with port
    python25-2.5.2_3 = up-to-date with port
    ruby-1.8.6.287,1 = up-to-date with port
    ruby18-bdb-0.6.4 = up-to-date with port
    samba-3.0.32_1,1 < needs updating (port has 3.0.32_2,1)
    screen-4.0.3_5 = up-to-date with port
    smartmontools-5.38 < needs updating (port has 5.38_2)
    speex-1.2.r1_1,1 = up-to-date with port
    sqlite3-3.6.4 = up-to-date with port
    tiff-3.8.2_1 < needs updating (port has 3.8.2_2)
    transmission-daemon-1.33 < needs updating (port has 1.42)
    transmission-web-1.33 < needs updating (port has 1.42)
    vorbis-tools-1.2.0_3,3 = up-to-date with port
    xcmiscproto-1.1.2 = up-to-date with port
    xextproto-7.0.2 = up-to-date with port
    xf86bigfontproto-1.1.2 = up-to-date with port
    xproto-7.0.10_1 = up-to-date with port
    xtrans-1.0.4 = up-to-date with port

    as you can see no howl/avahi is on it…The only extra port i’ve installed is transmission, but i don’t see why that would conflict with something else…
    are there any more things i can do to check were the problem is?

    #18338

    peter_ljung
    Participant

    Topic on installation on OpenBSD might help …
    http://forum.fireflymediaserver.org/viewtopic.php?f=3&t=7802&start=0#p20206
    Howl is used in this configuration.

    #18339

    Anonymous

    There is allmost certainly nothing wrong with the Firefly installation.

    There is however a bug in the em driver ( the driver used for the Intel NIC’s ) in version 7.0 of Freebsd. Which causes corruption of UDP packets ( used by Bonjour/mDNS ) if checksum offloading is enabled ( this is the default ).

    Solution is to disable checksum offloading for your network interface.

    To disable checksum offloading type the following command :

    ifconfig em0 -rxcsum -txcsum

    as root

    To disable checksum offloading on the next reboot add -rxcsum -txcsum to the ifconfig_em0 line in /etc/rc.conf

    I had the same problem when I updated my server form version 6.3 to 7.0.

    You can also update to version 7.1 which doesn’t have this bug

    #18340

    Anonymous

    HansS, you’re my hero!
    I would never have figured this out myself…
    thank you very much! Now my server is working :)??finally.

    #18341

    Anonymous

    @HansS wrote:

    There is allmost certainly nothing wrong with the Firefly installation.

    There is however a bug in the em driver ( the driver used for the Intel NIC’s ) in version 7.0 of Freebsd. Which causes corruption of UDP packets ( used by Bonjour/mDNS ) if checksum offloading is enabled ( this is the default ).

    Solution is to disable checksum offloading for your network interface.

    To disable checksum offloading type the following command :

    ifconfig em0 -rxcsum -txcsum

    as root

    To disable checksum offloading on the next reboot add -rxcsum -txcsum to the ifconfig_em0 line in /etc/rc.conf

    I had the same problem when I updated my server form version 6.3 to 7.0.

    You can also update to version 7.1 which doesn’t have this bug

    It seems the em driver in FreeBSD 8.0-STABLE has the same or similar problems. My firefly-svn-1696 fails miserably due to unknown (network) reasons.
    Having disabled checksum offloading things seem to work properly. See how long this lasts 8)

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.