You are here: Home » Topic » FreeBSD 7.0 Set up Question

FreeBSD 7.0 Set up Question

This topic contains 1 reply, has 2 voices, and was last updated by  rpedde 9 years, 7 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #2380

    joedunn
    Participant

    Hi all,

    I know this is dumb but I can’t figure it out. I am running FreeBSD 7 amd64 edition. I have mt-daapd-0.2.4.1 installed from ports. I also have mdns/mDNSResponder installed.

    All services are up, I see the following in the logs

    2008-04-15 22:53:41: Starting rendezvous daemon
    2008-04-15 22:53:41: Current database version: 8
    2008-04-15 22:53:41: Starting signal handler
    2008-04-15 22:53:42: Loading playlists
    2008-04-15 22:53:42: Initializing database
    2008-04-15 22:53:43: Starting mp3 scan
    2008-04-15 22:53:45: Starting web server from /usr/local/share/mt-daapd/admin-root on port 3689
    2008-04-15 22:53:45: Registering rendezvous names
    2008-04-15 22:53:45: Scanned 15860 songs in 4 seconds

    When I check on the local host (the FreeBSD server) I see the daapd share

    [[email protected] /usr/ports/audio/mt-daapd]# mDNSBrowse _daap._tcp
    browse reply: Add Service 0x2 ZFS Music Server _daap._tcp. local.
    browse reply: Add Service 0x2 OtherMusicServer_
    PW _daap._tcp. local.
    resolve reply: 0x2 ZFS Music Server _daap._tcp. local. 192.168.1.250 3689

    But when I check via macs on the network I get the following:

    mDNS -B _daap._tcp
    Browsing for _daap._tcp
    Talking to DNS SD Daemon at Mach port 4099
    Timestamp A/R Flags Domain Service Type Instance Name
    23:09:17.704 Add 0 local. _daap._tcp. OtherMusicServer_PW
    ^C

    The network card on the FreeBSD server is set to multicast and even put it in promiscuous mode and that made no difference. Below is the output of the ifconfig

    [[email protected] /usr/ports/audio/mt-daapd]# ifconfig em0
    em0: flags=8843 metric 0 mtu 1500
    options=9b
    ether 00:0e:0c:5a:64:0e
    inet 192.168.1.250 netmask 0xffffff00 broadcast 192.168.1.255
    media: Ethernet autoselect (1000baseTX )
    status: active

    The only other thing i see is there is two instances of mt-daapd, but that happens via the start up script so i am assuming that is normal

    Thanks for any help

    Joe

    #16835

    rpedde
    Participant

    @joedunn wrote:

    Hi all,

    I know this is dumb but I can’t figure it out. I am running FreeBSD 7 amd64 edition. I have mt-daapd-0.2.4.1 installed from ports. I also have mdns/mDNSResponder installed.

    All services are up, I see the following in the logs

    2008-04-15 22:53:41: Starting rendezvous daemon
    2008-04-15 22:53:41: Current database version: 8
    2008-04-15 22:53:41: Starting signal handler
    2008-04-15 22:53:42: Loading playlists
    2008-04-15 22:53:42: Initializing database
    2008-04-15 22:53:43: Starting mp3 scan
    2008-04-15 22:53:45: Starting web server from /usr/local/share/mt-daapd/admin-root on port 3689
    2008-04-15 22:53:45: Registering rendezvous names
    2008-04-15 22:53:45: Scanned 15860 songs in 4 seconds

    When I check on the local host (the FreeBSD server) I see the daapd share

    [[email protected] /usr/ports/audio/mt-daapd]# mDNSBrowse _daap._tcp
    browse reply: Add Service 0x2 ZFS Music Server _daap._tcp. local.
    browse reply: Add Service 0x2 OtherMusicServer_
    PW _daap._tcp. local.
    resolve reply: 0x2 ZFS Music Server _daap._tcp. local. 192.168.1.250 3689

    But when I check via macs on the network I get the following:

    mDNS -B _daap._tcp
    Browsing for _daap._tcp
    Talking to DNS SD Daemon at Mach port 4099
    Timestamp A/R Flags Domain Service Type Instance Name
    23:09:17.704 Add 0 local. _daap._tcp. OtherMusicServer_PW
    ^C

    The network card on the FreeBSD server is set to multicast and even put it in promiscuous mode and that made no difference. Below is the output of the ifconfig

    [[email protected] /usr/ports/audio/mt-daapd]# ifconfig em0
    em0: flags=8843 metric 0 mtu 1500
    options=9b
    ether 00:0e:0c:5a:64:0e
    inet 192.168.1.250 netmask 0xffffff00 broadcast 192.168.1.255
    media: Ethernet autoselect (1000baseTX )
    status: active

    The only other thing i see is there is two instances of mt-daapd, but that happens via the start up script so i am assuming that is normal

    Thanks for any help

    Joe

    Haven’t had any success reports on fbsd 7 (or patches either, for that matter). Best fix I’ve seen is to install avahi and configure with –enable-avahi.

    – Ron

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.