You are here: Home » Topic » Flrefly with media library on a CIFS mount

Flrefly with media library on a CIFS mount

This topic contains 2 replies, has 2 voices, and was last updated by  OCedHrt 8 years, 9 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #2821

    OCedHrt
    Participant

    In the mt-daapd.conf, the comments indicate that the music files have to be on an actual linux fs that is not over a network. But then I read a thread somewhere that said that was no longer the case. So I went ahead a tried it.

    What I have right now is:
    Turnkey Linux LAMP running in a VirtualBox VM with a CIFS mount to the shared folder on the host Vista PC.

    Firefly can build the library correctly, and read all the tags. But I am unable to get anything to play back with either the Firefly Java Client, Fireplay, the bundled demo Java applet, or the Crossfire web client.
    I have tried with ffmpeg enabled and disabled and mp3 set on the never transcode list.

    So only thing I can think of now is, the music files have to be local?

    #18266

    fizze
    Participant

    No, if firefly can scan them then it can also play them back.
    Do you try to play them back inside the virtual machine using banshee or amarok…?

    If that works chances are your guest to host communication is flawed.

    #18267

    OCedHrt
    Participant

    That’s good to know. It might have been something to do with enabling the non case sensitive option.

    I switched to using VirtualBox shares and I still had problems. The log will show errors like the following:

    2008-12-14 08:23:35 (b7484b90): Thread 1921: Error opening /MNT/SHARE/AUDIO/CHINESE/4 IN LOVE/FALL IN LOVE/FALL IN LOVE - 02 - 4 IN LOVE - ä½ ä¼æ³.MP3: No such file or directory
    2008-12-14 08:26:56 (b7484b90): Thread 2107: Error opening /MNT/SHARE/AUDIO/CHINESE/3T/TEST.MP3: No such file or directory

    Two things about this:
    1. VirtualBos shares are case sensitive, so that could be the reason. I turned off non-case sensitive and it is working now. (But still can’t get Crossfire to work, but FirePlay does for MP3 :)).
    2. CIFS mount was not case sensitive, which is why I checked it. But it didn’t work. Maybe it would have worked with it unchecked.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.