You are here: Home » Topic » FLAC transcoding on NSLU2 ?

FLAC transcoding on NSLU2 ?

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #284
    hpsenicka
    Participant

    My NSLU2 is now working famously serving up streams using MP3 and WAV files. So far I haven’t had a lot of success with FLAC or other formats..

    I did notice that the NSLU2 shows up as 2 distinct services on my Roku SoundBridge… the default NSLU2 as well as the rsp version. Am I correct in assuming that 2 different daemons are running here?

    Do they share a common mt-daapd config file, or are the configurations managed seperately?

    My goal is to be able to use the NSLU2 to serve up FLAC files to the Roku, to maintain the highest audio fidelity possible.

    #4549
    rpedde
    Participant

    @hpsenicka wrote:

    My NSLU2 is now working famously serving up streams using MP3 and WAV files. So far I haven’t had a lot of success with FLAC or other formats..

    I did notice that the NSLU2 shows up as 2 distinct services on my Roku SoundBridge… the default NSLU2 as well as the rsp version. Am I correct in assuming that 2 different daemons are running here?

    Do they share a common mt-daapd config file, or are the configurations managed seperately?

    My goal is to be able to use the NSLU2 to serve up FLAC files to the Roku, to maintain the highest audio fidelity possible.

    Nope, same daemon, two ways to talk to it. Maybe at some point there will be others — upnp, etc.

    But they are the same daemon, so yes, they share the same config.

    As far as flac on the nslu2, you should be able to just add the .flac extension to your “extensions” entries in the config file (/opt/mt-daapd/mt-daapd.conf), and add “flac” to the ssc_codectypes.

    That should really be it.

    — Ron

    #4550
    hpsenicka
    Participant

    Well I seem to be successful playing FLAC through the regular mt-daapd service, but the RSP version doesn’t play them.

    The FLAC songs are browsable, but the titles are prefixed with an X on the Roku display.

    Is this a limitation of the RSP version, or do I still have something set up wrong?

    #4551
    fizze
    Participant

    the RSP version doesnt to transcoding (yet). 😉

    #4552
    rpedde
    Participant

    @fizze wrote:

    the RSP version doesnt to transcoding (yet). 😉

    Oh yeah… sorry… that’s in svn. I was hoping to get win32 transcoding done. If I don’t tonight, then I’ll drop whats in svn now, which includes script-based transcoding for rsp.

    — Ron

Viewing 5 posts - 1 through 5 (of 5 total)
  • The forum ‘Setup Issues’ is closed to new topics and replies.