You are here: Home » Topic » flac playback with 1696 – what did I do wrong?

flac playback with 1696 – what did I do wrong?

FireFly Media Server (formerly mt-daapd) Firefly Media Server Forums Firefly Media Server Setup Issues flac playback with 1696 – what did I do wrong?

This topic contains 3 replies, has 2 voices, and was last updated by  Anonymous 9 years, 9 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #2074

    Anonymous

    Hi,

    I’ve build and installed the latest nightly, which was fun as it’s the first time I’ve done that on Ubuntu 🙂

    Now I’m having a little trouble with flac playback.

    Here is an excerpt from the logfile:

    2007-12-28 16:57:04 (b6cb9b90): Executing: select * from songs where id=5861
    2007-12-28 16:57:04 (b6cb9b90): Creating new db handle
    2007-12-28 16:57:04 (b6cb9b90): Opening file:///media/raid/audio/rs500-flac/401-500/499+-+Thin+Lizzy+-+The+Boys+Are+Back+In+Town+(1976).flac
    2007-12-28 16:57:04 (b6cb9b90): Checking handler for file
    2007-12-28 16:57:04 (b6cb9b90): opening /media/raid/audio/rs500-flac/401-500/499 – Thin Lizzy – The Boys Are Back In Town (1976).flac
    2007-12-28 16:57:04 (b6cb9b90): Thread 1: Length of file (remaining): 30061070
    2007-12-28 16:57:04 (b6cb9b90): Updating Content-Type from application/x-dmap-tagged to audio/flac
    2007-12-28 16:57:04 (b6cb9b90): Added *Content-Length=30061070*
    2007-12-28 16:57:04 (b6cb9b90): Updating Connection from close to Close
    2007-12-28 16:57:04 (b6cb9b90): Emitting reponse header Content-Length: 30061070
    2007-12-28 16:57:04 (b6cb9b90): Emitting reponse header Expires: -1
    2007-12-28 16:57:04 (b6cb9b90): Emitting reponse header Cache-Control: no-cache
    2007-12-28 16:57:04 (b6cb9b90): Emitting reponse header DAAP-Server: firefly/svn-1696
    2007-12-28 16:57:04 (b6cb9b90): Emitting reponse header Accept-Ranges: bytes
    2007-12-28 16:57:04 (b6cb9b90): Emitting reponse header Content-Language: en_us
    2007-12-28 16:57:04 (b6cb9b90): Emitting reponse header Content-Type: audio/flac
    2007-12-28 16:57:04 (b6cb9b90): Emitting reponse header Server: mt-daapd/svn-1696
    2007-12-28 16:57:04 (b6cb9b90): Emitting reponse header Connection: Close
    2007-12-28 16:57:04 (b6cb9b90): Emitting reponse header Date: Fri, 28 Dec 2007 16:57:04 GMT
    2007-12-28 16:57:04 (b6cb9b90): Entering config_set_status
    2007-12-28 16:57:04 (b6cb9b90): Exiting config_set_status
    2007-12-28 16:57:04 (b6cb9b90): Session 0: Streaming file ‘499 – Thin Lizzy – The Boys Are Back In Town (1976).flac’ to 192.168.0.6 (offset 0)
    2007-12-28 16:57:04 (b6cb9b90): Write error: Connection reset by peer
    2007-12-28 16:57:04 (b6cb9b90): Error copying file to remote…

    2007-12-28 16:57:04 (b6cb9b90): Entering config_set_status
    2007-12-28 16:57:04 (b6cb9b90): Exiting config_set_status
    2007-12-28 16:57:04 (b6cb9b90): Thread 1: Terminating
    2007-12-28 16:57:04 (b6cb9b90): Thread 1: Freeing request headers
    2007-12-28 16:57:04 (b6cb9b90): Thread 1: Freeing response headers
    2007-12-28 16:57:04 (b6cb9b90): Thread 1: Freeing request vars
    2007-12-28 16:57:04 (b6cb9b90): Thread 1: Closing fd
    2007-12-28 16:57:04 (b6cb9b90): With thread 1 exiting, 1 are still running

    Can anyone help me get the flac working?

    As I understand 1696 supports transcoding, so it should be OK!

    Thanks,

    Lou

    #15423

    Anonymous

    @LouO wrote:

    Hi,

    I’ve build and installed the latest nightly, which was fun as it’s the first time I’ve done that on Ubuntu 🙂

    Now I’m having a little trouble with flac playback.

    I just had a nose around and I think I should have used the –enable-flac option when running ./configure

    Will start the build again and see what goes on!

    L

    #15424

    rpedde
    Participant

    @LouO wrote:

    @LouO wrote:

    Hi,

    I’ve build and installed the latest nightly, which was fun as it’s the first time I’ve done that on Ubuntu 🙂

    Now I’m having a little trouble with flac playback.

    I just had a nose around and I think I should have used the –enable-flac option when running ./configure

    Will start the build again and see what goes on!

    L

    Also you’ll need to flac executable for transcoding. I believe that’s the “flac” package in ubuntu.

    — Ron

    #15425

    Anonymous

    @rpedde wrote:

    Also you’ll need to flac executable for transcoding. I believe that’s the “flac” package in ubuntu.

    — Ron

    Many thanks.

    The final straw that got the whole thing working was installing the ffmpeg libs.

    There are a couple of versions of the libflac on Ubuntu, I removed one and installed the more recent, don’t know if that helped but it’s all working now!

    Cheers,

    L

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.