You are here: Home » Topic » flac [email protected] OS Xpage 2

flac [email protected] OS X

This topic contains 23 replies, has 4 voices, and was last updated by  colleenex 9 years, 3 months ago.

Viewing 9 posts - 16 through 24 (of 24 total)
  • Author
    Posts
  • #16127

    Anonymous

    New related question:

    Has anyone built a universal (PPC+Intel) version of Firefly that is capable of transcoding from FLAC? I don’t have any space on my Intel machine to install the development tools. I was hoping I could create universal binaries on the PPC machine instead.

    Thhx

    #16128

    andyg
    Participant

    Hi Labchip,

    been trying to get the flac enabled binary to work on my Mac PPC (more for interest/test than anything else as I generally stream through a slug that handles flac files happily) and all’s good up to the point of locating the mt-daapd binary in /src/. The version I find there is only 288kb (292,792 bytes) whereas I see your version was 528,980. If I swap in that new mt-daapd binary for the existing firefly binary, no great surprise then that firefly fails to start. I’ve tried compiling on both 1586 & 1696 with the same result and in both cases the mt-daapd filesize is the same.

    Being a linux/*nix idiot, I’m pretty much admitting defeat but wondered if you could upload the binary & the 3 plugins again so I can try to get this cracked?

    cheers, Andy

    #16129

    Anonymous

    Here you go Andyg. I have re-uploaded them here. Let me know if they work for you.

    http://www.filedropper.com/fireflyppcfiles

    #16130

    andyg
    Participant

    Cheers for them, got ’em now.

    On startup, firefly fails to load straight away – the Apple log shows:

    Dyld Error Message:
    Library not loaded: /opt/local/lib/libFLAC.7.dylib
    Referenced from: /Users/andyg/Library/PreferencePanes/Firefly.prefPane/Contents/Resources/Firefly Helper.app/Contents/Resources/Server/firefly
    Reason: image not found

    I saw your comment regards editing the path to the flac binary and have tried doing that to no effect. As I say, not being proficient with linux it was a bit of a stab in the dark… A quick look in spotlight shows I have libFLAC.8.2.0.dylib living in /opt/local/lib but no libFLAC.7.dylib

    Can you show the exact code you used on that mt-daapd-ssc.sh script, as I probably messed up in the editing & that may see me right…

    cheers, andy

    #16131

    Anonymous

    As far as I can remember, the path to the FLAC binary is the only part of the mt-daapd-ssc.sh script that I changed


    # You may need to fix these paths:
    #

    WAVSTREAMER=./wavstreamer
    ALAC=./alac
    OGGDEC=oggdec
    FLAC=/opt/local/bin/flac

    The error you have seems more like a problem with MacPorts than with Firefly. I have seen similar errors all over the place after I updated MacPorts (in order to install mp3fs for mac). Unfortunately I haven’t succeeded in properly updating all the parts, so I have not been able to install mp3fs (which is great btw and works like a charm on Ubuntu).

    Back to your problem, I suggest you use Firefly 1586. And make sure the version of FLAC in /opt/local/bin/flac is 1.1.2 (and not 1.2.1 – it doesn’t seem to like that). Perhaps that will automatically bring libFLAC.7.dylib into your /opt/local/lib directory. If not, I can send it to you .

    #16132

    andyg
    Participant

    Yes, that was the path I edited as well…

    I’ve found a flac & metaflac binary 1.1.2 (tried compiling my own from sourceforge but I luck out at the make install stage) and copied them into /opt/local/bin but I’m still getting the same error as before when firefly tries to start up. If you can upload that libFLAC.7.dylib file it’d be appreciated. If I still can’t get it to work then I’ll retire gracefully and leave you alone!

    cheers, andy

    #16133

    Anonymous

    I’m sure you are going to need many other dependencies as well. I think the file you mention is actually a link/shortcut to another file rather than a file itself. I will try to locate what i think are all the relevant files, zip them up and send them to you. However, it might take a day or two – I am not at home now.

    #16134

    andyg
    Participant

    No worries, as & when you have time. Agreed, having that file alone may well not be nearly enough, which is why I’m not going to stress it too much if I can’t get it to work, but it’s a worth a shot.

    cheers, andy

    #16135

    colleenex

    How do you take a screen shot on a Mac that’s running a Windows OS? I need to be able to take screen shots on Windows because that’s the only place the programs I need for work are; I’m making tutorials for some programs & I want to be able to put screen shots in them. I tried the shift command ctrl 3 stuff, but that didn’t work. It’s a Mac keyboard, so there’s no print screen button.
    ___________________
    external keyword tool ~ keyworddiscovery.com ~ keycompete.com ~ compete.com ~ webmasterworld.com

Viewing 9 posts - 16 through 24 (of 24 total)

The forum ‘Nightlies Feedback’ is closed to new topics and replies.