Fireplay times out outside LAN, apache server running on XP

FireFly Media Server (formerly mt-daapd) Firefly Media Server Forums Firefly Media Server Setup Issues Fireplay times out outside LAN, apache server running on XP

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #2721

    Greetings all –

    I am pretty sure I have seen this question come up a few times but have never really seen it answered.

    Commence Grovelling
    I am the noobiest of noobs, and have wasted many hours on this not doing my into level Java homework. It is therefore, with humble supplications, that I submit my request and await your reproof.

    Background Info
    I have a computer running Windows XP with a working Apache server. I VNC or SSH into this box. The Apache server can be accessed with no problems using the DynDNS address. Ports are all forwarded to the server’s static internal IP. (The relevant ports here being 80, 9999, and even 3689?) Fireplay.html is renamed index.html in a folder directly beneath my document root. All the host=&port= entries have been changed to the DynDNS address and 9999. Windows firewall is allowing all the appropriate ports.

    What Works
    Everything. Inside the LAN. Fireplay is lightning fast, ITunes can see the files and stream them, etc etc.

    What Doesn’t Work
    When anyone tries to access from outside the LAN, fireplay displays a message that it’s trying to to connect to the server on port 9999, and times out. I believe when I try to access it via proxy, (this might have been trying to access it asks me for a username and password. (It says something about bo melborg and port 3689?) In any case, when I try to enter the password that I set up to manage Firefly remotely, it simply displays the prompt again.

    *Other notes*
    I don’t think i necessarily need Firefly to stream music if the apache server is working (or that firefly and apache are even related in this inquiry?) If anyone else knows of some sort of web-based streaming client that I could put on the webpage instead and not use Firefly, and if that is easier, I would appreciate it.

    *Other, other notes*
    Please don’t just tell me how dumb I am. Refer to the section marked “Commence Grovelling” as many times as necessary.



    As you say you forwarded all those ports, it shouldn’t be a problem.
    Try placing fireplay not on apache, but with firefly’s web admin page. (On port 3689 or another on windows. It shows in the config.)
    So that you connect using http://myserver:port/fireplay.html


    I think I have tried this before, but after making sure that Fireplay was in the admin-root folder, I tried again, entering server.address:9999/fireplay.html. As expected, it worked perfectly internally. Externally, both requests timed out. You should know that my router doesn’t support loopback, so the DNS address is mapped to the server’s static internal IP in my hosts file.

    Any other thoughts or suggestions would be appreciated.



    if the page doesn’t even load externally, I think the port forwarding went wrong.


    I’m looking at my router’s port forwarding list, and they are all forwarded. 80 obviously works, because people can access my server externally. I don’t see why 9999 or 3689 would be any different?


    I appreciate your help and any further insight into this problem, including any alternate solutions that may or may not involve firefly.


    Any ideas out there?

Viewing 6 posts - 1 through 6 (of 6 total)
  • The forum ‘Setup Issues’ is closed to new topics and replies.