You are here: Home » Topic » FirePlay Flash client for FireFlypage 56

FirePlay Flash client for FireFly

This topic contains 873 replies, has 98 voices, and was last updated by  beaon 8 years, 6 months ago.

Viewing 15 posts - 826 through 840 (of 874 total)
  • Author
    Posts
  • #14096

    Anonymous

    I’m seeing new potential for Firefly with this. My employer has started to block all of the music sites, but if I were to install this on my WHS box, I’m betting I could connect to my home IP from work and stream my collection to my work PC… will have to give that a go tonight…

    #14097

    brucec64

    I’m trying to configure Fireplay to work under IIS wwwroot on my HP Media Server. I modifed the html in 3 places with servername and port = 9999. However, when attempting to access fireplay, I’m getting asked to log into http://www.mellberg.org and see a message “connecting to http://www.mellberg.org:3689

    Has anyone seen this before? Is there additional security setup required to get this to work under IIS?

    #14098

    viatorvoice

    Hi all!

    So after tinkering with my ex470 I got yesterday. I though I would set up fireplay. I put it in my wwwroot folder and modified the .html like the tutorial says. I can connect. I have a different music password. But all I get when it its loaded is 3 playlists (library, genius, Purchased) with no songs. In iTunes on my home network I see three songs (.mp3) on the share. Please Help.

    #14099

    Anonymous

    is it possible to pass the mp3-password via the FirePlay.html – file directly to the swf-Plugin, so that the user doesn’t need to know it? (I use an alternative authentication method to give only some specific users access to the FirePlay.html – page, so it’s no problem if they can see the mp3-password, but it’s annoying to type it in everytime they use Fireplay..)

    #14100

    Anonymous

    Would it be possible in the next version to be able to pass options in the HTML to completely remove the download and “generate playlist” links? The ability to disable the download link is good, but if it is disabled it probably shouldn’t show up, as it then just becomes a temptation to poke around. The playlist generator makes me a bit nervous too. If I understand it, using this would allow someone to use another client to access my music. I have my installation of FirePlay behind a custom login screen (we’re in an educational environment, and the only people who should have access are students taking certain classes) and if one were to generate a playlist then they could pass it on to others who shouldn’t have access.

    Personally, I second the idea of getting rid of the playlist pane as well (or be able to hide it). On my installation it is redundant because my playlists are all based on genre, so you see two panes that look almost the same. That may be just me though.

    Thanks. This little app saved me a lot of time.

    #14101

    wwarren
    Participant

    I first got Fireplay working about this time last year on a WDMBWE. That system died and I’m trying to get it working again on a new linux PC but I’m having a weird problem. I have Firefly installed and running correctly on 192.168.1.114:3689. I’ve copied the four FirePlay files into the admin-root folder and edited FirePlay.html to include the servers IP and port number. However when I browse to 192.168.1.114:3689/FirePlay.html I get a completely blank page and the mt-daapd process dies and has to be restarted. Its 0.89 FirePlay and 1696 Firefly on Ubuntu Server 8.04.

    [Update: Hmm. The problem seems to be related to how I login when I edit the config files. It works when I’ve edited the config files via SSH or when logged in locally, but fails when I edit them remotely via Webmin.]

    #14102

    Anonymous

    Hello music fans.

    I’ve got the same problem as some of you reported – at work, the firewall is blocking everything except port 80 and 443.
    So I needed a workaround to get fireplay working on port 80 (or 443).
    Here is how I managed it to work with IIS6.

    You may need an own domain or dynamic DNS accout which you can manage. In my scenario I setted up a new subdomain cos the main (www.) domain is already pointing to the WHS home page.
    I got my router configured to update my dyndns.org account regulary. In my domain administration I created a CNAME record for http://www.my-domain.com so it is always reachable by that name. The same I did for the new subdomain: music.my-domain.com pointing to a CNAME record that is my dyndns.org address.
    BTW it’s easy to get this domain even used by the MSS’s Webshare by editing just a few entries in the registry.

    Enough of off topic talk, lets go to work:

    1a. we need a .NET URL Rewriter and Reverse Proxy. Read more about it at http://www.codeplex.com/urlrewriter and download the latest build there.

    1b. create a new folder in i.e. C:Inetpub called “music”

    1c. inside this folder create a new text file, name it “ManagedFusion.Rewriter.rules” and put in the following text:


    RewriteEngine On
    RewriteRule ^(.*)$ http://localhost:9999$1 [P]

    1d. now extract from the downloaded “Managed Fusion URL Rewriter” the file called “web.config” to your new dir (C:Inetpubmusic)

    1e. in “C:Inetpubmusic” create a folder called “bin” – to this folder extract the “ManagedFusion.Rewriter.dll”

    After these steps your folder structure should look like this:

    C:Inetpubmusic – containing “web.config” and “ManagedFusion.Rewriter.rules”
    C:Inetpubmusicbin – containing “ManagedFusion.Rewriter.dll”

    Now we need to create a new website in IIS.

    2a. create a new website listening on port 80, homedir is the folder you created in 1b. Name it whatever you like.

    2b. edit properties for this new website. On “Website” tab select advanced settings for the “IP Address” binding. Add there a new Hostheader entry to which this website will listen on, i.e. music.your-domain.com – don’t forget to create this subdomain in your domain administration of your provider. A dyndns address should work fine too.

    2c. this website does not need any rights to run scripts or list directory content! Edit properties, go to Home Directory tab and disable everything!

    2d. in the same tab, under application settings click on “Configuration”. Add a new “Wildcard application map” pointing to “C:WINDOWSMicrosoft.NETFrameworkv2.0.50727aspnet_isapi.dll” and UNCHECK “verify that file exists”!

    That’s all. You don’t need to change anything on firefly or fireplay.
    Now you should be able to reach fireplay website going to http://music.your-domain.com/fireplay.html – keeping in mind, that your calling it by it’s new, dedicated (sub)domain!
    If you miss “fireplay.html” at the end you will get the firefly admin-page. To change that, you will need to rename your fireplay.html file to index.html. Rename the existing (original) index.html to admin.html or just move it out there.

    #14103

    wwarren
    Participant

    When I access FirePlay.html from inside my LAN, it works fine. When I access it from outside through a forwarded port, it prompts for Firefly password, delivers a blank page, and crashes mt-daapd. I set debug to 9 and snipped out the last few lines of the log after a crash. Any help as to what this means is appreciated.

    2008-11-24 15:14:14 (b7445b90): Opening /usr/share/mt-daapd/admin-root/FirePlay.swf
    2008-11-24 15:14:14 (b7445b90): Opening file:///usr/share/mt-daapd/admin-root/FirePlay.swf
    2008-11-24 15:14:14 (b7445b90): Checking handler for file
    2008-11-24 15:14:14 (b7445b90): opening /usr/share/mt-daapd/admin-root/FirePlay.swf
    2008-11-24 15:14:14 (b7445b90): Emitting reponse header Content-Language: en_us
    2008-11-24 15:14:14 (b7445b90): Emitting reponse header Content-Type: text/html
    2008-11-24 15:14:14 (b7445b90): Emitting reponse header Server: mt-daapd/svn-1696
    2008-11-24 15:14:14 (b7445b90): Emitting reponse header Connection: close
    2008-11-24 15:14:14 (b7445b90): Emitting reponse header Date: Mon, 24 Nov 2008 21:14:14 GMT
    2008-11-24 15:14:14 (b7445b90): Write error: Connection reset by peer
    2008-11-24 15:14:14 (b6c44b90): Received a message from daap server
    2008-11-24 15:14:14 (b6c44b90): Rendezvous socket closed (daap server crashed?) Aborting.
    2008-11-24 15:14:14: Aborting

    [Update 11/28/08: This is too weird.
    Connect thru local LAN w/ Firefox 3.0.1 – works.
    Connect thru internet w/ Firefox 3.0.1 – crash.
    Connect thru internet w/ IE7 – works.
    Connect thru internet w/ Firefox 3.0.1 with no add-ons – works.
    Tried turning on all add-ons one at a time
    Connect thru internet w/ Firefox 3.0.1, only Google Toolbar add-on – crash
    Connect thru internet w/ Firefox 3.0.1. all add-ons except Google Toolbar – works.]

    #14104

    HellerMD98
    Participant

    Is it possible to use FirePlay with a different server than Firefly, namely Flash Media Server? Also, is the source code to FirePlay available?

    Thanks in advance for any replies!

    #14105

    blamm
    Participant

    Hey Bo.

    Been lurking for a few months. Just noticed that you appear to be producing a Chumby version of Fireplay. Does it use Flash Lite? Would/could it work on my Sony Ericsson w910i?

    Ta

    #14106

    Anonymous

    Giday EH!

    I hope I have not missed the answer to this question.

    how do you set the host and port settings in FirePlay.html


    'movie', 'FirePlay?host=&port=&preventdownload=0',


    The syntax I mean?

    I tried ?host=92.168.x.xx=&port=3689=&preventdownload=0 in all 3 places and it looks like it is connected but is not.

    If you use ?192.168.1.73:3689=&preventdownload=0′ it goes to http://www.mellberg.org:3689.

    I am trying to connect to the Firefly server (Ubutu 8.10) from the out side. 😀

    internet —- Wireless Router—Building lan


    Wireless bridge—Wired Router—Testing Lan with server

    I am on the Buildihg lan connected by Wi-Fi and the FireFly Server is behind a router that connects to the building lan via Wi-Fi, the server has a static IP.

    It works on the (Test Lan) and the (Building Lan) in the if I put it in /admin-root directory with out changes to the file, but I get an admin prompt.

    I would like to run it on apache as http://serveraddress/fireplay/FirePlay.html and not have the Admin prompt, so others on the building lan can use it.

    I tried doing it this way because I could not get itunes to connect and display the Play lists,
    iTunes claimed to be connected and I get a user name prompt, the server does not show in Itunes so I think I am missing a router setting.
    I did not configure the play password – what is the play users name any way?

    Any way Can any one help me with FirePlay?

    Thank You!

    #14107

    Anonymous

    I would like to be able to do the same thing. If anyone could help me out with apache that would be great.

    #14108

    Anonymous

    @bukkit wrote:

    I would like to be able to do the same thing. If anyone could help me out with apache that would be great.

    What did you have in mind?

    Are you running apache2 on Linux?

    I run a Ubuntu 8.10 server with apache2 that I installed during the Ubuntu install.

    I have added a .conf file to the “/etc/apache2/conf.d” directory listing the directories I want the apache to serve.
    The directories are not in apache DocumentRoot “/var/www/HTML” they are “/var/www/webcam” etc.
    I did change the default DocumentRoot from “/var/www” to “/var/www/HTML” to keep things neater.

    I can post a snip of the .conf file if you want!

    Would that help any?

    Later

    #14109

    EVILRipper
    Participant

    Heya Bo,
    I really enjoy this piece of software, as they blocked rights to install software like winamp or itunes on the computers at work.

    I have one feature request which is probably a pain or very easy to implement.
    Currently, the search string is stripped on spaces. The search results are ‘or’ed using the search words.
    When searching for ‘the prodigy’, I get all results with ‘the’ OR ‘prodigy’ in it.
    Could you take a look at searching for ‘the’ AND ‘prodigy’ ? It would really shrink the number of results. 🙂
    Right now, adding more search words actually increases the number of results, instead of shrinking it.

    Thanks in advance,
    Erik

    #14110

    Bo Mellberg
    Participant

    Regarding the search: I will look in to it!

    /Bo

Viewing 15 posts - 826 through 840 (of 874 total)

The forum ‘Add-on Software’ is closed to new topics and replies.