You are here: Home » Topic » FirePlay Flash client for FireFlypage 45

FirePlay Flash client for FireFly

Viewing 15 posts - 661 through 675 (of 874 total)
  • Author
    Posts
  • #13931
    EVILRipper
    Participant

    To tonzurakoite:

    So to clarify:
    – Port 256 is used by firefly. (port 512 seems to be ‘something’ else, guess it’s the Edna you mentioned)
    – You -can- stream using Fireplay local.
    – You -cant- stream using Fireplay remote.
    – You -can- stream using the applet remote.

    So, you might search for the difference between the applet and fireplay.
    Since I don’t know how the applet or fireplay work/connect, I have no idea what could be causing this (most probably) blocked connection.

    And I must say, you have some good music. 😉 (I couldnt resist doing a quick check with DaapPlaylistGenerator)

    Oh, and I guess “others” dont have execute and/or read access to the archives. I get a ‘Not Authorized’ message.

    P.S. Thanks, 10.000 Maniacs sounded great. 🙂

    #13932
    fizze
    Participant

    That’s what my nmap sais, at least:

    PORT     STATE    SERVICE       VERSION
    80/tcp open http Microsoft IIS webserver 5.1
    135/tcp filtered msrpc
    139/tcp open netbios-ssn
    256/tcp open http mt-daapd httpd svn-1586
    443/tcp open https?
    445/tcp open microsoft-ds Microsoft Windows XP microsoft-ds
    1030/tcp open msrpc Microsoft Windows RPC
    1720/tcp filtered H.323/Q.931
    3389/tcp open microsoft-rdp Microsoft Terminal Service
    8080/tcp open http TiVo Desktop httpd 1.4.279.957

    🙄

    #13933
    Anonymous
    Inactive

    Hi all,
    I am new to Firefly. I got it working on Fedora 8 and I really love it. I am trying to get Fireplay working so I can use it at work. However, after simply dropping the files into /usr/share/mt-daapd/admin-root and loading http://localhost:3689/FirePlay.html Fireplay just hangs “trying” to connect to localhost. Everything works fine in Itunes with Firefly. Any help would be great.

    #13934
    fizze
    Participant

    Well, if localhost is your server, then that should work.
    Maybe some ip-filters cut the localhost traffic. Did you try to access it via IP / hostname?

    #13935
    Anonymous
    Inactive

    Yes, I have tried to access it using the hostname, internal 192.168.x.x, and external ip 24.x.x.x. All use give the same result. Besides port 3689, is there another that I should open? Is this a firewall issue?

    #13936
    Bo Mellberg
    Participant

    Have you tried editing the .html as well? There are three places where you can specify your hostname (or ip) and port.

    #13937
    Anonymous
    Inactive

    Yes, I have changed those to the external IP. I am at work now. Same hang. I am forwarding 3689 to that machine, all I get is Connecting to http://24.x.x.x:3689. does port 80 need to forward to? Thanks again

    #13938
    calvin
    Participant

    Hi Bo,

    would it be possible to configure some keys for your perfect client 🙂

    I am using it on a FujisuSiemens Activy (thats an embedded XP Media Center box) with my TV. Mouse is a little bit difficult doing it with the arrows on a remote control. It would be perfect if e.g.
    G for Genre
    A for Artist
    L for album List
    S for Source / or S for Search?
    and some other key for the Song list
    would be possible.

    thanks in advance

    #13939
    Bo Mellberg
    Participant

    Would a tab-functionality be sufficient? I think that can be quite easily implemented.

    #13940
    calvin
    Participant

    that would be good start, i will try that ! 🙂

    #13941
    Anonymous
    Inactive

    *** Sorry all, I fixed the zip files, should be accessible now.

    And – Yes, I CAN use Fireplay local, CANT use it remote, and CAN use the Java applet local AND remote.

    – – – 8< – – –

    First, lemme say I *love* FirePlay–I just wanna be able to love it from work, lol.

    I have gone through the other posts, and nothing seems to help me with figuring out why I can only get FirePlay to work within my network at home. Trying to stream music from work just gives a “Connecting to: http://209.181.138.228:256&#8230; message forever.

    I’ve included links to a screen shot and my files for examples:
    http://209.181.138.228/fireplay.jpg – Screen shot.
    http://209.181.138.228/fireplay.zip – My fireplay.html file.
    http://209.181.138.228/mt-daapd.zip – My mt-daapd.conf file.

    To clarify though, I *can* play music from work via the applet.html Java page that’s still included with FireFly on both ports 256 and 512, as well as with another (I realize totally different) streaming server Edna (again on ports 256 and 512, it plays at work no problem).

    So I am hoping someone will be able to look at this stuff and point out whatever I’m missing.

    #13942
    Anonymous
    Inactive

    To sum up,
    iTunes can see the share just fine and plays great! I can navigate to the mt-daapd/admin-root/ through any browser just fine from any machine.

    I have altered FirePlay.html to look for hosts localhost (when using the machine FireFly is running on [Fedora 8 x86]), hostname and local ip 192.168.x.x (for local machine and 3 others in the house.), and external ip 24.x.x.x (for local, machine in house and at work). All yield the same Connecting to http://{insert your choice}:3689 hang.

    I am using FireFly 0.2.4.1 and FirePlay v0.85. I have even turned the firewall on the fedora box completely off. Still nothing. I am not sure what I am doing wrong. Am I missing some key package? Thanks for any help.

    #13943
    Anonymous
    Inactive

    One more thing. I installed the fc9 rpm for this at rpmfind.net I noticed opening in Safari gives an error. I am missing rsp/info? I installed using the software installer and i didn’t give any options. I don’t have rsp in the admin-root directory. Is this the issue? How can I fix? thanks.
    d

    #13944
    Anonymous
    Inactive

    bloddy great program.

    want to make access public however using the installation in the /usr/share/mt-daapd/www-root method then asks for password every time, also giving access to server admin.

    moving to /var/www then wont connect as path hasn’t been connected to via 3689
    cant find a way to edit files to tell it to go through 3689. lost.

    #13945
    Bo Mellberg
    Participant

    @typheous wrote:

    moving to /var/www then wont connect as path hasn’t been connected to via 3689
    cant find a way to edit files to tell it to go through 3689. lost.

    You should be able to edit FirePlay.html to do this. In three spots, edit the file to “host=www.yourserver.com&port=3689”

    If you want to, protect the directory using an ordinary .htaccess-file (assuming apache server).

Viewing 15 posts - 661 through 675 (of 874 total)
  • The forum ‘Add-on Software’ is closed to new topics and replies.