You are here: Home » Topic » Firefly Ubunt/osx setup problem

Firefly Ubunt/osx setup problem

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #2961
    Anonymous
    Inactive

    hi!

    I just setup a firefly server on my ubuntu machine. With http://localhost:3689/index.html i can reach the configuration and my files are scanned without a problem.

    Now heres the problem:

    Neither iTunes on my macbook nor amarok2 (ubuntu jaunty) on on my laptop can find the playlist / Stream.
    what i have tried:

    * i activated “allow multicast” for my router (running tomato on a WRT54G – didnt help
    * i opened the port 3689 for all computers in my network threw port forwarding – didnt help
    * Pinging each computer works absolutely fine, also can i acces the shared folders, including the shared music folder
    * Every machine can acces firefly config with browsing to 192.168.1.100:3689
    * reinstalled avahi on the ubuntu machine

    Can anybody help me? It makes me mad not getting it to work!

    Greetings Anon

    #18811
    Anonymous
    Inactive

    push!

    #18812
    stretch
    Participant

    Can you try using the java Firefly client.
    The java client doesn’t rely on multicast to find the server.

    If the Java client works then your router isn’t processing multicast properly

    #18813
    Anonymous
    Inactive

    Downloaded the program on a laptop and did following steps:

    File -> new libary ->
    entered hostname
    entered ip adress of the pc on which firefly media server is running and it worked on 2 machines.
    Opened another server on a second laptop and i can reach it from every other pc (also with the original sever pc) with the java applet.

    You said then it would be a problem woth my router not beeing able to process multicast properly.

    I am running a Linksys WRT54GL Router with Tomato firmware in which i activated the multicast option. (see the attached picture)

    Do you think it could be a problem with ubuntu and bonjour?

    it really makes me mad!

    #18814
    stretch
    Participant

    When running on *nix platforms, Firefly uses a built-in mDNS responder or avahi not bonjour.
    As you can access Firefly with the java client, Firefly is running & you clearly have a service discovery problem.
    I’m not a ubuntu expert so i can’t help you much more than that

    If the router doesn’t handle multicast properly then it isn’t alone. The DIR-655 doesn’t either.

    #18815
    EVILRipper
    Participant

    I agree with stretch on this one. As you have no trouble accessing firefly directly, it is clearly a discovery problem.

    #18810
    Anonymous
    Inactive

    I tried to install firefly in Windows on the server (including apple bonjour). The shared music was instantly visible in itunes on the other computers what means your right and there is something wrong with the Avahi in ubuntu…

    I will try to solve it and post the result here if i make it to eventually help other users!

    thanks for your help

Viewing 7 posts - 1 through 7 (of 7 total)
  • The forum ‘Setup Issues’ is closed to new topics and replies.