You are here: Home » Topic » Firefly on NAS?page 4

Firefly on NAS?

Viewing 15 posts - 46 through 60 (of 63 total)
  • Author
    Posts
  • #10709
    Anonymous
    Inactive

    This was the response:
    “-rwxr-xr-x 1 root root 725883 Nov 4 17:56 /opt/mt-daapd-svn-1586/src/mt-daapd”

    #10710
    sonichouse
    Participant

    Looks like that could be the one then.

    so try runing

    /opt/mt-daapd-svn-1586/src/mt-daapd -c  /etc/mt-daapd.conf

    Good luck 😆

    #10711
    Anonymous
    Inactive

    Hey thanx for all help, but still no response more than back to promt…
    👿
    An dalso, in the S99firefly script it says:
    “echo “Starting Firefly”
    /usr/local/sbin/mt-daapd -c /etc/mt-daapd.conf”
    then shouldn’t it be in sbin?!

    👿 👿 👿 👿

    #10712
    sonichouse
    Participant

    In your conf, look at where it is writing the log file.

    Check if it has written a log and see if it has anything in there.

    You might want to increase the debug level with -d9 on the command line as well e.g.

    /opt/mt-daapd-svn-1586/src/mt-daapd -d9 -c /etc/mt-daapd.conf

    or you could try

    /opt/mt-daapd-svn-1586/src/mt-daapd -V
    and see if it prints the version to the screen.

    #10713
    sonichouse
    Participant

    @andrease wrote:

    Hey thanx for all help, but still no response more than back to promt…
    👿
    An dalso, in the S99firefly script it says:
    “echo “Starting Firefly”
    /usr/local/sbin/mt-daapd -c /etc/mt-daapd.conf”
    then shouldn’t it be in sbin?!

    👿 👿 👿 👿

    According to the wiki the file is copied to /usr/local/sbin.

    so you should be able to use that one as well.

    the wiki also talks about symbolic linking of the sqlite3 library as well.

    #10714
    fizze
    Participant

    This all doesn’t sound right.
    If mt-daapd is being run in foreground mode any error messages are output to the console.
    And if there isn’t anything, chances are the binary is not being run at all.

    Also, why is the binary in the source folder? Did you compile yourself?
    If so, are you sure you’ve used the right configure options, and did the make && make install?

    #10715
    Anonymous
    Inactive

    Alright, so I finally got it running!!! 😀 😀 😀
    But a new problem…
    I have the MP3 files in a directory, that when i run firefly from
    my computer and runs MIONET (wich now is stopped…) is called:
    \Andreas_musikPUBLICAndreas
    Now without MIONET, I get the explorer connecting and logging in with the admin user. I now no longer sees the PUBLIC folder! How do I get that?
    I still have some unsorted mp3’s there…
    And also I try to move some MP3’s in the dir that have been created before and I can’t do anything with those files!
    I can’t get admin access! I use the same login as when I did all those programming stuff via SSH!

    And, what should the music folder in the firefly on the nas be?
    Can’t get it to find any songs!
    Puh!
    Anyone?

    /Andy

    #10716
    sonichouse
    Participant

    Congratulations 😛

    you could try and find the lcation of the directory with

    find / -name mp3 -type d

    On my slug this gives

    /share/hdd/data/public/mp3

    That is the directory you need to point firefly at.

    Obviously change mp3 to Andreas when doing the find :D.

    Steve

    #10717
    Anonymous
    Inactive

    in this topic here a some users using WD my book but i found this topic to late
    my problem ist postet here:
    http://forums.fireflymediaserver.org/viewtopic.php?t=6911

    thx in advance

    #10718
    Anonymous
    Inactive

    Hi again all!
    Now I get the soundbridge to find all of my mp3’s but it won’t
    play them!
    I tried to chmod the files, but it won’t help…
    I can also see, move and do everything with the files,
    since I re-imported all files as su.
    Any suggestions?

    /Andy

    #10719
    sonichouse
    Participant

    Can you try setting the debuglevel=9 in mt-dappd.conf via the web configruation page or editing mt-daapd.conf and then play one of the files.

    Look in the mt-daapd.log, you might get a clue there.

    /Steve

    #10720
    Anonymous
    Inactive

    OK, so I tried to change the debug level via the web conf. but gets the message:
    Error: 500general:debuglevel

    and I can’t find it in the mt-daapd.conf file…

    Is there a “advanced config” in mt-daapd.conf?!

    /Andy

    #10721
    fizze
    Participant

    You might as well invoke -d 9 as a parameter.

    I still dont think you have the paths to the mt-daapd executable right, as well as the path to mt-daapd.conf

    #10722
    Anonymous
    Inactive

    Fizze… The mt-daapd is running and I can see all my files through
    the Soundbridge… But how do I look at the mt-daapd to see if it has the
    executable right?

    And regarding the “-d 9″… is all I have to do include the
    line: “debuglevel = -d 9” in mt-daapd.conf?

    /Andy

    #10723
    fizze
    Participant

    Well if its running then everything is fine 🙂

    Nah, if the mt-daapd is running, just access your administrative website at server:3689 in any browser.
    There you can specify the debuglevel as well as any other options.

    Cheers 😉

Viewing 15 posts - 46 through 60 (of 63 total)
  • The forum ‘General Discussion’ is closed to new topics and replies.