You are here: Home » Topic » Firefly now running on unmodifed Linkstation Live/Propage 3

Firefly now running on unmodifed Linkstation Live/Pro

FireFly Media Server (formerly mt-daapd) Firefly Media Server Forums Firefly Media Server General Discussion Firefly now running on unmodifed Linkstation Live/Pro

Viewing 7 posts - 31 through 37 (of 37 total)
  • Author
    Posts
  • #11761
    bobinchicago
    Participant

    @cezza wrote:

    I’ve been playing with the Firefly package that’s detailed in the howto, and determ¡ned that /etc/init.d/firefly doesn’t support the restart parameter. This can be fixed by editing /etc/init.d/firefly and changing this:

      restart)
    stop
    start
    ;;

    To this:

      restart)
    $0 stop
    $0 start
    ;;

    I guess for convention’s sake /etc/init.d/firefly should be renamed /etc/init.d/firefly.sh…

    Also, having looked at one of Kaiten’s posts elsewhere (and assuming the above edit has been made and that /etc/init.d/firefly has been renamed /etc/init.d/firefly.sh), I’ve determ¡ned that you can set daemonwatcher to automatically restart Firefly it it’s stopped running by adding the following to /etc/daemonwatch.list:

     /var/run/mt-daapd.pid           /etc/init.d/firefly.sh restart

    I know this isn’t literally a fix for the Bonjour bug in 1586, but would it have that effect of ensuring that the server’s running and visible? I’ve had to shut down my Linkstation Live with Firefly and go back to iTunes after too many mornings of the SoundBridge Radio’s generic alarm beep. I’d love to switch back to the NAS.

    Assuming that’s the case, I’m enough of a rookie to want to make sure I have the steps correct going in:

    1. Ensure that I have telnet access by

     java -jar acp_commander.jar -t  -o

    2. Once I’ve ensured that, telnet in and

    vi /etc/init.d/firefly

    3. Move to the section detailed here starting with the

    restart)

    line and make the indicated $0 changes to the two lines and save the changes.

    4. Rename the file as mentioned.

    mv /etc/init.d/firefly /etc/init.d/firefly.sh

    5. Edit /etc/daemonwatch.list:

    vi /etc/daemonwatch.list

    6. Anywhere within daemonwatch.list, add the line at the end of the quoted post:

    /var/run/mt-daapd.pid           /etc/init.d/firefly.sh restart

    … and just to cover my newbie butt, that last line of code really goes on one line, right?

    If I’ve left anything out, forgotten to consider anything, please feel free to steer me with A’s, B’s, .3 and .6’s, or whatever else seems appropriate. 8) Thanks! (And thanks very much to bawbagg, Kaiten, of course rpedde, and everyone who put this together!)

    #11762
    Sam1
    Participant

    Ron,
    I found the correct mt-daapd configuration file in Telnet. The one that I had changed permissions on was in [/etc/mt-daapd.conf]. The one that I should (and did) change permissions on was [/etc/mt-daapd/mt-daapd.conf].
    All working fine now.
    Thank you for your patience again.
    C 😛 [/quote][/code]

    #11763
    rpedde
    Participant

    @Sam1 wrote:

    Ron,
    I found the correct mt-daapd configuration file in Telnet. The one that I had changed permissions on was in [/etc/mt-daapd.conf]. The one that I should (and did) change permissions on was [/etc/mt-daapd/mt-daapd.conf].
    All working fine now.
    Thank you for your patience again.
    C 😛

    [/code][/quote]

    That would do it. 🙂

    — Ron

    #11764
    Anonymous
    Inactive

    I followed the instructions in the original post on a fresh LinkStation Live (fw v2.10, telnet enabled).

    mtdaapd quits shortly after startup with the following output to /var/log/mt-daapd.log:

    2008-01-21 20:39:32 (4001d4a0): Firefly Version svn-1586: Starting with debuglevel 2
    2008-01-21 20:39:32 (4001d4a0): Plugin loaded: ssc-script/svn-1586
    2008-01-21 20:39:32 (4001d4a0): Plugin loaded: rsp/svn-1586
    2008-01-21 20:39:32 (4001d4a0): Plugin loaded: daap/svn-1586
    2008-01-21 20:39:32 (4001d4a0): Starting rendezvous daemon
    2008-01-21 20:39:32 (4001d4a0): Starting signal handler
    2008-01-21 20:39:32 (4001d4a0): Initializing database
    2008-01-21 20:39:32 (4001d4a0): Full reload...
    2008-01-21 20:39:32 (4001d4a0): Starting web server from /usr/local/share/mt-daapd/admin-root on port 3689
    2008-01-21 20:39:32 (4001d4a0): Registering rendezvous names
    2008-01-21 20:39:32 (4001d4a0): Serving 0 songs. Startup complete in 0 seconds
    2008-01-21 20:39:32 (4001d4a0): Rescanning database
    2008-01-21 20:40:26 (4001d4a0): Rendezvous socket closed (daap server crashed?) Aborting.
    2008-01-21 20:40:26: Aborting

    Any suggestion on how to troubleshoot this?

    #11765
    rpedde
    Participant

    @jrs wrote:

    I followed the instructions in the original post on a fresh LinkStation Live (fw v2.10, telnet enabled).

    mtdaapd quits shortly after startup with the following output to /var/log/mt-daapd.log:

    2008-01-21 20:39:32 (4001d4a0): Firefly Version svn-1586: Starting with debuglevel 2
    2008-01-21 20:39:32 (4001d4a0): Plugin loaded: ssc-script/svn-1586
    2008-01-21 20:39:32 (4001d4a0): Plugin loaded: rsp/svn-1586
    2008-01-21 20:39:32 (4001d4a0): Plugin loaded: daap/svn-1586
    2008-01-21 20:39:32 (4001d4a0): Starting rendezvous daemon
    2008-01-21 20:39:32 (4001d4a0): Starting signal handler
    2008-01-21 20:39:32 (4001d4a0): Initializing database
    2008-01-21 20:39:32 (4001d4a0): Full reload...
    2008-01-21 20:39:32 (4001d4a0): Starting web server from /usr/local/share/mt-daapd/admin-root on port 3689
    2008-01-21 20:39:32 (4001d4a0): Registering rendezvous names
    2008-01-21 20:39:32 (4001d4a0): Serving 0 songs. Startup complete in 0 seconds
    2008-01-21 20:39:32 (4001d4a0): Rescanning database
    2008-01-21 20:40:26 (4001d4a0): Rendezvous socket closed (daap server crashed?) Aborting.
    2008-01-21 20:40:26: Aborting

    Any suggestion on how to troubleshoot this?

    The best troubleshooting is to up the log level to 9 and see what it does. It looks very possible that the cause of this is a corrupt database though. I’d probably start with stopping hte server and deleting the songs.db (or songs3.db) and any .journal files in the db directory, then starting it again. If it still keeps dying, then set a log file in the config and up the debuglevel to 9 and see what that shows.

    Yell if that doesnt’ make sense.

    — Ron

    #11766
    Anonymous
    Inactive

    Ron,

    It works now. Thanks for your help!

    The long story is I went through and removed /usr/local/var/cache/mt-daapd/songs.db, and was monkeying about on the way to setting the -d9 flag. Well, I just happened to check df and noticed that the root partition was full. I had misplaced a copy command and had filled the /var/log directory with junk. So I cleaned it out and now all works! Chalk this one up to a case of PEBKAC.

    I’m now enjoying my Roku SB served by mt-daapd! 🙂 Thanks again!
    -joel

    #11767
    Anonymous
    Inactive

    Thank you very much for your hand working.

    It really helps me a lot.

    Thanks again…

Viewing 7 posts - 31 through 37 (of 37 total)
  • The forum ‘General Discussion’ is closed to new topics and replies.