You are here: Home » Topic » Firefly now running on unmodifed Linkstation Live/Propage 2

Firefly now running on unmodifed Linkstation Live/Pro

FireFly Media Server (formerly mt-daapd) Firefly Media Server Forums Firefly Media Server General Discussion Firefly now running on unmodifed Linkstation Live/Pro

Viewing 15 posts - 16 through 30 (of 37 total)
  • Author
    Posts
  • #11746
    mave
    Participant

    Hi Kaiten,

    that was 100% correct 😀

    I checked it and now flac works – and it’s incredible how fast it is. Wow!
    It seems to be as fast and reactive as my firefly running on a Sempron 2400 – really impressive.

    Thank you very much for your help, you saved me a lot of time!
    And thanks again to BB for the brilliant description.

    🙂 Marcus

    #11747
    bawbagg
    Participant

    I updated the wiki with the fix.

    BB

    #11748
    Kaiten
    Participant

    For those running with logs.. you might want to add the mt-daapd log to the log rotate schedule too. 😉

    #11749
    rpedde
    Participant

    @Kaiten wrote:

    For those running with logs.. you might want to add the mt-daapd log to the log rotate schedule too. 😉

    Remember to touch the new logfile and chown it to the “run_as” user, then send it a HUP, otherwise it won’t move to the new log file.

    — Ron

    #11750
    taalas
    Participant

    Hello bawbagg,

    just registered to say thank you for the great instructions you provided. I originally found your post on the linkstationwiki forums in search for a replacement of the Live’s stock mt-daapd (which accessed the HD like crazy).

    It took me about 4 minutes installing a recent Firefly using your wiki article. Thanks!

    One more thing: Additionally to your instructions I changed the file permissions on the config file to be able to change config through the web interface (standard file permissions from the tar would result in the web interface not being able to write to the file). All is well now, web interface gives errors sometimes when writing a new password or server name (Error500:adminpass e.g.) but I think this is Firefly-related. The changes work regardless. Others fields work without any error as far as i remember…

    Thanks

    Markus

    #11751
    Kaiten
    Participant

    @taalas wrote:

    All is well now, web interface gives errors sometimes when writing a new password or server name (Error500:adminpass e.g.) but I think this is Firefly-related.

    It is 😀

    #11752
    taalas
    Participant

    Phew 😉 good to knew, I was guessing there 😀

    #11753
    cezza
    Participant

    @bawbagg wrote:

    I’ve been able to get Firefly running on my unmodded Linkstation Live (with a 500GB disk 😉 ).

    [edit]

    I posted a detailed howto on the Linkstation forums – thread is http://forum.linkstationwiki.net/viewtopic.php?f=39&t=3509

    Just wanted to say that this is by far the easiest set of instructions for getting Firefly running on a NAS (and specifically the Linkstation) that I’ve seen. Thank you for taking the time to produce them.

    I’ve been playing around with the idea of getting a NAS device for my Roku Soundbridge for some time now, and this solution fits…

    #11754
    cezza
    Participant

    @bawbagg wrote:

    I posted a detailed howto on the Linkstation forums – thread is http://forum.linkstationwiki.net/viewtopic.php?f=39&t=3509

    I’ve been playing with the Firefly package that’s detailed in the howto, and determined that /etc/init.d/firefly doesn’t support the restart parameter. This can be fixed by editing /etc/init.d/firefly and changing this:

      restart)
    stop
    start
    ;;

    To this:

      restart)
    $0 stop
    $0 start
    ;;

    I guess for convention’s sake /etc/init.d/firefly should be renamed /etc/init.d/firefly.sh…

    Also, having looked at one of Kaiten’s posts elsewhere (and assuming the above edit has been made and that /etc/init.d/firefly has been renamed /etc/init.d/firefly.sh), I’ve determined that you can set daemonwatcher to automatically restart Firefly it it’s stopped running by adding the following to /etc/daemonwatch.list:

     /var/run/mt-daapd.pid           /etc/init.d/firefly.sh restart
    #11755
    Sam1
    Participant

    Thanks for the excellent instructions on the Linkstation. Worked first time except for the problem with the configuration file. I cannot edit this from the web interface as posted on this thread. I have tried changing the permissions on the mt-daapt.conf file through telnet using the chmod 777 mt-daapd.conf still no joy…

    Any ideas?

    #11756
    rpedde
    Participant

    @Sam1 wrote:

    Thanks for the excellent instructions on the Linkstation. Worked first time except for the problem with the configuration file. I cannot edit this from the web interface as posted on this thread. I have tried changing the permissions on the mt-daapt.conf file through telnet using the chmod 777 mt-daapd.conf still no joy…

    Any ideas?

    What does it do?

    #11757
    Sam1
    Participant

    Sorry Ron, I should have given more detail. SVN-1586

    When I go to the web interface and try to open the configuration page I get [Your config file is not writable, you can not change anything using this webpage]. All of the options are visible but not editable.

    Telnet in to see what permissions are set

    [[email protected]:/etc/mt-daapd# ls -l
    -rw-r–r– 1 root root 8172 Oct 8 20:53 mt-daapd.conf]

    I ran [chmod 0666 /dev/null] and checked the permissions. Results are: [crw-rw-rw- 1 root root 1, 3 Oct 10 2001 null]

    I then ran [chmod 777 mt-daapd.conf] the results below.
    [-rwxrwxrwx 1 root root 457 Sep 22 14:06 mt-daapd.conf]

    Still not able to edit the configuration file from the web interface.

    Am I doing anything stupid?

    #11758
    rpedde
    Participant

    @Sam1 wrote:

    Sorry Ron, I should have given more detail. SVN-1586

    When I go to the web interface and try to open the configuration page I get [Your config file is not writable, you can not change anything using this webpage]. All of the options are visible but not editable.

    Telnet in to see what permissions are set

    [[email protected]:/etc/mt-daapd# ls -l
    -rw-r–r– 1 root root 8172 Oct 8 20:53 mt-daapd.conf]

    I ran [chmod 0666 /dev/null] and checked the permissions. Results are: [crw-rw-rw- 1 root root 1, 3 Oct 10 2001 null]

    I then ran [chmod 777 mt-daapd.conf] the results below.
    [-rwxrwxrwx 1 root root 457 Sep 22 14:06 mt-daapd.conf]

    Still not able to edit the configuration file from the web interface.

    Am I doing anything stupid?

    The only thing I can think is that maybe that’s not the config file you think it is. Is that really the same config file that it says is the config file in the web interface?

    What’s the full path?

    #11759
    Sam1
    Participant

    Hi Ron, Sorry for the delay in reply……it’s the time difference.

    The path in the web config is [Config File Location /etc/mt-daapd/mt-daapd.conf]

    C[/quote]

    #11760
    rpedde
    Participant

    @Sam1 wrote:

    Hi Ron, Sorry for the delay in reply……it’s the time difference.

    The path in the web config is [Config File Location /etc/mt-daapd/mt-daapd.conf]

    C

    [/quote]

    Hrm. Try chmod 666? I’ll double-check the code, but it sure should work.

    🙁

Viewing 15 posts - 16 through 30 (of 37 total)
  • The forum ‘General Discussion’ is closed to new topics and replies.