Firefly not showing up as "Shared" in iTunes

This topic contains 6 replies, has 3 voices, and was last updated by  garydauphin 7 years, 9 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #2892

    Anonymous

    Hey all,

    New to Unbuntu server and samba. So I had Firefly under my “shared” heading in itunes and then did the localhost3689 ,saw the Firefly page , all seemed well. As I was clicking through the page list on the right hand side of Firefly it just suddenly lost connection with the host. I had gotten Firefox messages like check your connection, check firewall settings, host might be down. So now I can’t get the Firefly back in iTunes shared and the folder that was in etc/mt-daapd in unbuntu is gone. All I have is the mt-daapd.config file. When I go into Terminal to reinstall Firefly it tells my I already have it installed. I search my computer and it is nowhere to be found only the config file. All I was doing was looking at the Firefly page. I didn’t config anything or change anything. I had the Firefly server page for about 10 minutes before anything happened.

    Very confused,
    paul

    #18510

    fizze
    Participant

    It probably just stopped or crashed.
    You need to restart firefly.

    To do so open a terminal and type “sudo /etc/init.d/mt-daapd start” 😉
    Of course there are many ways to start a daemon on linux, but this one is fairly simple.

    #18511

    Anonymous

    Thank you. I’m sure I’ll have more questions.

    -paul

    #18512

    Aggienator

    Hi I too have this problem. Firefly installed on Ubuntu 9.04. After installation and setup firefly appeared for a short wile in my shared libraries in Itunes on my Mac, but then disappeared. I have stopped and started the daapd, but it is still no longer there. iTunes is set to look for shared libraries. Any ideas gratefully received.

    #18515

    garydauphin

    I, too, am having the exact same issue. I found a fix, though it is not yet elegant:

    I wrote a two line script that stops the server and then immediately restarts it.

    sudo /etc/init.d/mt-daapd stop
    sudo /etc/init.d/mt-daapd start

    I saved this as a text file as “Restart FireFly.sh” and set the Permissions to make the file executable. Now when I double click it, it asks me if I want to run this in the Terminal,and I click Run in Terminal. It fixes the problem every time.

    Now you might think that all it does it restart a dead mt-daapd process, but if I leave out the STOP command, and just put the START command, it doesn’t work. So, something about stopping a running server and restarting it fixes the problem every time.

    The downside is that I have to manually enter the sudo Password everytime.

    I tried taking out the “Sudo” so it would need a password from me, and then having the script run every time I login:

    System -> Preferences -> Startup

    Here I noticed that the Mt-daapd or Firefly was not listed to automatically startup. So, I added my script to the list of startup items.

    Well, this worked for one run, then upon restart it wouldn’t work. The script would always STOP mt-daapd every time without SUDO, but it didn’t seem to START it again afterwards. To test, I put sudo back in there, and it worked perfectly.

    So, I am thinking you need sudo privileges to run
    /etc/init.d/mt-daapd start

    I went looking for that file, which turns out to be a config script that launches

    /usr/sbin/mt-daapd So, I was hoping that I gave permission to run that app without being sudo, all might be well:

    If foudn that this an executable binary, but only executable by root. So, I went to the terminal and set it read / write for my user:

    sudo chmod 777 /usr/bin/mt-daapd

    Well that, too, worked during one session, but upon reboot, didn’t work again without Sudo being in there.

    gd

    #18513

    EVILRipper
    Participant

    no offense, but the usual /etc/init.d/ script accepts a ‘start’, ‘stop’ and ‘restart’. So your script is probably redundant.
    Also, adding a init.d script to the boot process, you could execute the command ‘update-rc.d defaults’.
    Although it is defined in the mt-daapd.conf, it should be run by user ‘nobody’. So I actually doubt you need root to run it.

    #18514

    fizze
    Participant

    You need root permissions to run init scripts on most unix-oid OSes I know.
    It’s definetly the case for Debian/Ubuntu.

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.
Register here