You are here: Home » Topic » Firefly Not showing Playlists

Firefly Not showing Playlists

This topic contains 13 replies, has 3 voices, and was last updated by  bboons 10 years, 9 months ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #799

    wiredhernandez
    Participant

    Very basic I am sure. I am running latest win32 version of Firefly on XP. I can create smart playlists and they work just fine. I have also tried to create .pls and .m3u in winamp and saved in d:mp3My Playlists .. The files do not appear at all under playlists but the smart ones configured on server do. I know im missing somethin Mg simple. Client is Roku M2000. Any help appreciated. -Adam

    #7384

    S80_UK
    Participant

    Assuming that the D: drive you mention is on the same machine, is the playlist folder and the folder for the files that they point to set up in the Firefly configuration options? Is the switch for processing .m3u files as playlists set to yes? And is Firefly scanning so that it picks up new files? Once every 10 minutes or so works well for me. Basic questions, but I know from my experience with Firefly that these are easy to miss when trying out new ideas.

    #7385

    bboons

    I’m having similar problems. I’m running svn-1417 on Ubuntu Dapper. The only play lists that I can get to on the SB are the ones I create with the wizard. All other playlists including smart playlists in the .playlist file are not picked up. I don’t understand why even the smart playlists are not working, I double checked the playlist file location and the corresponding “playlist = ” specification in the .conf file.
    I don’t see any errors logged with debug flag on.
    BTW, when I unpacked the svn-1417 tar file I noticed that the sample .playlist file was missing and so I just copied one from the svn-1359 release and modified it to fit my directory structure. Why was this file removed from the tar package ?. Is it not supported ?.

    #7386

    rpedde
    Participant

    @bboons wrote:

    I’m having similar problems. I’m running svn-1417 on Ubuntu Dapper. The only play lists that I can get to on the SB are the ones I create with the wizard. All other playlists including smart playlists in the .playlist file are not picked up. I don’t understand why even the smart playlists are not working, I double checked the playlist file location and the corresponding “playlist = ” specification in the .conf file.
    I don’t see any errors logged with debug flag on.
    BTW, when I unpacked the svn-1417 tar file I noticed that the sample .playlist file was missing and so I just copied one from the svn-1359 release and modified it to fit my directory structure. Why was this file removed from the tar package ?. Is it not supported ?.

    Correct… it doesn’t parse the file based playlist anymore — they got moved into the database. Generally, though, the ones in the database are like the ones in the file, except parsed and available immediately rather than having to start and stop the server.

    I left the .playlist directive in there, because I’m going to make the server backup the playlists to the .playlist file on startup and shutdown, so that way you have a backup of the playlists. It won’t be user editable, though.

    — Ron

    #7387

    bboons

    @rpedde wrote:

    Correct… it doesn’t parse the file based playlist anymore — they got moved into the database. Generally, though, the ones in the database are like the ones in the file, except parsed and available immediately rather than having to start and stop the server.

    I left the .playlist directive in there, because I’m going to make the server backup the playlists to the .playlist file on startup and shutdown, so that way you have a backup of the playlists. It won’t be user editable, though.

    — Ron

    Ok, that makes sense. But, I am trying to create a smart playlist along the lines of “path includes dirname”. I could not find a way to do that with the wizard, the “path” option used to be available as a directive in the .playlist file. Is there an equivalent that I can use ?.

    #7388

    rpedde
    Participant

    @bboons wrote:

    Ok, that makes sense. But, I am trying to create a smart playlist along the lines of “path includes dirname”. I could not find a way to do that with the wizard, the “path” option used to be available as a directive in the .playlist file. Is there an equivalent that I can use ?.

    Yup:

    path includes “dirname”

    Just don’t use the wizard. Dump it right into the text box. The wizard just show simple examples, it’s not required to build the playlist.

    Remember that you must escape quotes and backslashes with backslashes:

    artist is “”Weird Al” Yankovic”

    path includes “\incoming”

    — Ron

    #7389

    bboons

    Thanks for the tips. I got my playlist problems resolved.

    #7390

    bboons

    Now that I have smart playlist working next I tried a .pls playlist for radio stations and it is not working. Here’s the content of the playlit file:
    [playlist]
    numberofentries=1
    File1=http://scfire-ntc0l-1.stream.aol.com:80/stream/1074
    Title1=(#1 – 298/3384) .977 The Hitz Channel
    Length1=-1
    Version=2

    I put this .pls file in the same directory as my other music files (these files are playable on my soundbridge client).
    I also killed and restarted mt-daapd daemon -svn1417 (BTW, is there a better way to restart this service other than kill/start?).

    I was expecting to see something under the “playlist” section of soundbridge for this particular file but all I see are the smart playlists.

    What am I missing?

    #7391

    rpedde
    Participant

    @bboons wrote:

    Now that I have smart playlist working next I tried a .pls playlist for radio stations and it is not working. Here’s the content of the playlit file:
    [playlist]
    numberofentries=1
    File1=http://scfire-ntc0l-1.stream.aol.com:80/stream/1074
    Title1=(#1 – 298/3384) .977 The Hitz Channel
    Length1=-1
    Version=2

    I put this .pls file in the same directory as my other music files (these files are playable on my soundbridge client).
    I also killed and restarted mt-daapd daemon -svn1417 (BTW, is there a better way to restart this service other than kill/start?).

    I was expecting to see something under the “playlist” section of soundbridge for this particular file but all I see are the smart playlists.

    What am I missing?

    try http://wiki.mt-daapd.org/wiki/Streaming_Audio.

    You can rescan by going to the web interface (http://localhost:port). On the status page you can make it rescan. You can also change the config there to add (for example) an admin password, then you can access the web configurator from anywhere.

    — Ron

    #7392

    bboons

    @rpedde wrote:

    try http://wiki.mt-daapd.org/wiki/Streaming_Audio.

    You can rescan by going to the web interface (http://localhost:port). On the status page you can make it rescan. You can also change the config there to add (for example) an admin password, then you can access the web configurator from anywhere.

    Sorry, I shoud have mentioned that I already tried the wiki instructions as well (every step of it).
    1. I created the .url file in the specified format.
    2. added a .m3u playlist with the .url file
    3. edited .conf to enable processing of .m3u and .url
    4. restarted server
    5. started full rescan.

    I also tried to create a smart playlist with the type includes “URL” specification and that did not work either. I’m guessing that if the smart playlist does not work then I should not even bother trying a static playlist.

    #7393

    rpedde
    Participant

    @bboons wrote:

    Sorry, I shoud have mentioned that I already tried the wiki instructions as well (every step of it).
    1. I created the .url file in the specified format.
    2. added a .m3u playlist with the .url file
    3. edited .conf to enable processing of .m3u and .url
    4. restarted server
    5. started full rescan.

    Okay.. hrm.. this is nightlies, right? Do you see the radio station file at all? Do you get any errors in the log file?

    You can try specifying a log file, then bumping your debug level up (9?), then doing a full scan. Stop the server, and search for “.url”. See if you see what it does when it tries to add the file. Does it not like the format? Does it not see it at all?

    Curious.

    Because it sounds like you have it all right. Check the logs, though, you should see an error message, or a scan of the url file followed by an insert into the database.

    — Ron

    #7394

    bboons

    I’m using svn-1417 and here’s the relevant debug log (at level 9):

    Found /home/Disk1/Aud/Radios
    Found Radios.. recursing
    Found /home/Disk1/Aud/Radios/top_40.url
    Executing: select * from songs where path=’/home/Disk1/Aud/Radios/top_40.url’ and idx=0
    Executing: INSERT INTO updated VALUES (421)
    Rows: 1
    Found music file: top_40.url
    Codec type: (null)
    Getting URL file info
    Title: Top 40
    Bitrate: 128
    URL: http://scfire-ntc0l-1.stream.aol.com:80/stream/1074
    Date Added: 1164752509
    Codec: (null)
    Executing: select count(*) from songs where path=’/home/Disk1/Aud/Radios/top_40.url’ and idx=0
    Executing: UPDATE songs SET title=’Top 40′,artist=”,album=”,genre=”,comment=”,type=’pls’,composer=”,orchestra=”,conductor=”,grouping=”,url=’http://scfire-ntc0l-1.stream.aol.com:80/stream/1074′,bitrate=128,samplerate=0,song_length=0,file_size=63,year=0,track=0,total_tracks=0,disc=0,total_discs=0,time_modified=1164752509,db_timestamp=1164904731,bpm=0,disabled=0,compilation=0,rating=0,sample_count=0,codectype=” WHERE path=’/home/Disk1/Aud/Radios/top_40.url’ and idx=0
    Rows: 1
    Executing: insert into updated (id) select id from songs where path=’/home/Disk1/Aud/Radios/top_40.url’ and idx=0

    Can you tell what the problem is ?
    Thanks.

    #7395

    rpedde
    Participant

    @bboons wrote:

    Executing: insert into updated (id) select id from songs where path=’/home/Disk1/Aud/Radios/top_40.url’ and idx=0

    That looks like it’s inserting okay. Don’t you see it? What client are you using?

    #7396

    bboons

    @rpedde wrote:

    That looks like it’s inserting okay. Don’t you see it? What client are you using?

    I’m using the Soundbridge M1000 with the latest F/W.
    BTW, I did some major reshuffling of files and stuff and now the radio .url file appears to be working.
    Thanks for your input.

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.