You are here: Home » Topic » Firefly Bonjour Plugin listening on wrong network interface

Firefly Bonjour Plugin listening on wrong network interface

FireFly Media Server (formerly mt-daapd) Firefly Media Server Forums Firefly Media Server Setup Issues Firefly Bonjour Plugin listening on wrong network interface

This topic contains 3 replies, has 2 voices, and was last updated by  rpedde 10 years, 2 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #1555

    seppderdepp

    My Setup:

      * mt-daapd/Firefly Version: Version svn-1586
      * Server Operating System: Linux 2.4.27-uc1 #1767 armv5b unknown
      * Server Hardware: Freecom FSG-3 Storage Gateway
      * Client Device: Pinnacle/Roku Soundbridge M1001, iTunes 7.1 for Macintosh
      * Also tried using: Bonjour Network Browser
      * Connection of clients: Crossover cable, 100 MBit router, wireless access point
      * about 10000 mp3 songs on NAS HD

    Summary:
    I noticed that firefly bonjour serves on my WAN interface which is usually connected to the internet. Additionally I see that the default firewall settings of the FSG-3 are not compatible with the bonjour protocol.
    Summary of the problem:
    Firefly Bonjour Network only reachable on the outside interface of my NAS.

    A closer discussion:
    After successfully installing firefly with IPKG (nightly version that supports Pinnacle Soundbridge) I did this steps:

      * Create a guest user
      * Commented out the “killall” part of the startup script since FSG-3 does not have the pid* command installed
      * Created a symlink of the startup script to /etc/rc
      * Started the firefly server manually with “-d 9 -f” flags
      * Removed a mp3 file that caused firefly to crash

    After that I noticed that neither iTunes nor Soundbridge could access firefly, although it is possible to see the configuration web page I tested various things.

    1.) Permit all network access on the FSG-3

      iptables -F INPUT
      iptables -P INPUT ACCEPT
      iptables -F OUTPUT
      iptables -P OUTPUT ACCEPT
      iptables -F FORWARD
      iptables -P FORWARD ACCEPT

    2.) Used Bonjour Browser (http://www.tildesoft.com)
    3.) Tried the internal/LAN port as well as the outside/WAN ports to connect to both Soundbridge and iTunes Mac

    Results:
    – Firefly seems to broadcast (?) bonjour pakets on my Outside/WAN interface exclusively
    – iTunes successfully communicates with the firefly server, also loading the firefly playlists when connected to the WAN port, but not on the internal ones
    – The same with the Soundbridge
    – Bonjour Browser also shows the DAAP server when connected to the outside port only

    Questions:
    I can cope with the firewalling and all other issues but I do not know why or how the firefly bonjour server is using my outside ethernet interface. Does someone have an idea on how to configure it to work with my internal interfaces (exclusively)?

    Thank you.

    #11670

    rpedde
    Participant

    @seppderdepp wrote:

    I can cope with the firewalling and all other issues but I do not know why or how the firefly bonjour server is using my outside ethernet interface. Does someone have an idea on how to configure it to work with my internal interfaces (exclusively)?

    Thank you.

    There isn’t a configurable option for that right now. I *had* some stuff hacked up for interface selection with the old (aspl-licenced) rendezvous stuff, but haven’t put it back in this version.

    Mostly because it seemed to be little used, as rendezvous seemed pretty smart about picking interfaces to bind to.

    Apparently not *that* smart.

    I can hack the code back in for interface selection and see what that does.

    — Ron

    #11671

    fantux
    Participant

    I’d like to follow up on this. In my Server (Debian Etch) I have one Interface with multiple IP adresses. Sometimes (always?) mt-daapd announces itself using the wrong IP-Address.
    My guess is, that the first IP that was assigned to the interface is used which – in my case – is the wrong one. So I’d like to second this request for configurable interface selection.

    #11672

    rpedde
    Participant

    @fantux wrote:

    I’d like to follow up on this. In my Server (Debian Etch) I have one Interface with multiple IP adresses. Sometimes (always?) mt-daapd announces itself using the wrong IP-Address.
    My guess is, that the first IP that was assigned to the interface is used which – in my case – is the wrong one. So I’d like to second this request for configurable interface selection.

    I looked at the code a while back (but forgot to post back to this thread). It looks like the code actually honors the “interface” value in the “general” section. Drop in the device name, and it should work.

    Try it and let me know.



    [general]
    interface=eth0

    — Ron

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.