You are here: Home » Topic » Firefly, Belkin F5D7132UK WURE and multicasting problem

Firefly, Belkin F5D7132UK WURE and multicasting problem

FireFly Media Server (formerly mt-daapd) Firefly Media Server Forums Firefly Media Server Setup Issues Firefly, Belkin F5D7132UK WURE and multicasting problem

Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #1664
    be4con
    Participant

    I’m running a Roku M1001 with static IP wired to a Buffalo WBMR-G54. The Buffalo connects wirelessly to a Belkin F5D7132UK Wireless G Universal Range Extender which is then wired to my pc.

    The pc runs Firefly.

    I can connect the Roku to the net to update software, listen to radio etc but I cannot see Firefly. With the WURE out of the picture I can get Firefly on the Roku OK.

    I’ve searched the forums and found that this is probably due to the Belkin not forwarding multicasting/unicasting. I’m a relative noob though and this means precious little to me. I understand that I probably have to configure the Belkin to do this but can’t find a way to do so. Belkin support have so far been useless. They just give me the standard rubbish about resetting and reconfiguring the WURE without addressing the specific problem in hand.

    Without the Belkin I get Firefly but with constant rebuffering, with it I get perfect internet radio with no rebuffering but no Firefly. I’m not firewalled, turning off my firewall makes not a jot of difference.

    I’m hoping maybe someone will read this and be able to help me configure the Belkin, or failing that tell me what other manufacturers WURE I can buy that will forward Firefly, so I can cut my losses, sell the Belkin and finally get my Roku running the way I know it should be able to.

    Thanks a lot.

    #12235
    Anonymous
    Inactive

    OK, first up Roku advise against ‘double hopping’ – router/Access Point/range extender combo – says it’s more trouble than it’s worth… but I also have this kind of set up and it works pretty well.

    I have a F5D7130 Belkin AP/extender so on my experience here are some suggestions:

    Make sure your AP is in the same IP range as the router but outside the 2-100 numbers. ie. my router is 192.168.2.1, the AP is 192.168.2.254 and make sure the subnet mask is the same (255.255.255.0)

    Obviously make sure both devices are on the same channel – and whilst you’re at it, maybe change away from the router’s default as probably you & half your neighbours are all on the same channel thus causing more interference. You’d need to hook up the AP to the router to change the AP’s channel as once you’ve done the router the AP won’t communicate wirelessly with it whilst on the original channel (of course…)

    If you have the following options on the AP then in Wireless>Channel & SSID set the wireless mode to 54gLRS and if you have turbo mode set it to frame bursting. Ideally your router will have the same/similar options.

    On your router’s config page, you should have a wireless bridge option – go in there, set Bridge Mode to Manual and put in the WLAN & LAN MAC addresses which you’ll find on the bottom of your AP.

    Give that a whirl – hope it helps… Andy

    #12236
    be4con
    Participant

    Thanks Andy

    I forgot to mention that I did originally have the system set up with the router wired to the pc and the WURE wired to the Roku and suffered the same problem: The Roku got perfect internet radio but no Firefly. So I am confident that the Router and WURE are communicating well up to a point.

    I have already done most of what you have suggested: The IPs on my network are all static, the router sis 192.168.11.1 and the WURE is 192.168.11.254. They are both on the same channel and it is the best channel I could find using Network Stumbler. The WURE is on 54gLRS. The only thing I haven’t done is set the bridging to manual and entered the WURE MAC address. I’ll give that a try and report back.

    Thanks

    Edit:

    I’ve looked in my Buffalo config page and it’s a tad confusing. I have the option of setting Bridge Filters but no option to set bridging to manual, I assume this is what you mean?

    The Bridge Filters options allow me to set a source and a destination MAC address; a source and destination port (Any or Ethernet in each case); a Protocol (PPPoE Session, PPPoE Discovery, IPX – Ethernet II, RARP, IPv6, IPv4 or Any) and finally whether to Deny or Allow.

    Can you offer me any advice of what options I should set here?

    #12237
    Anonymous
    Inactive

    I’ve looked in my Buffalo config page and it’s a tad confusing. I have the option of setting Bridge Filters but no option to set bridging to manual, I assume this is what you mean?

    The Bridge Filters options allow me to set a source and a destination MAC address; a source and destination port (Any or Ethernet in each case); a Protocol (PPPoE Session, PPPoE Discovery, IPX – Ethernet II, RARP, IPv6, IPv4 or Any) and finally whether to Deny or Allow.

    No guarantees here but would suggest that your ‘source’ is the router and ‘destination’ is the AP – not sure about the port but would sit on the fence with ‘Any’ to start with.
    Regards protocol – that’s the way your broadband connection is configured in the router/modem and checking mine it’s PPPoA rather than PPPoE. Have a look in your router setup page and search in Internet WAN>Connection Type and see how you’re configured – that would point you in the right direction as to the protocol you should specify.
    Lastly, logic would seem to dictate that you’re Allowing rather than Denying.

    Although it shouldn’t really be an issue, I think this kind of illustrates the problems of mixing networking equipment from different manufacturers and making them communicate with each other. 🙄 If one config doesn’t improve things, try another combination. But best to back up your original router settings first so that it if it all goes pear-shaped at least you can do a hard reset of the modem/router and reinstall your previous settings.

    Once it’s working properly you should in theory see the activity light on the AP blinking as it streams to the SB. Pinging it would also make sense to see that you’re getting a good connection through to it (I average 2ms when pinging from the router to AP).

    andy

    #12238
    be4con
    Participant

    Thanks again Andy

    I’ve tried every possible combination but no success. I’m still faced with perfect internet radio but no Firefly.

    I tried pinging the AP but I only have the MAC from the base of the unit. Strangely it isn’t listed as a connected item as any of the routers DHCP clients or in the log. Is this maybe because it is just acts as an extension of the router on the network? I can ping the router (which is only connected wirelessly through the AP) and get a response time of 1ms.

    I’m beginning to think that the Belkin just isn’t compatible in any way. So much for it being a Universal Range Extender huh? 🙄

    If you have any other ideas on what I might try next then I’d be delighted to hear them. Otherwise thanks for your help so far.

    I’m looking at getting a separate 10dbi antenna for the buffalo to see if that will do the trick in extending my network so I can cut out the Belkin altogether.

    #12239
    Anonymous
    Inactive

    I tried pinging the AP but I only have the MAC from the base of the unit. Strangely it isn’t listed as a connected item as any of the routers DHCP clients or in the log.

    now that does seem weird. To confirm – you are pinging 192.168.11.254? If it’s not responding at all then something somewhere in the setup is evidently wrong and so the AP obviously wouldn’t be extending your range as it’s not on the LAN.

    At that point I fear I’m right out of suggestions and sounds like your antenna would be a good bet.

    Just out of interest though, if you have the SB right up close to the router when it’s wireless, does firefly appear as a server on the display? Equally, can you confirm that firefly appears as a share in iTunes? And how far away from the router before you lose firefly?

    #12240
    be4con
    Participant

    Thanks again Andy.

    Oops, told you I was a relative noob 🙂

    Nope I didn’t try pinging that IP. I just did ipconfig /all and as it wasn’t listed I must admit I gave up at that point. When I ping 192.168.11.254 it’s there with a time of 3ms.

    I’ve had my SB since Jan 2007. The router I have only had since July. My SB worked well with a BT voyager router that I used to have but I did get rebuffering problems with Firefly, when the BT router died I replaced it with the Buffalo as it was listed on the Roku website as a good bet and I was hoping it would cure the rebuffering problems.

    As it happens it gives me more rebuffering problems than the BT router did.

    That said, if I remove the AP from the network and have just the router wired to the pc and the SB wirelessly connected then I get Firefly on the SB, but I get internet blackspots around the house (which was 1 reason for the need for a WURE) and I get frequent rebuffering on the SB and occasional drops of the network which need a reboot and re-entry of the WPA key to repair (which was the other.)

    I’m not sure how far away I have to be before I get these problems, but to give you an idea the SB is at the front of the house on the ground floor and the pc is on the first floor at the back of the house. It’s only about 15m in a straight line, through 2 internal walls.

    Firefly appears in iTunes as a share.

    #12241
    Anonymous
    Inactive

    I’m not sure how far away I have to be before I get these problems, but to give you an idea the SB is at the front of the house on the ground floor and the pc is on the first floor at the back of the house. It’s only about 15m in a straight line, through 2 internal walls.

    similar to my setup… and truth be told I did get rebuffering from time to time, now completely cured by investing in a NSLU2 and going down the NAS route… but that’s another story 😆

    however, what I never got was firefly not showing on the SB and that seems pretty weird indeed. Not sure if anyone else has experienced that either – I don’t recall reading any posts regards that. Certainly the rebuffering is a constant headache for wireless users and no doubt you’ve read the moans here and on the roku forums in that respect.

    When I ping 192.168.11.254 it’s there with a time of 3ms.

    well that doesn’t seem to too bad in the circumstances and shows that there is communication to/from the AP but I still don’t understand why having the AP in the sytem would cause firefly to fail in the entirety…

    The only other thing I can think of is if there’s some reason why the AP is blocking/interfering with the ports used by firefly. Assuming you’re on windows (not my forte) check the ports you need to have open – TCP & UDP – and have a scout around the router & AP to see if there’s some sort of option to open them up. But to be honest, I’m scrabbling around in the dark on that suggestion. Generally the ports would be set in your firewall permissions though you mentioned earlier you’re not firewalled anyway.

    I’m no great expert and not sure I can offer much more. I guess if the buffalo antenna is not too pricey then it’s worth giving it a go…

    Anyone else want to pitch in with some bright ideas…? 😯

    andy

    #12242
    rpedde
    Participant

    Anyone else want to pitch in with some bright ideas…? 😯

    andy

    The only thing I could think would be to check the regular stuff… go into the web admin pages of all the devices between the pc and the device, and see if there are settings to enable multicast or to enable igrp. If so, turn them on and see what that does.

    #12243
    be4con
    Participant

    There doesn’t seem to be any such settings on the AP, I have mailed Belkin to ask them if there is some hidden configuration page somewhere that has these options but they haven’t deemed it worthy of response. Because the router alone delivers Firefly to the SB I assume that multicasting is already switched on on the router.

    I have ordered a 10dbi antenna from ebay, we shall see if that does the trick when it arrives. It was dirt cheap though so may well be trash, but I figured it worth the few pounds.

    If that doesn’t work I can see me giving up and getting a NSLU myself if I carry on getting these problems. The Roku has so much potential, it’s been the most satisfying and most frustrating piece of technology I own in almost equal measures.

    Thanks for all the advice and assistance so far, I’ll report back when the antenna arrives to let you know if I sorted it, or if Belkin ever get back in touch.

    #12244
    be4con
    Participant

    I’m delighted to say that the new antenna on the Buffalo seems to have solved the network problems. 😀

    I wish I’d tried it first as the antenna only cost me £3.49 plus P&P and the Belkin was £30. I guess you live and learn.

    I’ve decided to keep the Belkin and just plug it in occasionally when I want to go online with my PS3 which is the other end of the house to the router now, but to keep it unplugged the rest of the time so that the SB doesn’t ever try to connect to it.

    Thanks for all the help trying to get my setup to work with Firefly though.

    #12245
    Anonymous
    Inactive

    Hi,
    Did you be4con or anyone else ever resolve this issue?
    I have the same range extender, and a soundbridge, with FireFly running on a LinkStation Live connected to the main router by wire. As per the above posts, if the sb connects to the WURE, it cannot ‘see’ the firefly server but can connect to internet radio, whereas directly connected to the router there is no problem (other than rebuffering due to noise). I see that Belkin have not updated the firmware for the extender and guess they are unlikely to do so now as the device is a few years onto the market. In testing, I set my router to refuse connection from my laptop, so that the laptop would only be able to connect to the WURE to get onto the network. I then accessed the firefly interface on port 3689, and then ran the DAAP applet and it streamed music to the laptop fine, so I’m not quite sure why the SB can’t see FF when connected to the WURE. I’m not sure if this is a valid test, but I assume the applet runs locally so must be receiving the data via the correct ports…

    #12246
    rpedde
    Participant

    @jpcwebb wrote:

    Hi,
    Did you be4con or anyone else ever resolve this issue?
    I have the same range extender, and a soundbridge, with FireFly running on a LinkStation Live connected to the main router by wire. As per the above posts, if the sb connects to the WURE, it cannot ‘see’ the firefly server but can connect to internet radio, whereas directly connected to the router there is no problem (other than rebuffering due to noise). I see that Belkin have not updated the firmware for the extender and guess they are unlikely to do so now as the device is a few years onto the market. In testing, I set my router to refuse connection from my laptop, so that the laptop would only be able to connect to the WURE to get onto the network. I then accessed the firefly interface on port 3689, and then ran the DAAP applet and it streamed music to the laptop fine, so I’m not quite sure why the SB can’t see FF when connected to the WURE. I’m not sure if this is a valid test, but I assume the applet runs locally so must be receiving the data via the correct ports…

    The issue is multicast, which is the discovery mechanism that the soundbridge (and iTunes) use to discover other itunes servers. The WURE passes tcp okay, but not multicast. Which means that the soundbridge can’t locate the server, and no music. 🙁

    #12247
    Anonymous
    Inactive

    Well, in an effort to get a repeater working, I discovered that another Access Point on my network will operate in repeater mode, and I know that it does support multicast as I have used it to pick up Wake-on-LAN signals set as a multicast signal (an Edimax EW-7206APg). However, whilst is seems to work fine with my laptop, the SB seems to want to connect to it in wireless B mode instead of G, so of course the WPA encryption fails. This is weird behaviour. I’m going to try to switch the repeater to protected (G) mode only tonight to see if it will connect, but I am confused as to why the SB would try mode B first and not recognise that it can use wireless G…
    Might try RokuLabs forums to see if they know what’s wrong.

    Incidentally, why doesn’t this forum like the word ‘d e t e r m i n e’?

    #12248
    rpedde
    Participant

    @jpcwebb wrote:

    Incidentally, why doesn’t this forum like the word ‘d e t e r m i n e’?

    Ah, just admit you are a spammer. 🙂

    Truthfully, there were a bunch of spammers spamming ermine coats or something and I plonked the word, but apparently the spam word thing was a little *too* aggressive.

    Lol.

    Wonder how many unsuspecting people that has hit. 🙂

    Fixed now.

    — Ron

Viewing 15 posts - 1 through 15 (of 16 total)
  • The forum ‘Setup Issues’ is closed to new topics and replies.