You are here: Home » Topic » Firefly + Amarok = songs truncated

Firefly + Amarok = songs truncated

This topic contains 5 replies, has 2 voices, and was last updated by  hfeinman 10 years, 3 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #1546

    sdbd29
    Participant

    Hi everybody

    I’m using firefly for just few days but it really rocks ^^

    My server runs ubuntu 7.04 with mt-daapd 0.2.4 (ubuntu package)

    At home i’m using a mac with iTunes7.0.3 on my local network, the shared library is found and everything is Ok.

    Since firefly is really great I want to use it every where, my Laptop running ubuntu 7.04 I’m trying to use my shared library over the internet using amarok feature.
    I specified my server adress, found the library, connected to it, added songs to the amarok playlist and play it πŸ˜€
    It rocks, well not exactly because amarok does not play end of songs, it pass to the next song.
    It does not depend on songs length (I tried with songs of 1min10 and 5min30), the truncated part has not always the same length (from 30s to 2min).

    The mt-daapd logfile is ok : I mean there are no errors.

    If anyone has a hint ?

    My configuration :
    server: ubuntu 7.04 with firefly 0.2.4 package

    client : ubuntu 7.04 with amarok 1.4.5 or 1.4.6 (I tested the two versions, same problem)

    #11638

    sdbd29
    Participant

    I did a ssh tunnel redirecting my server:3689 to localhost:3689, to see if it works better.

    Amarok can see my firefly library, and it works better but not perfectly !

    Playing the same songs as previously, now between 5 and 15 seconds are skipped at the end.

    I followed :
    http://wiki.mt-daapd.org/wiki/SSH_Tunnel

    and more exactly this : http://nozell.com/blog/2006/11/29/access-a-remote-daap-share-by-tunneling-over-ssh-ubuntuedgy/
    for ubuntu (linux)

    I do not manage to make Banshee find my library anyway, only Amarok can but still with truncated songs

    #11639

    sdbd29
    Participant

    😳 Getting at home tonight, trying Amarok on my laptop in my local network –> same problem.

    Seems to be a bug in amarok or my configuration of amarok. I’m gonna cry for help at Amarok forums πŸ˜‰

    #11640

    rpedde
    Participant

    @sdbd29 wrote:

    😳 Getting at home tonight, trying Amarok on my laptop in my local network –> same problem.

    Seems to be a bug in amarok or my configuration of amarok. I’m gonna cry for help at Amarok forums πŸ˜‰

    Hrm… that’s kinda strange.

    Are these mp3 files, or transcoded files?

    #11641

    sdbd29
    Participant

    My files are mp3 files. And exatly the same files from the firefly server play well with iTunes.

    In Amarok forum I found this :
    http://amarok.kde.org/forum/index.php/topic,13561.0.html
    the “bug” seems to exist with version 1.4.4, 1.4.5 and 1.4.6.

    I’m going to try with banshee, in fact found why with ssh tunnel it doesn’t see my shared library …

    #11642

    hfeinman

    I love mt-daapd, it gives me the freedom to select anything from my library and play on my HiFi with just a few keystrokes. But,

    I also have this problem. I am running on a fedora 5 server, transcoding. Works fine on my XT laptop with itunes, truncates the last 5 or 10 seconds when using amarok on the server.

    I see there is no further discussion of this topic over in the amarok forum. I’ll try adding my voice over there.

    Thanks, H

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.