File size limit exceeded when mt-daapd.log>2GB

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #1788
    oliver
    Participant

    When I tried to start up mt-daapd it just said “File size limit exceeded” and wouldn’t start. However, a few minutes ago I discovered that this error was talking about my mt-daapd.log (optional setting in mt-daapd.conf), that had grown above 2GB. It appears that mt-daapd won’t start if the log file is larger than 2GB.

    Maybe this is a feature rather than a bug though, in my case the log file would have kept growing until my root partition was all used up. My logfile had grown very fast becaus of my debuglevel setting, that was set to 9.

    Maybe this error should say “Logfile size limit exceeded” rather than “File size limit exceeded”. That would make it easier to understand, I believe. 😀 I use svn-1668 by the way.

    Anyway, Thanks for a great piece of software, I use it daily. 🙂

    #12797
    S80_UK
    Participant

    Could be a feature of your operating system…? FAT32 has a 2 gig limit for each file.

    #12798
    oliver
    Participant

    @S80_UK wrote:

    Could be a feature of your operating system…? FAT32 has a 2 gig limit for each file.

    Hm I don’t think so. But then I’m no expert. I’m running ubuntu server (“2.6.15-26-server”), and my root partition’s filesystem is ext2.

    #12799
    S80_UK
    Participant

    OK, it was only a guess – Ext2 goes to 16G with a 1k block size (larger with larger blocks) so something else is responsible.

    http://en.wikipedia.org/wiki/Ext2

    #12800
    rpedde
    Participant

    @oliver wrote:

    When I tried to start up mt-daapd it just said “File size limit exceeded” and wouldn’t start. However, a few minutes ago I discovered that this error was talking about my mt-daapd.log (optional setting in mt-daapd.conf), that had grown above 2GB. It appears that mt-daapd won’t start if the log file is larger than 2GB.

    Maybe this is a feature rather than a bug though, in my case the log file would have kept growing until my root partition was all used up. My logfile had grown very fast becaus of my debuglevel setting, that was set to 9.

    Maybe this error should say “Logfile size limit exceeded” rather than “File size limit exceeded”. That would make it easier to understand, I believe. 😀 I use svn-1668 by the way.

    Anyway, Thanks for a great piece of software, I use it daily. 🙂

    The real fix is 64 bit file support. I need to find a >2G *something* to test with, though.

    Maybe I should just grow my logs to 2G like you did. 🙂

    #12801
    solexx
    Guest

    @rpedde wrote:

    The real fix is 64 bit file support. I need to find a >2G *something* to test with, though.

    That’s easy (if you run Linux): dd if=/dev/zero of=2gigfile bs=1M count=1025.

    This will give you give you 2GB+1MB of zeroes. May even be sent around by mail if compressed. 😉

    #12802
    rpedde
    Participant

    @solexx wrote:

    @rpedde wrote:

    The real fix is 64 bit file support. I need to find a >2G *something* to test with, though.

    That’s easy (if you run Linux): dd if=/dev/zero of=2gigfile bs=1M count=1025.

    This will give you give you 2GB+1MB of zeroes. May even be sent around by mail if compressed. 😉

    hrm… yeah, but that’s less than useful, as it isn’t an mp3 file or something I can stream. 🙂

    — Ron

    #12803
    beeka
    Participant

    @rpedde wrote:

    it isn’t an mp3 file or something I can stream. 🙂

    Maybe you could copy an mp3 file to the beginning and end of the 2gb of zeros? My first thought was to concatenate 2gb of mp3 files into one, but a core of zeros might be easier… Of course, testing could take quite a while if you have to stream to the 2gb mark before you find errors 😉 (nearly four hours even if it was wave audio)

    Steve.

    #12804
    Anonymous
    Inactive

    I’m guessing this is why all the video content I have that is larger than 2GB doesn’t show up?


    Steve

    #12805
    rpedde
    Participant

    @smcclay wrote:

    I’m guessing this is why all the video content I have that is larger than 2GB doesn’t show up?


    Steve

    Probably. How to you generate a m4v that large?

    #12806
    Anonymous
    Inactive

    @rpedde wrote:

    @smcclay wrote:

    I’m guessing this is why all the video content I have that is larger than 2GB doesn’t show up?


    Steve

    Probably. How to you generate a m4v that large?

    I use eyeTV on a Mac to record TV shows.

    You could try using something like Handbrake from http://handbrake.m0k.org/ to rip a DVD to m4v.

    #12807
    rpedde
    Participant

    @smcclay wrote:

    @rpedde wrote:

    @smcclay wrote:

    I’m guessing this is why all the video content I have that is larger than 2GB doesn’t show up?


    Steve

    Probably. How to you generate a m4v that large?

    I use eyeTV on a Mac to record TV shows.

    You could try using something like Handbrake from http://handbrake.m0k.org/ to rip a DVD to m4v.

    Of course I tried that and got a 1g file. Guess I’ll try again at higher quality. 🙂

Viewing 12 posts - 1 through 12 (of 12 total)
  • The forum ‘Nightlies Feedback’ is closed to new topics and replies.