You are here: Home » Topic » Feisty Fawn + mtdaapd = Bonjour won’t start…

Feisty Fawn + mtdaapd = Bonjour won’t start…

FireFly Media Server (formerly mt-daapd) Firefly Media Server Forums Firefly Media Server Setup Issues Feisty Fawn + mtdaapd = Bonjour won’t start…

This topic contains 12 replies, has 5 voices, and was last updated by  rpedde 10 years, 6 months ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #1308

    nathanziarek
    Participant

    mt-daapd/Firefly Version: svn-1376
    Server Operating System: Ubuntu 7.03 Feisty Fawn
    Server Hardware: Pentium 4, 2500 MHz
    Client Device: iTunes 7.1 for Mac
    Connection of clients: Mac through router (connection working)

    The computer, other than some ffmpeg stuff, is a brand new install.

    To install Firefly Media Server, I simply used

    sudo apt-get mt-daapd

    It installed without a fuss. I logged into the web administration and changed my settings (Server Name, file types, etc). Everything took. When the server didn’t show up in iTunes, I first restarted the daemon

    sudo /etc/init.d/mt-daapd restart

    before noticing that in the web interface it says Bonjour is stopped.

    I stopped the daemon and ran

    sudo mt-daapd -f

    to see what sort of errors I received. Thing is, it worked fine. The server showed up in iTunes and I was able to stream my music and videos.

    I know I am not using the latest nightly version, so perhaps this is a worthless report. I was trying to come up with an easy way to get it all installed, and using apt-get certainly fits the bill 🙂

    Thanks,

    Nate

    #10208

    nathanziarek
    Participant

    Looks like this guy is having the same problem, so no need for the duplicate thread…

    #10209

    rpedde
    Participant

    @nathanziarek wrote:

    mt-daapd/Firefly Version: svn-1376
    Server Operating System: Ubuntu 7.03 Feisty Fawn
    Server Hardware: Pentium 4, 2500 MHz
    Client Device: iTunes 7.1 for Mac
    Connection of clients: Mac through router (connection working)

    The computer, other than some ffmpeg stuff, is a brand new install.

    To install Firefly Media Server, I simply used

    sudo apt-get mt-daapd

    It installed without a fuss. I logged into the web administration and changed my settings (Server Name, file types, etc). Everything took. When the server didn’t show up in iTunes, I first restarted the daemon

    sudo /etc/init.d/mt-daapd restart

    before noticing that in the web interface it says Bonjour is stopped.

    I stopped the daemon and ran

    sudo mt-daapd -f

    to see what sort of errors I received. Thing is, it worked fine. The server showed up in iTunes and I was able to stream my music and videos.

    I know I am not using the latest nightly version, so perhaps this is a worthless report. I was trying to come up with an easy way to get it all installed, and using apt-get certainly fits the bill 🙂

    Thanks,

    Nate

    Is it possible you had an old version installed before that? 0.2.4, maybe?

    And was avahi running before you started it the first time?

    #10210

    mrblack
    Participant

    the apt-get install wont work.

    I wrote this little blog post about how I got it working with fiesty (with a shh tunnel as well), you may want to grab the latest .deb to be sure of it working.

    http://www.mrblack.co.uk/blog/2007/04/02/tunnelling-music-from-ubuntu-to-itunes-via-ssh/

    #10211

    CCRDude
    Participant

    Ubuntu and Bonjour?

    If you want to use Avahi, you have to manually enabled Avahi somewhere… Ubuntu has a zero-unnecessary-open-port-policy (or whatever they call it), so even if you install avahi, it won’t be open until you say so in its (?) config file.

    #10212

    nathanziarek
    Participant

    Is it possible you had an old version installed before that? 0.2.4, maybe?

    And was avahi running before you started it the first time?

    I guess it is possible that I had an old version, but I had _just_ finished installing Ubuntu from scratch. So if it was there, it would have to come with the default installation.

    I think your Avahi question is dead-on though. Looking through my history, I did run

    sudo /etc/init.d/avahi-daemon restart

    Everything appears to be working fine now (music and videos stream nicely). The only oddity is that in the server status it says Bonjour Stopped. We’ll see what happens after a restart, but I think I can live with that 🙂

    #10213

    nathanziarek
    Participant

    Thank you mrblack. Turns out I couldn’t leave well-enough alone. 😛

    My steps:

    sudo apt-get remove mt-daapd
    sudo apt-get install libid3tag0
    wget http://prdownloads.sourceforge.net/mt-daapd/mt-daapd_0.2.4-1_i386.deb?download
    sudo dpkg -i mt-daapd_0.2.4-1_i386.deb
    sudo /etc/init.d/mt-daapd restart

    … which provides the error …

    Restarting mt-daapd: Invalid config directive: db_type
    Error reading config file (/etc/mt-daapd.conf)

    I tried both sqlite and sqlite3. Other than that, I made no changes, and this is the config that was working two minutes before with the apt-get version.

    I’m also a little confused about the versioning. apt-get gave me 0.2.4, which is being called an “old version.” But the latest release on sourceforge also appears to be 0.2.4. Am I missing something?

    #10214

    nathanziarek
    Participant

    OK, well, I don’t have any idea what is going on. I removed the custom config file, resintalled mt-daapd using mrblack’s method, edited the newly created config and it all starts up fine. When I go to the web page, though, it is the old non-AJAXy version. I was starting to really dig the new one.

    So, since it seems I am running the same version anyway, I guess I’ll just go back to the apt-get version (unless I should go to a nightly, but I’m guessing you all would get sick of me pretty quick if I was using an unstable verion 🙂

    Advice, as always, is appreciated.

    Nate

    #10215

    rpedde
    Participant

    @nathanziarek wrote:

    OK, well, I don’t have any idea what is going on. I removed the custom config file, resintalled mt-daapd using mrblack’s method, edited the newly created config and it all starts up fine. When I go to the web page, though, it is the old non-AJAXy version. I was starting to really dig the new one.

    So, since it seems I am running the same version anyway, I guess I’ll just go back to the apt-get version (unless I should go to a nightly, but I’m guessing you all would get sick of me pretty quick if I was using an unstable verion 🙂

    Advice, as always, is appreciated.

    Nate

    I’d not use 0.2.4. It’s *old*.

    #10216

    mrblack
    Participant

    Yeah the ace new firefly web stuff is only really availible on the nightly releases.

    Over here …

    http://nightlies.mt-daapd.org/

    Grab the .deb labelled edgy and you should have funky new-admin-ness.

    #10217

    William_Syd
    Participant

    When you apt-get on Feisty you get..

    Firefly Media Server, version svn-1376.

    Then in /etc/event.d/ create a file called mt-daapd and paste into it the following….

    start on startup

    stop on runlevel 0
    stop on runlevel 6


    respawn

    exec /usr/sbin/mt-daapd -f

    and save.

    To start, type

    sudo start mt-daapd

    To check the status…

    sudo status mt-daapd

    I still get Bonjour stopped. Music still arrives at iTunes.

    #10218

    William_Syd
    Participant

    Looking into this a little more..

    Does avahi have to be started before mt-daapd ?

    /etc/init.d/mt-daapd
    /etc/rc0.d/K20mt-daapd
    /etc/rc1.d/K20mt-daapd
    /etc/rc2.d/S20mt-daapd
    /etc/rc3.d/S20mt-daapd
    /etc/rc4.d/S20mt-daapd
    /etc/rc5.d/S20mt-daapd
    /etc/rc6.d/K20mt-daapd
    /etc/init.d/avahi-daemon
    /etc/rc2.d/S50avahi-daemon
    #10219

    rpedde
    Participant

    @william_syd wrote:

    Looking into this a little more..

    Does avahi have to be started before mt-daapd ?

    /etc/init.d/mt-daapd
    /etc/rc0.d/K20mt-daapd
    /etc/rc1.d/K20mt-daapd
    /etc/rc2.d/S20mt-daapd
    /etc/rc3.d/S20mt-daapd
    /etc/rc4.d/S20mt-daapd
    /etc/rc5.d/S20mt-daapd
    /etc/rc6.d/K20mt-daapd
    /etc/init.d/avahi-daemon
    /etc/rc2.d/S50avahi-daemon

    Yes, avahi must be stared first.

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.