You are here: Home » Topic » [Fedora 9] Firefly does not start up automatically

[Fedora 9] Firefly does not start up automatically

FireFly Media Server (formerly mt-daapd) Firefly Media Server Forums Firefly Media Server Setup Issues [Fedora 9] Firefly does not start up automatically

This topic contains 3 replies, has 1 voice, and was last updated by  nterry 9 years, 2 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #2639

    Anonymous

    Hi there,

    i have set up a fedora 9 as my music and file server, so it works on runlevel 3.

    i have installed mt-daapd from the official repository – everything worked fine, except of one thing:

    if i configure the service to start up automatically i get the following error message:

    mt-daapd: client.c: 776: avahi_client_errno: Assertion ‘client’ failed.

    and the service does not start.

    if i login after the boot process completed and started the service manually

    /etc/init.d/mt-daapd start

    the service starts manually

    what did i make wrong?

    thanks in advance, lukas

    #17711

    Anonymous

    after some googling, i have found something i could do and it worked!

    you have to put the start-skripts for the different runlevels AFTER avahi!

    so, for me it was:

    in the directories
    /etc/rc.d/rc3.d/
    /etc/rc.d/rc4.d/ (why the hell ever runlevel 4)
    /etc/rc.d/rc5.d/

    mv S85mt-daapd S99mt-daapd

    after a reboot it worked like a charm!

    this would lead to my next question…

    how can i post a bugfix suggestion to the fedora team? πŸ˜‰

    #17712

    Chris.Simmons

    First, thanks, this got me too!

    Now I did a little digging and its now even more solved – it reads this information from the file

    /etc/init.d/mt-daapd

    If you look near the top, change the line

    # chkconfig: – 85 15

    to read

    # chkconfig: – 99 15

    Apparently this is what the chkconfig command reads when building the symlinks. If you change this then you don’t have to manually.

    So I did this (to make sure it cleaned up the old links first):-

    1) chkconfig mtdaapd off
    2) Make above edit
    3) chkconfig mtdaapd on

    Tada!

    I second fixing this too needless to say πŸ™‚

    #17713

    nterry

    Works for me to with FC8. However I needed to do:

    1) chkconfig mt-daapd off
    2) Make above edit
    3) chkconfig mt-daapd on

    Note the addition of the “-” in the mt-daapd. I think that was probably a typo, but may be an FC8/FC9 difference

    Thanks again

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.