You are here: Home » Topic » failed to browse data – CPU issue?

failed to browse data – CPU issue?

This topic contains 4 replies, has 2 voices, and was last updated by  t0m 13 years, 10 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #23

    t0m
    Participant

    Hi Folks!

    I’m expecting browsing problems with SB M1000 and mt-daapd (e.g. failed to browse data)

    regarding to the roku forum this error is because the data cannot be loaded fast enough / the sb is timeout waiting for data..

    I “only” have got ~11200 songs in my db, using wired environment.

    So I wonder if this might be a CPU issue
    mt-daap is running on my debian woody kernel 2.6.2 / Pentium II 350MHz

    #3130

    rpedde
    Participant

    Have you tried the released 0.2.1 version? That has a contributed patch that significantly speeds up transfers.

    I would think that a P-II class machine wouldn’t have a problem speed-wise.

    Also, make sure you have compression turned off — that may (depending) actually make the transfer speed slower, rather than faster as you might imagine.

    That’s where I’d start, anyway.

    #3131

    t0m
    Participant

    Have you tried the released 0.2.1 version?

    Yep.. installed it using your debian package.

    Also, make sure you have compression turned off — that may (depending) actually make the transfer speed slower, rather than faster as you might imagine.

    Hmm, I’ll try that this evening..

    /T0m

    #3132

    rpedde
    Participant

    I’ve been thinking about this today, and another reason it tends to browse slowly is that the browse data is kept in a linked list, and the entire database is enumerated and checked against the list.

    So it’s a n! algorithm to return a browse list, which is complicated by the fact that it’s doing strcasecmp along the whole list.

    I could make it log(n) by using a red/black tree to store the browse list.

    I’ll add that to my “to do shortly” list.

    — Ron

    #3133

    t0m
    Participant

    I’ve turned compression off.
    And browsing seems to be more ‘reliable’.

    Thanks

Viewing 5 posts - 1 through 5 (of 5 total)

The forum ‘General Discussion’ is closed to new topics and replies.