You are here: Home » Topic » Error reading config file. Build 1417 on FC4

Error reading config file. Build 1417 on FC4

This topic contains 3 replies, has 2 voices, and was last updated by  rpedde 10 years, 9 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #925

    niamh
    Participant

    [[email protected] mt-daapd-svn-1417]# /etc/init.d/mt-daapd start
    Starting DAAP server: Error reading config file (/usr/local/etc/mt-daapd.conf)
    [FAILED]

    Copying mt-daapd.conf from /etc to /usr/local/etc enables Firefly to start… but Shouldn’t /etc be the right place for the file?

    #8128

    rpedde
    Participant

    @niamh wrote:

    [[email protected] mt-daapd-svn-1417]# /etc/init.d/mt-daapd start
    Starting DAAP server: Error reading config file (/usr/local/etc/mt-daapd.conf)
    [FAILED]

    Copying mt-daapd.conf from /etc to /usr/local/etc enables Firefly to start… but Shouldn’t /etc be the right place for the file?

    Perhaps. It is if you configure it with –prefix=/usr, but when you use /usr/local as the prefix, it uses $PREFIX/etc.

    I thought that was already fixed though. Maybe not.

    — Ron

    #8129

    niamh
    Participant

    @rpedde wrote:

    Perhaps. It is if you configure it with –prefix=/usr, but when you use /usr/local as the prefix, it uses $PREFIX/etc.

    I thought that was already fixed though. Maybe not.

    — Ron

    I used-
    [[email protected] mt-daapd-svn-1417]# ./configure –prefix=/usr/local –sysconfdir=/etc –enable-sqlite

    So I’d expect the path as specified in sysconfdir to be used as specified… though if of course I’d specified –sysconfdir=etc then I’d expect it to use what it does.

    Whatever it was only a very minor problem easily overcome

    #8130

    rpedde
    Participant

    @niamh wrote:

    I used-
    [[email protected] mt-daapd-svn-1417]# ./configure –prefix=/usr/local –sysconfdir=/etc –enable-sqlite

    Ah, yes. The sysconfdir bug is a known bug, as is putting the shared libraries in pkgdir rather than libdir. Just that armwrestling autoconf is so much work that i tend to put it off as long as I can. :-/

    But thanks for reminding me. Maybe I’m sufficiently rested up to tackle it again. 🙂

    — Ron

Viewing 4 posts - 1 through 4 (of 4 total)

You must be logged in to reply to this topic.