You are here: Home » Topic » Do I ever get this to work

Do I ever get this to work

This topic contains 24 replies, has 2 voices, and was last updated by  rpedde 12 years, 3 months ago.

Viewing 15 posts - 1 through 15 (of 25 total)
  • Author
    Posts
  • #73

    Anonymous

    Hey guys,

    I installed Ubuntu Hairy Hedgehog Linux a few weeks ago, and it actually works excellent B) . Due to the fact that there is no itunes version for linux I wanted to stream mp3’s through my home network using another program and wanted it to show up in iTunes normally on the other computers. I thought this could be exactly the thing I was looking for.

    I followed the documentation exactly, configured everything properly, installed the right programs etc. When I actually run mt-daapt on verbose mode nothing seems wrong and no warning messages appeared. The admin page seems te be accessible from the other computers so I thought it was working fine. But still it isn’t appearing in iTunes on all the computers in my network. I searched for an answer, tried everything, nothing worked. … I surely don’t know what to do now :huh: :blink:

    #3449

    rpedde
    Participant

    This is probably a firewall issue on the server.

    Try the suggestions here in the faq:

    http://wiki.mt-daapd.org/wiki/FAQ#mt-daapd_keeps_dropping_out_of_iTunes

    – Ron

    #3450

    Hoekstone

    Sorry but this is not working. It doesn’t help when I shut down firestarter or when I type those commands in the console. Firestarter doesnt give any warnings also when running. What I can say also is that in the FAQ there is a problem like this ” mt-daapd keeps dropping out of iTunes”. But here mt-daapd never appeared in iTunes.

    #3451

    rpedde
    Participant

    What –configure command did you use?

    #3452

    Hoekstone

    What do you mean ? How I installed the program ?

    #3453

    rpedde
    Participant

    When you compiled the program, what command did you use to configure it?

    or did you install the .deb package?

    Also, as the “showing up in iTunes” thing depends on mdns, it would help to know if you are running Howl or some other mdns provider.

    Also, what documentation did you follow?

    — Ron

    #3454

    Hoekstone

    I installed the program using the .deb package. I have compiled the mdns program of Apple to see if that works when I run it, no luck. Also tried Howl, without result. When I run your program it sais that it uses mDNS right so I didn’t run any of the other programs while mt-daapd was running.

    #3455

    velociped
    Participant

    Two additional questions…

    The admin page seems te be accessible from the other computers so I thought it was working fine. But still it isn’t appearing in iTunes on all the computers in my network.

    When you say “all”, do you mean all or any? If “all” is more accurate, then how does the configuration on the machines which can access the shared library differ from those which cannot?

    Also…and this is a rudimentary check, but it has proven to be the culprit in the past…have you enabled the bit within the iTunes client which searches the local subnet for shared libraries?

    If you have not already done so, you may want to read through this earlier thread regarding a similar issue. The solution never really revealed the true culprit — other than being a Windows idiosyncrasy — but there are several useful troubleshooting tips which may aid in diagnosing and eliminating possible causes.

    Herman

    #3456

    Hoekstone

    When I said “not All” the computers I meant all. Not any of the computers on my home network “sees” my linux box in iTunes, so the blame is not on the configuration of those computers. Sorry for the incompletion of my post. I checked the option in iTunes to search for shared libraries on all of them. When windows was installed on this computer I used iTunes to share my music on the network. It was showing up on all the computers and it was functioning excellent !

    #3457

    velociped
    Participant

    Have you tried testing whether or not iTunes is still “functioning excellent” as a DAAP server?

    From what you describe, it seems unlikely to be an mt-daapd issue. The problem likely has something to do with the Rendezvous/Bonjour/zeroConf beacon. Either it is not broadcasting (i.e. not installed or configured corerctly on the Linux box) or the XP boxes are not detecting it (e.g. a firewall issue or the anomalous XP issue as described in the previously referenced thread). In order to determine which, you will need to analyze the traffic on your subnet.

    Also, if your Windows machines are running SP2 and you have ICF activated, it will be necessary to ensure the required ports (DAAP, TCP 3689; mDNS, UDP 5353) are open to traffic.

    Herman

    #3458

    Hoekstone

    Well, I tested iTunes to see if Daap is still working well when using iTunes as a server on another computer on my network. And it still is “functioning excellent”… One has kerio installed (the “server”, Kerio showed that it was listening on the right ports and sending on the right port”) and the other has Norton installed (the “client”. Norton showed that every port necessary was allowed to pass) and yes! it showed up in iTunes. So the problem must be in my Linux box. I don’t think something is wrong with my rendezvous etc. things, because in foreground mode mt-daapd said that it was starting… :dry: But I’m gonna check the conf file once more to see if I made any mistakes.

    #3459

    rpedde
    Participant

    Yup, I’m with you, it looks like a rendezvous thing.

    Stuff to check:

    1. do a “ps” on your linux box and make sure there isn’t anything related to mdns running. No mDNSResponder, no mDNSProxyResponder, no nifd, no nothing. You might try uninstalling howl as well (apt-get remove –purge howl).

    You said you already downloaded and compiled the apple mdns stuff… let’s use that for testing.

    Run this:


    mDNSProxyResponderPosix 10.10.10.10 test test _daap._tcp. 3689

    You should see a server called “test” pop up in your iTunes. If not, then you have firewall issues.

    If it *does* pop up, then….

    2. Try making sure your servername is something short with no special characters, plain latin1, no spaces, and, say… less than 8 characters. “test” might be good. 🙂

    The length limit should be regular dns length limit, and it should accept utf-8, but let’s start with something simple first.

    3. Again, make sure you don’t have any other mdns things running.

    4. Use netstat to make sure nothing is listening on udp port 5353 — a double-check on the stopping the mdns stuff.

    5. Edit your config file to point the mp3_dir to an empty directory. Then start mt-daapd with a -d9 and a logfile specified in your config file. Let it run a bit, then stop it and take a look at the log file. Hopefully it will tell you something informative.

    — Ron

    #3460

    Hoekstone

    Well, as I said before in this topic I have already tried mDNSResponderPosix. But I did it again, this is what the console sais:
    mDNSResponder: startQuery – no initialized DNS
    mDNSResponder: ERROR: startQuery – -65545 (keeping question in list for retransmission
    mDNSResponder: hndlLookupSOA: startInternalQuery returned error -65545 (breaking until next periodic retransmission)
    Made Service Records for test._daap._tcp.local.
    Service test._daap._tcp.local. now registered and active

    I changed the IP adress to the right one I use on my network (10.0.0.205). It gives a few errors as you can see. It isn’t showing up in iTunes as well. And you said it should be a firewall issue … I told you guys before, I configured them (yes all the firewalls on my network) well and it is also happening when I shut them all off. Also when I use one of the other computers on my network as the server using iTunes itself it works. And I use firestarter as firewall on my linux box and it is also not showing up when I shutted it off.

    #3461

    velociped
    Participant

    I can see where this can become quite frustrating, but we really are trying to help you. 🙂

    The fact that mDNS is returning errors suggests that there is some sort of issue. What does netstat report? Does it show an “*.mdns” entry under the udp protocol section? Does it show a registered address and inode under the active local sockets section?

    It really would help if you could run a sniffer on your subnet in order to look at the quality of the QandA traffic. This would help determine whether it is a beacon or client issue. I am leaning toward beacon/server issue, but the traffic analysis would confirm one way or the other.

    Herman

    #3462

    rpedde
    Participant

    Are there any errors BEFORE the -65545?

    The 65545 means that mdns wasn’t initialized, but I don’t know why it failed to initialize. There should be an error message before that. This is a 32bit intel box, right? Not something esoteric like AMD64 or an ARM box or something, right?

    Did you run the netstat to make sure you weren’t running some other mdns process? I really suspect this.

    As far as the firewall issue goes, did you merely turn it off, or did you add the rules to allow multicast traffic? And did you stop and uninstall Howl?

Viewing 15 posts - 1 through 15 (of 25 total)

You must be logged in to reply to this topic.