You are here: Home » Topic » DLink DIR-655 and Roku SoundBridge M2000 – Making it workpage 2

DLink DIR-655 and Roku SoundBridge M2000 – Making it work

FireFly Media Server (formerly mt-daapd) Firefly Media Server Forums Firefly Media Server Setup Issues DLink DIR-655 and Roku SoundBridge M2000 – Making it work

This topic contains 26 replies, has 7 voices, and was last updated by  toecheese 10 years, 1 month ago.

Viewing 12 posts - 16 through 27 (of 27 total)
  • Author
    Posts
  • #16637

    sssobel

    D-Link released firmware version 1.20 on July 21st. I installed it today, and unfortunately, it doesn’t resolve the incompatibility issue with Firefly/iTunes/SoundBridge.

    #16638

    Anonymous

    1.20 doesn’t work for me either. Very disappointing. Maybe some combination of settings might do the trick but I don’t have time to experiment.

    My Netgear WNR3500 worked very well while it worked except the entire network would just drop out randomly and come back – both wired and wireless connections. Now it seems to have stopped connecting to the internet which is why I tried the 1.20 firmware on my otherwise unused DIR-655.

    Looks like I’ll have to get a replacement from Netgear.

    #16639

    Anonymous

    I’ve just installed Firefly on an Linkstation Pro (stock firmware 1.11) using the standing instructions, but neither of my Soundbridge players (Radio & M400) will see the library on the NAS. They will however connect to both Firefly and Windows Media Player servers on a Vista wireless laptop. The FF service is definitely running on the LS, the Java Firefly Client will happily stream from the library, but that uses an explicit IP/Port connect rather than looking for the multicast. I have a DLink G624T router. The SB’s are on firmware 3.0.54 (I have also downgraded them to 3.0.44 but no joy with that either).

    I’m guessing that the problem is the multicast signal is not getting through the wired-wireless boundary on the router as all the successful connects are wireless-wireless.

    Is the conclusion from those using it that the Netgear WNR3500 router definitely works between soundbridge (Pinnacle branded in my case) devices and a wired server (Linkstation)? I don’t have any ‘n’ devices but the gigabit rate might be useful for backups.

    #16640

    Anonymous

    I just got my DAP-1522 via FedEx today. I set up the access point in bridge mode, made sure it was talking to the router, plugged it into the wall in my living room, hooked up my Roku, and can now enjoy my Firefly server. I know this may not be feasible for most, but I needed the switch capability of the 1522, as I have other network devices hooked up and buying a single-port access point for each was wasting money. Anyway, this setup met my needs and now has my Roku seeing the server again! 😀

    #16641

    Nova

    I’ve had similar problems to those mentioned above with the DIR-655 firmware 1.20. I am using the DIR-655 as a wireless access point, not my internet router. The multicast option is checked in the configuration utility, but the SB apparently isn’t getting the multicast packets as it reports no Firefly.

    I had an old DIR-614+ (also a D-link router) sitting on a shelf, so I plugged it into the same switch that the DIR-655 is on. This router does not have a configuration specifically for multicast (that i can find), yet when I change the preferred wireless network in the SB to the DIR-614+ the Firefly server shows up and everything works fine.

    Given the exact same network topology for both wireless access points, I have to conclude that there is something wrong with the multicast implementation in the DIR-655. Possibly it is only set up to pass multicast packets coming off the WAN side, not the LAN side.

    #16642

    Anonymous

    I found the switch on my DLink G624T router to enable IGMP snooping at last (see above). Its on the QoS page. Enabling this now means Soundbridge can see the Linkstation Firelfy library (hurrah), but only if I leave Bonjour running on the PC (bah!). Have started another thread for this (http://forums.fireflymediaserver.org/viewtopic.php?t=8208).

    #16643

    irjason

    I’m coming in a bit late to the game here. I found this thread after I upgraded the firmware on my DIR-655. I have hardware version A1, and my Roku m-500s were working fine wirelessly with firmware 1.02. I upgraded to 1.21 and my Soundbridges could no longer see Firefly over the wireless. I tried for an hour or so adjusting settings to no avail. Finally I decided to downgrage to 1.02 again.

    After some searching on D-Link’s site I saw that they do not have firmware version 1.02 available for download directly. Snooping about on their ftp server, I was delighted to find it still there. Unfortunately downgrading directly from 1.21 to 1.02 was not possible. I was finally able to get back to 1.02 by downgrading from 1.21 to 1.11 then to 1.02.

    If you’re having trouble and your router is able to run version 1.02 you might want to give this a try. Be sure to back up your settings first!

    You can find the firmares here:
    ftp://ftp.dlink.com/Gateway/dir655/Firmware/

    #16644

    dbsanders

    I had the same problem with firmware 1.21. Now there is a new beta firmware version, 1.22 beta 5, and it seems to resolve the issue. I just upgraded and it seems stable so far (a couple hours). My Roku now sees my Firefly server from wired to wireless!

    Download from D-Link FTP:
    ftp://ftp.dlink.com/Gateway/dir655/Firmware/dir655_firmware_122b05_beta.zip

    #16645

    CtrlX
    Participant

    I tried the beta upgrade, but still no luck 🙁
    Has anyone else got it working with the new beta-firmware?

    #16646

    toecheese
    Participant

    the beta firmware doesn’t work for me, either.

    #16648

    toecheese
    Participant

    anyone ever have any luck with this? I’ve tried firmware 1.32NA and it still won’t see firefly or iTunes.

    #16647

    Anonymous

    Hi toecheese

    I reported problems earlier in this thread last year with my DSL-624T router. That died last week and I replaced it with a DSL-2740B. All the problems I have with firefly on my linsktation NAS have now gone; all Soundbridges connect instantly to firefly, do not lose the server in the menu and I no longer need bonjour running on a PC. All this happened out of the box, no additional settings needed changing on the router. If you need a router with an ADSL modem included, then I would recommend it.

    It does seem odd why router firmware from the same manufacturer should behave differently on their various models.

Viewing 12 posts - 16 through 27 (of 27 total)

The forum ‘Setup Issues’ is closed to new topics and replies.