You are here: Home » Topic » Disabling loading of plugins

Disabling loading of plugins

This topic contains 6 replies, has 3 voices, and was last updated by  Anonymous 10 years, 4 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #1574

    Anonymous

    Hi,

    Excuse me if this question has been answered before – I did some searching and couldn’t find the answer…

    I’ve just upgrade from an ancient version of mt-daapd (from the gdbm days) running on Unslung to the latest nightly running on Debian/Etch. My intent is to run a number of additional apps on the slug (mail sever, webserver with AJAX webmail app) so I need to trim memory usage where I can. Hence, I want to prevent mt-daapd from loading plugins that I don’t need – presumably daap and ssc – leaving just rsp for serving to my soundbridge.

    Do I do this by changing the config file or by deleting (or, at least, renaming) the plugins themselves?

    TIA,

    _

    #11779

    fizze
    Participant

    you can modify the mt-daapd.conf through the webinterface and exclude selceted plugins.
    Be aware though that Linux pretty much swaps out unused memory, as not to clutter RAM.

    dont let you the /proc/meminfo fool you πŸ˜‰

    #11780

    Anonymous

    @fizze wrote:

    you can modify the mt-daapd.conf through the webinterface and exclude selceted plugins.
    Be aware though that Linux pretty much swaps out unused memory, as not to clutter RAM.

    dont let you the /proc/meminfo fool you πŸ˜‰

    Thanks!

    Actually I can’t edit the config file from the web interface since the file is owned by root and mt-daapd is run as user “music” – I’ll stick to modifying it with vi!

    You may have a point about swapping out – I’ve currently got a base Debian install (including OpenSSH and exim4) plus vsftpd, mt-daapd, lighttpd + php and only 49% of the memory is being used for kernel + applications and there is over 2M in swap.

    However, I still want to turn off (probably) DAAP so that the server only shows up once on the soundbridge.

    Thanks again,

    _

    #11781

    rpedde
    Participant

    @Underscore wrote:

    @fizze wrote:

    you can modify the mt-daapd.conf through the webinterface and exclude selceted plugins.
    Be aware though that Linux pretty much swaps out unused memory, as not to clutter RAM.

    dont let you the /proc/meminfo fool you πŸ˜‰

    Thanks!

    Actually I can’t edit the config file from the web interface since the file is owned by root and mt-daapd is run as user “music” – I’ll stick to modifying it with vi!

    You may have a point about swapping out – I’ve currently got a base Debian install (including OpenSSH and exim4) plus vsftpd, mt-daapd, lighttpd + php and only 49% of the memory is being used for kernel + applications and there is over 2M in swap.

    However, I still want to turn off (probably) DAAP so that the server only shows up once on the soundbridge.

    Thanks again,

    _

    Also, depending on version, it might just load all the plugins in the plugin_dir regardless of the settings for plugins. If you find that’s the case, just rename the plugins to something other than .so, as that’s how it decides what to try to load — anything with .so.

    — Ron

    #11782

    Anonymous

    @rpedde wrote:

    @Underscore wrote:

    @fizze wrote:

    you can modify the mt-daapd.conf through the webinterface and exclude selceted plugins.
    Be aware though that Linux pretty much swaps out unused memory, as not to clutter RAM.

    dont let you the /proc/meminfo fool you πŸ˜‰

    Thanks!

    Actually I can’t edit the config file from the web interface since the file is owned by root and mt-daapd is run as user “music” – I’ll stick to modifying it with vi!

    You may have a point about swapping out – I’ve currently got a base Debian install (including OpenSSH and exim4) plus vsftpd, mt-daapd, lighttpd + php and only 49% of the memory is being used for kernel + applications and there is over 2M in swap.

    However, I still want to turn off (probably) DAAP so that the server only shows up once on the soundbridge.

    Thanks again,

    _

    Also, depending on version, it might just load all the plugins in the plugin_dir regardless of the settings for plugins. If you find that’s the case, just rename the plugins to something other than .so, as that’s how it decides what to try to load — anything with .so.

    — Ron

    Thanks, Ron. I’ve added the “plugins = rsp.so” line to my mt-daapd.conf (and commented out the two ssc-related lines) and I now have the server showing up just the once on the soundbridge.

    Cheers,

    _

    #11783

    fizze
    Participant

    …..and I now have the server showing up just the once on the soundbridge.

    That also means that the software on your soundbridge is horribly outdated.
    The double-listing of the firefly-servers has been fixed ages ago. πŸ˜‰

    #11784

    Anonymous

    @fizze wrote:

    …..and I now have the server showing up just the once on the soundbridge.

    That also means that the software on your soundbridge is horribly outdated.
    The double-listing of the firefly-servers has been fixed ages ago. πŸ˜‰

    It shouldn’t be; I’ve only recently (about a month ago) upgraded to the latest version…

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.