You are here: Home » Topic » Disable rescan on startup? BIG library crashes on rescans

Disable rescan on startup? BIG library crashes on rescans

FireFly Media Server (formerly mt-daapd) Firefly Media Server Forums Firefly Media Server General Discussion Disable rescan on startup? BIG library crashes on rescans

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #2604
    Anonymous
    Inactive

    Hi guys,

    I’m using a DNS-323 running Firefly 1498. I have a pretty huge music library and with some recent additions I’m up to 67,000 songs. Unfortunately, since adding the last 15,000 songs or so I’ve run into an annoying issue.

    Each time the library is rescanned (on startup for example) the server crashes.

    Typically, I see something along the lines of:

    008-08-20 19:34:41 (00000400): Serving 67203 songs. Startup complete in 196 seconds
    2008-08-20 19:34:41 (00000400): Rescanning database
    2008-08-20 19:55:19 (00000400): Starting playlist scan
    2008-08-20 19:56:53 (00000400): Rendezvous socket closed (daap server crashed?) Aborting.
    2008-08-20 19:56:53: Aborting

    I don’t have any problems with initial scans, just the timeouts/crashes on rescans.

    To get Firely to start I have to delete the songs.db entirely.

    This is no doubt caused by the limited RAM/CPU power in the DNS-323 and the number of songs I’ve got in the library. I’m wondering if I can bypass rescans entirely until I’m ready to delete songs.db and scan manually.

    Can anyone point me in the right direction?

    Thanks!

    #17628
    EVILRipper
    Participant

    Standard procedure to find the cause when the log doesn’t help is to edit the config file and raise the debuglevel.

    Then try again and check the log. Most possibly there is a corrupt file of some sort, which gets firefly on his knees.

    #17629
    fizze
    Participant

    Yes, there is an config option to surpress the initial scan.
    Also, you can set the rescan interval to 0 then it will not rescan automatically. Ever. 8)

    #17630
    Anonymous
    Inactive

    Can anyone point me to the config option to supress initial scans?

    #17631
    stretch
    Participant

    You’ll find it in the advanced configuration section.
    It’s labelled “Skip first Scan”

    You could also do it by editing the config file directly and add

    skip_first = 1

    to the scanning section

    #17632
    Anonymous
    Inactive

    Thanks. That did the trick!

Viewing 6 posts - 1 through 6 (of 6 total)
  • The forum ‘General Discussion’ is closed to new topics and replies.