You are here: Home » Topic » disable-oggvorbis, doesn’t…

disable-oggvorbis, doesn’t…

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #83
    saintdev
    Guest

    I was browsing the gentoo bugzilla, and came across mt-daapd complains about missing ogg-headers even with USE=”-vorbis”. So I thought I’d check out what is going on here.
    I intentionally uninstalled libvorbis to see what would happen.
    ./configure with no options works just fine. –enable-oggvorbs comblains about missing headers as one would expect. –disable-oggvorbis, though, also complains about missing vorbis headers!

    mt-daapd-cvs-20050713 > ./configure –disable-oggvorbis
    checking for a BSD-compatible install… /usr/bin/install -c
    checking whether build environment is sane… yes

    *snip*

    checking for sqlite.h… yes
    checking for sqlite_open in -lsqlite… yes
    checking ogg/ogg.h usability… yes
    checking ogg/ogg.h presence… yes
    checking for ogg/ogg.h… yes
    checking for ogg_sync_init in -logg… yes
    checking vorbis/codec.h usability… no
    checking vorbis/codec.h presence… no
    checking for vorbis/codec.h… no
    configure: error: vorbis/codec.h not found… Must have libvorbis installed for Ogg/Vorbis support

    As you can see this is still preasent in the latest nightly build, as well as 0.2.1.1

    #3533
    rpedde
    Participant

    Fixed in cvs.

    — Ron

Viewing 2 posts - 1 through 2 (of 2 total)
  • The forum ‘Setup Issues’ is closed to new topics and replies.