You are here: Home » Topic » Database doesn’t refresh

Database doesn’t refresh

This topic contains 11 replies, has 3 voices, and was last updated by  dreamer 10 years, 11 months ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #905

    dreamer

    Running 0.2.4 on Debian sarge

    I already had a /mp3/ folder with a couple of albums/songs (30 files total) in my home-folder. After installing mt-daapd I could access this folder without a problem, Now, I’ve added more files to this folder. Reset the server, Scanned the folder. Both multiple times. There should be around 60+ files in the folder now, but there are 31, of which the one extra file isn’t even playable by any player on my client (ubuntu dapper, neither Amarok or Rhythmbox)

    #8007

    CCRDude
    Participant

    Have you made sure the new files have proper access rights? Guess mt-daapd is running under a different acount than your user account, so… πŸ˜‰

    #8008

    dreamer

    I did chmod 777 on the whole folder, or doesn’t that also give the same access to the subdirs recursively? (before I didn’t have to do this btw)

    This one extra file that doesn’t play is also very strange I think ..

    #8009

    CCRDude
    Participant

    You’ll have to do a -R … chmod -R 777 foldername πŸ˜‰
    Have you looked into the log (tail /var/log/mt-daapd.log) to see if there’s any error about that file?

    #8010

    fizze
    Participant

    I too had some issues with non-updating ID3 tags on some files. I was running svn-1400 where there deffo was some bug with re-scanning.

    Cant confirm if its gone in svn-1450.

    Try to see if the file is in the DB by searching for its filename, or maybe the tag is just bogus?

    #8011

    dreamer

    Thank you CCRDude, the chmod now worked and all media I put in is recognised πŸ™‚

    but, if I put new media in the folder, will I aggain have to put the permissions on it ?

    [edit: I gues I do πŸ˜‰ ]

    #8012

    rpedde
    Participant

    @dreamer wrote:

    Thank you CCRDude, the chmod now worked and all media I put in is recognised πŸ™‚

    but, if I put new media in the folder, will I aggain have to put the permissions on it ?

    [edit: I gues I do πŸ˜‰ ]

    Your home directory isn’t world readable. Anything you put in there isn’t readable by some strange user. There are three ways to fix it — move your mp3 files out of your home directory and put them someplace world readable, make the permissions on the mp3 files such that they are world readable, or make the daemon run as your user (which has permissions to files in your home directory).

    Any of those methods are reasonable, but the first and third seem to me to be the most correct. That’s just me, though.

    — Ron

    #8013

    dreamer

    In regard to the third option, how can I run it as user? Currently I have it running as root, howcome it can’t access everything that way? (it did in the initial first run, when there where allready files in the folder)

    #8014

    fizze
    Participant

    even root does not have access to ALL files/folders.
    By definition, the root user is not the user who HAS all access rights, but who can OBTAIN all these. (by himself, that is ;))

    Just set up the user:group in the mt-daapd.conf file. πŸ˜‰

    #8015

    dreamer

    ^ hmm, the mt-daapd.conf looks really different after running the web-config πŸ˜›

    Anyway, do I put this in: Run As and then group?

    #8016

    rpedde
    Participant

    @dreamer wrote:

    ^ hmm, the mt-daapd.conf looks really different after running the web-config πŸ˜›

    yeah, that’s the “new format” config file.

    Anyway, do I put this in: Run As and then group?

    Just put your logon name as the “runas” user. Then you won’t have to keep messing with permissions, as you always have rights to your folder.

    The problem is when you run it as root, then it drops privs to run as “nobody” (or whoever the runas user is). Theory being that it provides a smaller attack cross-section.

    When you change it to runas you, then when you start it as root, it immediately changes user to run as you, who has permissions to read the mp3 files, and everyone is happy.

    or should be. Might have to chmod 777 /var/cache/mt-daapd, though.

    — Ron

    #8017

    dreamer

    @rpedde wrote:

    or should be. Might have to chmod 777 /var/cache/mt-daapd, though.

    — Ron

    yup, the files appeared, but I couldn’t play all, thanks

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.