You are here: Home » Topic » DAAP tunneling.. halfway there.. Help!

DAAP tunneling.. halfway there.. Help!

This topic contains 21 replies, has 5 voices, and was last updated by  matthewpiatt 9 years, 9 months ago.

Viewing 15 posts - 1 through 15 (of 22 total)
  • Author
    Posts
  • #467

    htilly
    Participant

    Hi there..
    First off.. thanks for a great app! Just what I have been looking for..
    It works great on my home network.. the Shared point pops up as it should with all the music and playlists.. just smooth 😀

    However I would like to listen to the music from work (have we heard it before?)… Well.. Im up and running with a SSH tunnel.

    My setup:

    (Home) Linux SuSe 10 – mt-daap 0.2.5
    (Work) XP sp2 – iTunes 6.0.5.20
    (Work) SSH Tunnel Client
    (Work) Rendevous Proxy (Java)

    Net setup:

    SSH Tunnel – localhost port 3600 to my Linux machine on port 3689
    This work. If I telnet or surf to http://localhost:3600 I can access the mt-daap running at home.

    So I guess something is screwed up with the Rendevous.

    I have tried a bunch of setup, but I guess this is how it “should” be.
    IP: 127.0.0.1
    Port: 3600
    Host Label: MP3
    Service Text: blank
    Service Type: _daap._tcp.local.

    In iTunes: nada.. the Share does not show up..

    What am I missing here ?!

    Please help.

    BR
    Tilly

    #5655

    rpedde
    Participant

    @htilly wrote:

    Service Type: _daap._tcp.local.

    Just “_daap._tcp”.

    That should do it.

    — Ron

    #5656

    htilly
    Participant

    @rpedde wrote:

    @htilly wrote:

    Service Type: _daap._tcp.local.

    Just “_daap._tcp”.

    That should do it.

    — Ron

    Thanks for a fast reply !

    However, it looks like RendevousProxy always add .local to all services 🙁
    If I configure a new type with just _daap._tcp it will add .local to it…

    Guess I need to figure out RendevousProxy. Do you know of any other App for Windows that does the same thing ?

    BR
    Tilly

    #5657

    mlomker

    Maybe you need 5353 UDP? I found this in a search:

    http://maisonbisson.com/blog/post/10161/

    #5658

    rpedde
    Participant

    However, it looks like RendevousProxy always add .local to all services 🙁
    If I configure a new type with just _daap._tcp it will add .local to it…

    Ah. You need to have a service name. You have blank. Put anything in — that will be the name of the library that will appear in iTunes.

    I downloaded and and rendezvous proxy, and that worked for me.

    #5659

    htilly
    Participant

    Ok.. well… this is a little bit strange, but quite fun…

    As I have understood it, you need to tunnel the DAAP protocol from you’re home machine to the local computer (I can be way of here).

    However, what I discovered was that nothing worked for me.. So I thought I should take a look at the actuall network traffic.
    What happened was that as soon as I started capture packages (setting the NIC in promiscuous mode) everything just worked. Without any tunnel, only having the Rendevous Proxy pointing directly to my home computer is popped up in iTunes =)

    Maybe this is the way it is supposed to work and my computer is screwed up and only work as it should in promiscuous mode.. Anyhow.. just felt that I needed to update the post with it =)

    (It still doesn’t work in standard mode) 🙁

    /Tilly

    #5660

    rpedde
    Participant

    @htilly wrote:

    Maybe this is the way it is supposed to work and my computer is screwed up and only work as it should in promiscuous mode.. Anyhow.. just felt that I needed to update the post with it =)

    Sounds like something with the ssh tunnel client? I haven’t seen that kind of behavior with other ssh clients (cygwin+openssh or ssh.com ssh client).

    Anyway, glad it’s working in some fashion anyway.

    — Ron

    #5661

    isohedral

    Hi,

    I just downloaded svn-1400 a few days ago. I set it up without a problem, and now I’m transcoding my OGG and FLAC collection over my home network from an Ubuntu server to my Powerbook with iTunes 7. Thanks for a useful and simple tool!

    I’m revisiting this thread because I’m experiencing the same problems with SSH tunneling. I’m trying to access my home share from work. I can set up the SSH tunnel without a problem. I can telnet and http to the local port at work and see firefly as a web server. I think the mdns stuff works, using any of avahi-publish, mDNSProxyResponder, or Network Beacon. The share appears in iTunes and in Banshee (but not in Rhythmbox). But when I click on the share, I get errors. I get the “-3260” error on iTunes and some kind of “Can’t Connect” exception in Banshee.

    I feel like I’m missing one bit of magic. Can it be a firewall problem, even if telnet and http work? Any thoughts on what I’m doing wrong? By any chance, is there some good command-line daap client that offers really verbose debug information? That would be a useful diagnostic tool. In a similar vein, perhaps there could be some way to test the connection from within the web-based administrative interface — some sort of “download test song” button. Or would that not prove anything?

    Thanks.

    #5662

    rpedde
    Participant

    @isohedral wrote:

    I’m revisiting this thread because I’m experiencing the same problems with SSH tunneling. I’m trying to access my home share from work. I can set up the SSH tunnel without a problem. I can telnet and http to the local port at work and see firefly as a web server. I think the mdns stuff works, using any of avahi-publish, mDNSProxyResponder, or Network Beacon. The share appears in iTunes and in Banshee (but not in Rhythmbox). But when I click on the share, I get errors. I get the “-3260” error on iTunes and some kind of “Can’t Connect” exception in Banshee.

    Okay. so at work, you have a machine with some arbitrary ip address… let’s say 10.1.1.25. And you’ve done something like:

    ssh home-firewall -L 3689:mt-daapd-server:3689 -g

    right?

    So connections on port 3689 are forwarded to 3689 on the machine inside your home network that’s serving daap, right?

    Stuff to check:

    1. Make sure you are using the -g flag, or it will only forward requests from localhost

    2. Make sure that you are advertising the addrss of your work machine when pushing proxy mdns — that is, you are advertising _daap._tcp from 10.1.1.25:3689.

    Can it be a firewall problem, even if telnet and http work? Any thoughts on what I’m doing wrong?

    Nope, almost certainly the clients are trying to connect to the wrong ip, or your ssh tunnel isn’t accepting connections (firewall on the ssh tunnel server? 10.1.1.25 in this example?)

    [/quote]
    In a similar vein, perhaps there could be some way to test the connection from within the web-based administrative interface — some sort of “download test song” button. Or would that not prove anything?
    [/quote]

    Probably wouldn’t — if you can see the web interface, all the daap stuff (and rsp) should work.

    If you have firefox, you can try this though — it will test rsp:

    surf (with firefox) to :


    http://server:port/rsp/db/1?limit=1

    that will give you an ID for the first song.

    In my case:


    ?

    0

    1
    6809

    ?

    ?

    1
    Candy Everybody Wants
    10,000 Maniacs
    10,000 Maniacs MTV Unplugged
    Pop 1980’s
    mp3
    192
    44100
    199575
    4959688
    2000
    3 14
    0
    0
    0
    0
    0 0 MPEG audio file
    1114741642
    1114741642
    0
    0
    mpeg


    My ID there is 1.

    Now I can fetch the song:


    wget http://server:port/stream/1

    Where the 1 at the end is ID.

    If you can pull the song that way, everything is working networkingly.

    — Ron

    #5663

    hankh95
    Participant

    I was previously able to get the remote share working using RendevousProxy in windows. I just switched over to Ubuntu desktop and have looked at the guide for getting the SSH tunnel to work, but got stuck. Here is the SSH tunnel error:

    [email protected]:~$ ssh user1@#home.ip.address.# -L 3689:#home.ip.address.#:3689 -g
    user1@#.home.ip.address.#’s password:
    bind: Address already in use
    Linux silmarillion 2.6.15-28-386 #1 PREEMPT Thu Feb 1 15:51:56 UTC 2007 i686 GNU/Linux

    There is a firewall on the home network with port 3689 forwarded to the mt-daapd server. (So I do see the server at http://#home.ip.address.#:3689/status.html

    Any help is appreciated.

    #5664

    sansp00
    Participant

    Looks like your local 3689 port is already used … Could you do this:
    netstat -an|grep 3689
    If you get a port with listening or doing something else, you’ll have to find out who’s using it or reroute to another port.
    Patrick S.

    #5665

    hankh95
    Participant

    Thanks Patrick,

    The local (client machine) I am connecting from has nothing on that port. When I SSH into the server machine, it is listening on port 3689, but I figured that was the mt-daapd server…

    Might this be because the firewall is forwarding port 3689 already to that machine inside the firewall?

    #5666

    rpedde
    Participant

    @hankh95 wrote:

    [email protected]:~$ ssh user1@#home.ip.address.# -L 3689:#home.ip.address.#:3689 -g
    user1@#.home.ip.address.#’s password:
    bind: Address already in use
    Linux silmarillion 2.6.15-28-386 #1 PREEMPT Thu Feb 1 15:51:56 UTC 2007 i686 GNU/Linux

    That bind error has to be coming from your local machine. Doesn’t matter much, though, you can always pick a different address:

    ssh [email protected] -L 9999:mt-daapd-server:3689

    Then you don’t have to worry about collisions.

    There is a firewall on the home network with port 3689 forwarded to the mt-daapd server. (So I do see the server at http://#home.ip.address.#:3689/status.html

    Eeek! Don’t do that. Just leave your firewall all locked down. Instead, use the ssh tunnel to connect to the internal machine.

    I don’t know how your network is set up. I imagine you have some kind of linux box running as a gateway. Maybe a dedicated machine running a full linux distro, maybe an embedded device like a wrt54g or something.. whatever. Doesn’t matter. Let’s call the outside IP address 70.1.1.25. We’ll call the inside interface 192.168.1.1. In addition, you have a separate mt-daapd server, right? At 192.168.1.2 or something?

    Right now, you say you have a firewall rule on the gateway machine that inbound nats anything to 3689 on the outside interface to 3689 on 192.168.1.2, right?

    I’m saying don’t do that. Instead, from work, do:

    ssh [email protected] -L 9999:192.168.1.2:3689

    Then when you do

    http://localhost:9999

    from your machine at work, you should get the admin page. Then just set up proxy mdns for _daap._tcp on localhost:9999 using mDNSPosixProxy or avahi.

    — Ron

    #5667

    hankh95
    Participant

    Thanks for the great help. I made all the changes listed and dropped a service file into the avahi services directory, but I still do not see the share when I am in iTunes on the work network. Here is what is in the service file:


    < ?xml version="1.0" standalone='no'?>
    < !DOCTYPE service-group SYSTEM "avahi-service.dtd">





    Silmarillian Music


    _daap._tcp
    9999
    Silmarillian



    I have restarted the avahi-daemon but still no share from the home network… Any other suggestions?

    Thanks, 98% there

    #5668

    sansp00
    Participant

    Im not very familiar with the avahi or the syntax, but shouldn’t this be the proper way …

    < ?xml version="1.0" standalone='no'?>
    < !DOCTYPE service-group SYSTEM "avahi-service.dtd">


    Silmarillian Music

    _daap._tcp 9999 Silmarillian

    It’s worth trying … Hope it helps
    Patrick S.

Viewing 15 posts - 1 through 15 (of 22 total)

You must be logged in to reply to this topic.