You are here: Home » Topic » Configuration webpage is empty

Configuration webpage is empty

This topic contains 6 replies, has 2 voices, and was last updated by  Anonymous 10 years, 6 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #2890


    I’ve done a new install on a SheevaPlug, everything is fine, but the configuration webpage is blank except for the title, all the other webpages are there except that one, and well, it’s kinda important to me 🙂 Does anyone have any ideas what I might be doing wrong?

    Thanks for any help you can offer!



    What are the permissions on mt-daapd.conf?
    It seems that the user cannot read or write to that file. 😉



    thanks for the help fizze, I tried changing the permissions (chmod 777) that did not help the webpage problem, however, I now have bigger problems that I cannot fix. It appears that no matter what I do, I can only get mt-daapd running right after an install, once I reboot, that’s it, it never works again until I reinstall a backup of my system and completely start over, then it all happens again. I’ve tried updates, upgrades, anything I could think of and nothing is working. Please help!



    Well, I don’t know about the specifics of the SheevaPlug (looks sweet though! :))

    First, check out firefly’s log file and the syslog for obvious messages.
    Don’t panic – linux lets you custimize lots of stuff, so theres no use in doing upgrades etc if something doesn’t work.
    Usually that just makes matters worse. Instead take a deep breath and dive into the bowels of your SheevaPlug! 😉



    yes, the sheevaplug is pretty cool so far, this is the last thing I *must* get working (or else find another itunes server). It turns out I have to do an apt-get update in order to install the mt-daapd (looks like a library problem I think). I’ll layoff the upgrades. Could you explain how to up the debug level and where the log file is? I’ve seen reference on here to them, but never how you do it, I’ll keep hunting. It is somewhat promising that it at least came up once. I was just used to my other pc where it installed and that was the end of it, runs perfectly.

    Thanks again!



    the mt-daapd.conf file is usually located in /etc.
    that has a line with the debuglevel.

    The config file also specifies where the logfile is located.
    If that entry is commented out, it just logs to syslog. (usually /var/log/messages or /var/log/syslog)

    Bear in mind that you need to restart firefly for any changes in the logfile to take effect.



    alright, the logfile yeilded some interesting results, mainly not able to access the database file and not able to load the plugins. I’d seen these errors on this board, but no solutions, so I thought I’ll work through the permissions on everything. Here’s what I know:

    1) if I chmod 777 on the entire root system, everything works fine, it survives reboot and continues to work.

    2) on a fresh install (root system from backup tar) if I just erase the songs3.db and restart mt-daapd it works, but doesn’t survive reboot (as in i have to delete that file every time I want to use mt-daapd on a reboot, not acceptable). The permissions are set by the mt-daapd for the file, so I know it’s ok, and i’ve even tried 777 the file, to no avail.

    Perhaps there are two things going on? My hunch is it’s still permissions somewhere, but where? What are all the files that have to have permissions set correctly? Also, is there a clue in the reboot thing, what gets reset on reboot that it doesn’t like?

    Thanks again for the help, I feel we’re getting closer!

Viewing 7 posts - 1 through 7 (of 7 total)

The forum ‘Setup Issues’ is closed to new topics and replies.