You are here: Home » Topic » Compile error with build 1696

Compile error with build 1696

This topic contains 1 reply, has 0 voices, and was last updated by  nakamoto 8 years, 4 months ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #2783

    leifdenby

    Hi guys

    I’m trying to build on a openbsd 4.3 system. Configured the build as:
    ./configure –with-id3tag=/usr/local –enable-sqlite3 –prefix=/usr/local CFLAGS=”-O2 -fno-strict-aliasing -pipe” CPPFLAGS=” -I/usr/local/include”

    which went fine, but the compiling breaks with:
    gmake[3]: Entering directory `/home/leif/downloads/mt-daapd-svn-1696/src/mdns’
    if /bin/sh ../../libtool –tag=CC –mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I.. -I/usr/local/include -g -Wall -DHAVE_SQL -DHOST='”i386-unknown-openbsd4.3″‘ -DHAVE_BROKEN_RECVDSTADDR -I/usr/local/include -O2 -fno-strict-aliasing -pipe -MT mDNSPosix.lo -MD -MP -MF “.deps/mDNSPosix.Tpo” -c -o mDNSPosix.lo mDNSPosix.c;
    then mv -f “.deps/mDNSPosix.Tpo” “.deps/mDNSPosix.Plo”; else rm -f “.deps/mDNSPosix.Tpo”; exit 1; fi
    gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I.. -I/usr/local/include -g -Wall -DHAVE_SQL -DHOST=”i386-unknown-openbsd4.3″ -DHAVE_BROKEN_RECVDSTADDR -I/usr/local/include -O2 -fno-strict-aliasing -pipe -MT mDNSPosix.lo -MD -MP -MF .deps/mDNSPosix.Tpo -c mDNSPosix.c -fPIC -DPIC -o .libs/mDNSPosix.o
    mDNSPosix.c: In function `SocketDataReady’:
    mDNSPosix.c:517: error: structure has no member named `NotAnInteger’
    mDNSPosix.c: In function `ParseDNSServers’:
    mDNSPosix.c:664: warning: Array size (10) smaller than format string size (11) (arg 3)
    gmake[3]: *** [mDNSPosix.lo] Error 1
    gmake[3]: Leaving directory `/home/leif/downloads/mt-daapd-svn-1696/src/mdns’
    gmake[2]: *** [all-recursive] Error 1
    gmake[2]: Leaving directory `/home/leif/downloads/mt-daapd-svn-1696/src’
    gmake[1]: *** [all-recursive] Error 1
    gmake[1]: Leaving directory `/home/leif/downloads/mt-daapd-svn-1696′
    gmake: *** [all] Error 2

    I’ve tried gmake (gnu make) as well as make (bsd make), both produce the same error.

    Thanks for any help.
    Leif

    #18123

    nakamoto

    It seems nobody has answered yet..

    Change “destAddr.NotAnInteger” to “destAddr.ip.v4.NotAnInteger” as other lines.
    It seems that the author forgot to write the line to be compatible with OpenBSD.

    The line 664 is also a potential bug. The size of a variable keyword[] should be declared to be greater than 10.

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.