can’t stay connected to server

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #854
    ckest
    Guest

    I have been having a problem staying connected to the server. It connects and then drops off. I recently changed my virus protection to McAfee Internet Security but I added the firefly media server as an exception with full access. My Roku device plays the music and then stops since it keeps losing the server. I have since changed to Windows Media Connect which seems to work fine but I would rather use iTunes. Any suggestions??

    #7682
    rpedde
    Participant

    @ckest wrote:

    I have been having a problem staying connected to the server. It connects and then drops off. I recently changed my virus protection to McAfee Internet Security but I added the firefly media server as an exception with full access. My Roku device plays the music and then stops since it keeps losing the server. I have since changed to Windows Media Connect which seems to work fine but I would rather use iTunes. Any suggestions??

    Can you share any info from the logs when this happens?

    #7683
    ckest
    Guest

    I tried uninstalling firefly and reinstalling it last night but that didn’t work. I just realized that maybe I needed to uninstall Bonjour and reinstall that before reinstalling firefly which I just did. So far I am still connected. It usually drops off pretty quickly so if it does again I will post the logs. Thanks.

    #7684
    rpedde
    Participant

    @ckest wrote:

    I tried uninstalling firefly and reinstalling it last night but that didn’t work. I just realized that maybe I needed to uninstall Bonjour and reinstall that before reinstalling firefly which I just did. So far I am still connected. It usually drops off pretty quickly so if it does again I will post the logs. Thanks.

    Also might be worth trying a nightly. There is a bonjor bug fixed that possibly could have something to do with it:

    http://nightlies.mt-daapd.org

    Still like to see the logs, though.

    — Ron

    #7685
    ckest
    Guest

    This is the log since it failed again.

    2006-12-03 22:37:57 (e4ef7c5f): Starting with debuglevel 0
    2006-12-03 22:37:58 (e4ef7c5f): Starting rendezvous daemon
    2006-12-03 22:37:58 (e4ef7c5f): Error: enum_begin failed (error 1): Misc SQL Error: no such table: config
    2006-12-03 22:37:58 (e4ef7c5f): Can’t get db version. New database?
    2006-12-03 22:37:58 (e4ef7c5f): Initializing database
    2006-12-03 22:37:58 (e4ef7c5f): Error: enum_begin failed (error 1): ?
    2006-12-03 22:37:58 (e4ef7c5f): Error: enum_begin failed (error 1): ?
    2006-12-03 22:37:58 (e4ef7c5f): Full reload…
    2006-12-03 22:37:58 (e4ef7c5f): Starting mp3 scan
    2006-12-03 22:39:42 (e4ef7c5f): Starting playlist scan
    2006-12-03 22:40:15 (e4ef7c5f): Scanned 1926 songs in 137 seconds
    2006-12-03 22:40:15 (e4ef7c5f): Starting web server from C:Program FilesFirefly Media Serveradmin-root on port 9999
    2006-12-03 22:40:15 (e4ef7c5f): Registering rendezvous names
    2006-12-03 22:40:15 (e4ef7c5f): Serving 1926 songs. Startup complete in 137 seconds
    2006-12-03 22:50:17 (e4ef7c5f): Rescanning database
    2006-12-03 22:51:06 (e4ef7c5f): Query: INSERT INTO updated VALUES (452)
    2006-12-03 22:51:06 (e4ef7c5f): Error: unable to open database file
    2006-12-03 22:51:06: Aborting

    #7686
    rpedde
    Participant

    @ckest wrote:

    2006-12-03 22:51:06 (e4ef7c5f): Error: unable to open database file
    2006-12-03 22:51:06: Aborting

    That’s a virus checker error. The anti-virus software has the file open, and so firefly can’t open it. Try and set your anti-virus software such that either it doesn’t scan .db files, or that it doesn’t scan the whole “Firefly Media Center” folder.

    — Ron

    #7687
    ckest
    Guest

    The only options I have are to scan all files or just scan program files and documents. Any suggestions or do I have to forget about using it?

    #7688
    rpedde
    Participant

    @ckest wrote:

    The only options I have are to scan all files or just scan program files and documents. Any suggestions or do I have to forget about using it?

    I’d think that just scanning program files and documents should do it. I’ve been searching around a bit and I see that sqlite 3.3.6 has “improved tolerance for windows virus scanners”, so I could try moving to 3.3.6 on a nightly build. If you can hang until the next nightly, I can try that.

    #7689
    ckest
    Guest

    I tried just scanning programs and documents but it lost the server again. I dowloaded Firefly from the Roku site. I’m not sure what you mean by your other suggestions and how I would go about getting those downloads or which one to get. By the way, thanks for all your help!

    #7690
    rpedde
    Participant

    @ckest wrote:

    I tried just scanning programs and documents but it lost the server again. I dowloaded Firefly from the Roku site. I’m not sure what you mean by your other suggestions and how I would go about getting those downloads or which one to get. By the way, thanks for all your help!

    Wait until the next nightly, and I’ll get the newer sqlite3 in there.

    — Ron

    #7691
    Simon
    Guest

    @rpedde wrote:

    @ckest wrote:

    I tried just scanning programs and documents but it lost the server again. I dowloaded Firefly from the Roku site. I’m not sure what you mean by your other suggestions and how I would go about getting those downloads or which one to get. By the way, thanks for all your help!

    Wait until the next nightly, and I’ll get the newer sqlite3 in there.

    — Ron

    I’ve been having exactly the same problem. The log gives the same information as posted previously and I am running Macafee as well. I have tried all the possible fixes already suggested but none seem to make any difference.
    Has a new nightly with the newer sqlite been added yet as I can’t see it.
    Just as a thought, it may be a coincidence but this appeared to start happening after I installed IE7 and Microsoft Defender. I disabled defender but it didn’t make any difference.
    Any other suggestions for a fix to this problem?
    Thanks

    #7692
    rpedde
    Participant

    @Simon wrote:

    I’ve been having exactly the same problem. The log gives the same information as posted previously and I am running Macafee as well. I have tried all the possible fixes already suggested but none seem to make any difference.

    This http://www.rokulabs.com/forums/viewtopic.php?t=10407

    is what I’ll be implementing in the new nightly… it has instructions for fixing it yourself. I’d like to hear reports back though. I’m kind of hesitant to start shipping with sqlite3 as a db backend as opposed to sqlite2, but if I don’t hear any bad database problem with sqlite3, that’s probably what I’ll start doing.

    — Ron

    #7693
    Simon
    Guest

    @rpedde wrote:

    @Simon wrote:

    I’ve been having exactly the same problem. The log gives the same information as posted previously and I am running Macafee as well. I have tried all the possible fixes already suggested but none seem to make any difference.

    This http://www.rokulabs.com/forums/viewtopic.php?t=10407

    is what I’ll be implementing in the new nightly… it has instructions for fixing it yourself. I’d like to hear reports back though. I’m kind of hesitant to start shipping with sqlite3 as a db backend as opposed to sqlite2, but if I don’t hear any bad database problem with sqlite3, that’s probably what I’ll start doing.

    — Ron

    Thanks Ron, I followed your link and loaded the sqlite3 file and everything seems perfect now. The server has been running for over 24 hours now without any problems, compared to just a few minutes previously. I have also deleted the file exclusions from Macafee and this hasn’t had any adverse affect at all. Thanks for your help.

Viewing 13 posts - 1 through 13 (of 13 total)
  • The forum ‘Setup Issues’ is closed to new topics and replies.