Can’t get SB to notice Firefly media server (1671/1673)Vista

FireFly Media Server (formerly mt-daapd) Firefly Media Server Forums Firefly Media Server Nightlies Feedback Can’t get SB to notice Firefly media server (1671/1673)Vista

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #1795
    hans.t
    Participant

    In spite of several attempts I can’t get SB (Pinnacle M1001) to recognize Firefly Media Server, running on my Vista PC (it simply does not show as an option to select) .

    Here is a short log:

    iTunes recognizes Firefly Media Server as shared: OK
    Firewall either down or up – no difference
    SB shows up in configution -> network as accessible and as device
    SB plays radio fine
    Windows Media Player : OK on SB
    No protection enabled
    Changed ports from 9999 to 3698

    I shut down all other programs running.

    I can not change any values in the web-admin ui. General 500 db-errors.

    I am the only user with administration rights. Even though, after an exit and restart I have to run the program with specific admin rights (otherwise I cannot change any value)

    I am at a loss how to solve this. Any ideas?

    #12828
    rpedde
    Participant

    @hans.t wrote:

    I am the only user with administration rights. Even though, after an exit and restart I have to run the program with specific admin rights (otherwise I cannot change any value)

    I’m not sure exactly what you mean by this. Can you walk through a process of trying to change something, and what messages pop up?

    As far as not being discoverable, can you turn the debug level to 9 and paste the first 40 or so lines of the log file after a restart here?

    #12829
    hans.t
    Participant

    Ron, I can’t change the config file. So I cannot change the debuglevel. Neither throught notepad nor through the web admin.

    It appears as though WMP 11 has a lock on the soundbridge. Did you ever test firefly in combination WMP 11? And in the network, do you have to put on or off sharing the media files? If it is off, it won’t find any library. If it is on, it will only find the WMP libraries. Very strange.

    As for the logfile. I exited Firefly before I tried to change the configfile, therefore the database went down (I guess). After starting up firefly again, the database did not re-open (?). This logfile is shown when firefly is now running.

    What I did do sincy yesterday is changing the standard applications (from WMP to iTunes). No effect whatsoever.

    Sorry for all the trouble.

    Log file: firefly.log

    2007-10-07 13:57:51 (9c36463a): Firefly Version svn-1673: Starting with debuglevel 2
    2007-10-07 13:57:51 (9c36463a): Plugin loaded: w32-event/svn-1673
    2007-10-07 13:57:51 (9c36463a): Plugin loaded: ssc-wma/svn-1673
    2007-10-07 13:57:51 (9c36463a): Plugin loaded: ssc-ffmpeg/svn-1673
    2007-10-07 13:57:51 (9c36463a): Plugin loaded: rsp/svn-1673
    2007-10-07 13:57:51 (9c36463a): Plugin loaded: daap/svn-1673
    2007-10-07 13:57:51 (9c36463a): Starting rendezvous daemon
    2007-10-07 13:57:51 (9c36463a): Building drive mapping table from C:Program FilesFirefly Media Servermapping.ini
    2007-10-07 13:57:51 (9c36463a): Initializing database
    2007-10-07 13:57:55 (9c36463a): Starting web server from C:Program FilesFirefly Media Serveradmin-root on port 9999
    2007-10-07 13:57:55 (9c36463a): Registering rendezvous names
    2007-10-07 13:57:55 (9c36463a): Serving 8207 songs. Startup complete in 5 seconds
    2007-10-07 13:57:55 (9c36463a): Rescanning database
    2007-10-07 13:58:26 (9c36463a): Error reading mp4 data: Unknown error
    2007-10-07 13:58:26 (9c36463a): Skipping E:Mijn MuziekVarious ArtistsThe Love Collection Vol.14 – Various artists – Nilsson – Without You.m4a – scan failed
    2007-10-07 13:58:27 (9c36463a): Error reading mp4 data: Unknown error
    2007-10-07 13:58:27 (9c36463a): Skipping E:Mijn MuziekVarious ArtistsZo dit is Kerstmis7 – Various artists – Extince – Deze Kerstvakantie.m4a – scan failed
    2007-10-07 13:58:27 (9c36463a): Starting playlist scan
    2007-10-07 13:58:47 (9c36463a): Error reading mp4 data: Unknown error
    2007-10-07 13:58:47 (9c36463a): Skipping E:Mijn MuziekVarious ArtistsThe Love Collection Vol.14 – Various artists – Nilsson – Without You.m4a – scan failed
    2007-10-07 13:58:48 (9c36463a): Error reading mp4 data: Unknown error
    2007-10-07 13:58:48 (9c36463a): Skipping E:Mijn MuziekVarious ArtistsZo dit is Kerstmis7 – Various artists – Extince – Deze Kerstvakantie.m4a – scan failed
    2007-10-07 13:58:53 (9c36463a): Updating playlists
    2007-10-07 13:58:54 (9c36463a): Scanned 8207 songs (was 8207) in 59 seconds
    2007-10-07 14:04:40 (9c36463a): Stopping gracefully
    2007-10-07 14:04:40 (9c36463a): Stopping rendezvous daemon
    2007-10-07 14:04:40 (9c36463a): Closing database
    2007-10-07 14:04:40 (9c36463a): Done!

    #12830
    hans.t
    Participant

    Ron, a further update.

    I reinstalled Vista from scratch ( 😡 ) and reinstalled Firefly (port 9999). It worked fine with my SB. When I put the PC on suspend (or sleep) mode (I don’t know which term Vista is using – I run a Dutch language version) and fired it up again, firefly is still running but my SB states that no library can be found. That is the only change I put in.

    When I then shut down my PC completely and restart, Firefly still won’t work with my SB. It initially won’t allow me to change the settings (so boxes are dimmed). I have to shut down Firefly and restart it, specifically running it with administration rights (although my useraccount has them standard).

    Does this help in any way? Can you test this on your machine? Could it be that the suspend mode locks something up completely? Could DEP (the Data Encryption Protocol) from Microsoft has anything to do with it?

    It can’t be WMP 11: it has not been started after my start from scratch.

    Hans

    #12831
    rpedde
    Participant

    @hans.t wrote:

    I reinstalled Vista from scratch ( 😡 ) and reinstalled Firefly (port 9999). It worked fine with my SB. When I put the PC on suspend (or sleep) mode (I don’t know which term Vista is using – I run a Dutch language version) and fired it up again, firefly is still running but my SB states that no library can be found. That is the only change I put in.

    And this is with Bonjour for Windows 1.0.4 from the Apple site?

    When I then shut down my PC completely and restart, Firefly still won’t work with my SB. It initially won’t allow me to change the settings (so boxes are dimmed). I have to shut down Firefly and restart it, specifically running it with administration rights (although my useraccount has them standard).

    That’s not right… The permissions on c:program filesfirefly media serverfirefly.conf should be everyone:full. They must not be. It should have been installed that way.

    Ooooooh! Wait… Dutch localized. Maybe I’m stupidly using “Everyone” rather than by special SID.

    That’s probably my fault. I’ll see if I can come up with a fix for that.

    Does this help in any way? Can you test this on your machine? Could it be that the suspend mode locks something up completely? Could DEP (the Data Encryption Protocol) from Microsoft has anything to do with it?

    I bet if you change permissions on the config file, it will work okay administrator permissions-wise.

    Still won’t fix the wake-from-sleep thing. I can *try* to re-register on wake, if that seems to fix it. I’m pretty sure I can get those messages.

    #12832
    hans.t
    Participant

    Ron, great. I really appreciate you looking into this.

    I changed the permissions on all executables and changed permission rights on the conf-file. At least the options are standard available.

    Even now I still can’t change options in the web admin ui. When I want to increase the debuglevel I get the following message:
    Error: 500general:debuglevel

    One strange phenomenon. After a clean install from Vista – when I start Firefly: everything OK. Going to suspend and reanimation – SB won’t reckognize FF. Completely restarting the PC won’t help then anymore.

    I will be out the next couple of days and be back Friday.

    Good luck,

    Hans

    #12833
    rpedde
    Participant

    @hans.t wrote:

    I changed the permissions on all executables and changed permission rights on the conf-file. At least the options are standard available.

    config file and log file are lal that have to have the permissions.

    Even now I still can’t change options in the web admin ui. When I want to increase the debuglevel I get the following message:
    Error: 500general:debuglevel

    That’s a current webui bug. It still changes the value though. Or should.

    One strange phenomenon. After a clean install from Vista – when I start Firefly: everything OK. Going to suspend and reanimation – SB won’t reckognize FF. Completely restarting the PC won’t help then anymore.

    Ya, that’s why I’d have to re-register via bonjour. Could you verify you are running bonjour 1.0.4?

    Will take me a while to get it going anyway.

    — Ron

    #12834
    hans.t
    Participant

    Yep. I am using Bonjour 1.0.4.

Viewing 8 posts - 1 through 8 (of 8 total)
  • The forum ‘Nightlies Feedback’ is closed to new topics and replies.