You are here: Home » Topic » Cannot start Firefly in FC6

Cannot start Firefly in FC6

This topic contains 20 replies, has 3 voices, and was last updated by  fizze 11 years, 7 months ago.

Viewing 15 posts - 1 through 15 (of 21 total)
  • Author
    Posts
  • #1356

    zak_neutron
    Participant

    Hi – just installed (using tarball) set up and editted conf files on fedora core 6 – but using ./mt-daapd start in /etc/init.d directory fails to start the service.

    “Starting DAAP server: /bin/bash: mt-daapd: command not found”

    What gives? 🙁

    Thanks

    #10484

    fizze
    Participant

    Well you did even compile? (using the correct options?)
    I guess FC6 comes with avahi-daemon?

    Or did you use a prefix, so that the start script cant find the mt-daapd binary? 😉

    #10485

    zak_neutron
    Participant

    Fizze

    Followed all instructions – Still a little new to compiling (./configure make, make install). But all seemed to work – even had to add id3tag dependencies – which again seemed to work.

    Can I show any logs that may help?

    avahi-daemon ?

    #10486

    rpedde
    Participant

    @zak_neutron wrote:

    Hi – just installed (using tarball) set up and editted conf files on fedora core 6 – but using ./mt-daapd start in /etc/init.d directory fails to start the service.

    “Starting DAAP server: /bin/bash: mt-daapd: command not found”

    What gives? 🙁

    Thanks

    Where did you get the init script? Looks like maybe that isn’t appropriate to the version you have.

    Also, did you compile with “–prefix=/usr”? If not, your mt-daapd executable is in /usr/local/sbin, not /usr/sbin.

    So you might need ot fix up the paths in the init script, or rebuild with –prefix=/usr

    — Ron

    #10487

    zak_neutron
    Participant

    Thanks Ron

    Checking back I used:

    “./configure –with-id3tag= /usr/local/lib”

    Do i need to recompile with –prefix=/usr?

    If I did – would I need to re-edit the mt-daapd.conf file or would that be uneffected?

    🙂

    #10488

    rpedde
    Participant

    @zak_neutron wrote:

    Thanks Ron

    Checking back I used:

    “./configure –with-id3tag= /usr/local/lib”

    Do i need to recompile with –prefix=/usr?

    If I did – would I need to re-edit the mt-daapd.conf file or would that be uneffected?

    🙂

    If you use the –prefix command, and do the “make” in the root directory (not in src), then it will build a new default config that has the right info in it. You’ll need to copy that config (from contrib/mt-daapd.conf) to /etc and edit the music path and name again.

    — Ron

    #10489

    zak_neutron
    Participant

    Cheers Ron

    Just to check (still a n00b with compiling! 😳 ) my current location for tar is ~/downloads/mt-daapd-0.2.4/ do I still run the “./configure –with-id3tag= /usr/local/lib” WITH your prefix command “with –prefix=/usr”

    Then run the make, then make install?

    Then copy ~/downloads/mt-daapd-0.2.4/contrib/mt-daapd.conf to /etc and edit accordingly?

    Sorry -still learning

    Thanks for your help Ron

    #10490

    rpedde
    Participant

    @zak_neutron wrote:

    Cheers Ron

    Just to check (still a n00b with compiling! 😳 ) my current location for tar is ~/downloads/mt-daapd-0.2.4/ do I still run the “./configure –with-id3tag= /usr/local/lib” WITH your prefix command “with –prefix=/usr”

    Ah, sorry, was giving you instructions for nightlies. You want:

    ./configure –with-id3tag=/usr/local –prefix=/etc

    But in 0.2.4, it won’t automatically set up proper paths. But the default config file probably has them in the right place anyway.

    Then run the make, then make install?

    Yup

    Then copy ~/downloads/mt-daapd-0.2.4/contrib/mt-daapd.conf to /etc and edit accordingly?

    No, no need. It doesn’t get updated to reflect the prefix settings in 0.2.4, it only does that in nightlies. So just verify that the config you have right now is correct — web_root is /usr/share/mt-daapd/admin-root, and that the db path is /var/cache/mt-daapd. Make sure that’s writable by “nobody”. Might have to make that directory by hand:

    # mkdir /var/cache/mt-daapd
    # chown nobody /var/cache/mt-daapd

    That should probably do it.

    Sorry -still learning

    Thanks for your help Ron

    np. yell if you get stuck.

    — Ron

    #10491

    zak_neutron
    Participant

    Ron – thanks for all your input

    Followed all the above – still reports same error –arrgh 😡

    “Starting DAAP server: /bin/bash: mt-daapd: command not found”

    Where do I go now!

    #10492

    rpedde
    Participant

    @zak_neutron wrote:

    Ron – thanks for all your input

    Followed all the above – still reports same error –arrgh 😡

    “Starting DAAP server: /bin/bash: mt-daapd: command not found”

    Where do I go now!

    Oh.

    Did you add your library path to ld.so.conf?

    Look in /etc/ld.so.conf and make sure that the path you have your self-libraries installed to (/usr/local/lib?) is in there. Then do a “ldconfig” as root and try and start it again.

    — Ron

    #10493

    zak_neutron
    Participant

    Ron

    Done all that – still no change in error message

    contents of ld.so.conf

    #include ld.so.conf.d/*.conf
    /usr/local/lib

    contents of /usr/local/lib is:

    drwxr-xr-x 2 root root 4096 May 1 22:04 .
    drwxr-xr-x 14 root root 4096 Nov 4 22:24 ..
    -rw-r–r– 1 root root 233966 May 1 22:04 libid3tag.a
    -rwxr-xr-x 1 root root 822 May 1 22:04 libid3tag.la
    lrwxrwxrwx 1 root root 18 May 1 22:04 libid3tag.so -> libid3tag.so.0.3.0
    lrwxrwxrwx 1 root root 18 May 1 22:04 libid3tag.so.0 -> libid3tag.so.0.3.0
    -rwxr-xr-x 1 root root 178600 May 1 22:04 libid3tag.so.0.3.0

    ran idconfig no errors

    started service mt-daapd – same message… 😥

    #10494

    rpedde
    Participant

    @zak_neutron wrote:

    started service mt-daapd – same message… 😥

    It can’t find I library, I think… what does:

    $ ldd /usr/sbin/mt-daapd

    show?

    #10495

    zak_neutron
    Participant

    Ron

    I think you’re right:

    results –

    ldd: /usr/sbin/mt-daapd: No such file or directory

    #10496

    fizze
    Participant

    This all sounds very weird.
    Let me add my 0.02€ 😉

    what gives:

    ls -l /bin/bash

    ls -l /bin/sh

    and

    ls -l /usr/sbin/mt-daapd

    and

    ls -l /usr/bin/ldd

    ?

    #10497

    zak_neutron
    Participant

    OK – Thanks fizze – **deep breath*** here goes

     ls -l /bin/bash
    -rwxr-xr-x 1 root root 722684 Jul 12 2006 /bin/bash

    ls -l /bin/sh
    lrwxrwxrwx 1 root root 4 Nov 4 11:30 /bin/sh -> bash

    ls -l /usr/sbin/mt-daapd
    ls: /usr/sbin/mt-daapd: No such file or directory

    ls -l /usr/bin/ldd
    -rwxr-xr-x 1 root root 5762 Jan 5 17:04 /usr/bin/ldd

    Thanks again

Viewing 15 posts - 1 through 15 (of 21 total)

The forum ‘Setup Issues’ is closed to new topics and replies.