You are here: Home » Topic » Cannot get mt-daap to work over VPN

Cannot get mt-daap to work over VPN

This topic contains 6 replies, has 4 voices, and was last updated by  Anonymous 11 years, 2 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #2304

    Anonymous

    Hi, I cannot for the life of me seem to get the daap shares to show over the VPN. Running mdns-scan on the server shows the shares but running mdns-scan on my laptop shows none. I can access the Firefly web interface just fine.

    The server is Debian running mt-daap from the repos
    The client is Ubuntu with Banshee
    I am using OpenVPN to link them both

    Thanks

    #16556

    Anonymous

    Ziroday,

    I have been trying this on and off for over a year. Looking at the sinffer captures I know what is wrong but I can’t come up with something clever to fix it. Firefly is multicast traffic and that traffic is not being passed across the vpn tunnel even if allowed by the ruleset.

    Maybe I will start tinkering again with this. But if you come up with a fix let me know. I think openvpn just doesn’t support passing multicast traffic.

    #16557

    Anonymous

    Hi Layer3rules,

    Finally got it working using the TAP interface instead of the TUN interface (something to do with avahi refusing to leave a local network) also I am not sure if this is needed but I enabled the point to point option (read more about it at http://avahi.org/wiki/Avah4users its point 9 )

    Unfortunatly buffering takes ages (20secs of buffering for 3secs of playtime) and I have to abandon it

    #16558

    Anonymous

    I tied the TUN interface as well a while back but never tried option 9. So exactly what and where did you put these options?

    so did you put

    allow-point-to-point=

    in your

    mt-daapd.conf

    ?

    #16559

    mas
    Participant

    Try running avahi daemon on the machine that runs the client and then have avahi manually braodcast the rsp service in the local net.

    #16560

    Anonymous

    I put allow-point-to-point=yes in my avahi config file. I found it in debian under /etc/avahi/avahi-daemon.conf

    #16561

    Anonymous

    Has anyone got this to work yet? I tried allow-point-to-point=yes, and it didn’t change anything. I am using a “tun” config as it is the most simple way to connect from my work computer to my home LAN. I know a “tap” config would fix this issue but I would rather change my setup.

Viewing 7 posts - 1 through 7 (of 7 total)

The forum ‘Setup Issues’ is closed to new topics and replies.