You are here: Home » Topic » Can no longer modify Firefly Config on NSLU2

Can no longer modify Firefly Config on NSLU2

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #1615
    pietc
    Participant

    I think I’ve scored an own-goal somewhere and would very much appreciate some help in sorting myself out again.

    I’m running Firefly on an NSLU2, which serves my Creative Mediasource library to my ROKU soundbridge. The slug is configured with a 512 mB flash drive as Disc 1 and a USB hard drive as Disc 2. I’m pretty sure that I followed all the installation instructions carefully when I set the system up last December and all worked fine, including being able to modify the Firefly config file. The system setup is as follows:

    mt-daapd/Firefly Version: 0.2.4.
    Server Operating System: Linux
    Server Hardware: NSLU2
    Client Device: Roku Soundbridge M1001
    Also tried using: N/A
    Connection of clients: Wireless access point

    I can successfully log into both the NSLU2 and the Firefly server web interfaces and the first indication of a problem was when I recently tried to edit the Firefly Configuration file and couldn’t do so. Having done my homework, I concluded that this was because the mt-daapd server couldn’t write the file, so I tried to Telnet in to check permissions.

    Having made sure that I’d enabled Telnet after rebooting the Slug, I opened a Windows command line box and entered “Telnet 192.168.2.77” (I had to use the “2” to match the rest of my home system). I was prompted for the slug login and password and entered “admin” for both, which resulted in the following messages:

    “No directory, logging in with HOME=/”

    “Welcome to Unslung V2.3R63-uNSLUng-6.8-beta


    NOTE: THIS SYSTEM IS CURRENTLY UNSLUNG


    “connection to host lost.”

    … and that’s as far as I get.

    I’m assuming that both my problems (unable to modify Firefly Config and unable to Telnet) are related. For info, the Slug home page reports:

    USB Port 1: Ready, 237MB (93% Free)
    USB Port 2: Ready, 281520MB (90% Free)

    uNSLUng status: Unslung to Disk1,/dev/sdb1

    I’m not experienced in Linux, although it looks similar to CPM, which I dabbled in a couple of decades ago. I suspect (hope) that I’m doing something glaringly stupid, like using the wrong login and password, but I don’t know what else to try. The only possible clue I have is that I may have temporarily swapped the drives over when I moved my setup to a different location, but I’m not sure about that.

    I’d be most grateful for any pointers!

    Many thanks in advance,

    Piet C.

    #12012
    Anonymous
    Inactive

    Having made sure that I’d enabled Telnet after rebooting the Slug, I opened a Windows command line box and entered “Telnet 192.168.2.77” (I had to use the “2” to match the rest of my home system). I was prompted for the slug login and password and entered “admin” for both, which resulted in the following messages:

    I believe you should be logging in as ‘root’ with whatever password you have associated with ‘root’ – admin/admin are the login/password for the web interface of the slug. Your telnet session should work from there…

    #12013
    fizze
    Participant

    Sadly enough, I am not familiar with mt-daapd 0.2.4. You might want to upgrade to a newer version, but thats just a sidenote.

    To manually modify the mt-daapd.conf you have to stop mt-daapd and then start it up manually.

    Anyhow, to log in via telnet you use the user “root” and the password for admin.

    #12014
    pietc
    Participant

    andyg and fizze –

    Thank you so much for such rapid responses. You’re quite right – I’d been trying to log in with the wrong PW. Isn’t it sad how old age affects the what’s-it-called!

    Anyway, I can now Telnet in and have used

    “chmod 666 /opt/etc/mt-daapd/mt-daapd.conf”

    to (re-)enable conf file amendments, so thank you.

    Noting that I need to stop and then re-start the server, how long should this take? My server seems to hang for ages, reporting DAAP Server stopping/wait…, while Rendezvous starts and stops immediately. Grateful for any clues.

    I’ll take fizze’s advice and upgrade to a more recent nightly, once I’ve restored my confidence.

    Thanks again,

    Piet

    Some people learn from others’ mistakes; the rest of us have to be the others.

    #12015
    fizze
    Participant

    Thank you so much for such rapid responses. You’re quite right – I’d been trying to log in with the wrong PW. Isn’t it sad how old age affects the what’s-it-called!

    😆 good one, I have to remember that for later.

    Well, I’d suggest you back up your config file.
    The format radically changed so its no longer compatible.
    Anyway, you just need to adapt the mp3_dir to reflect the path where your music is located.

    Everything else is alright by default.

    Then again set the mt-daapd.conf to be world-writeable and the rest should work nicely through the web-interface.

    The reason for mt-daapd to start so long is that its doing a full-rescan at startup. So depending on your amount of music it might take a couple of mintes to a couple of hours 😉

    In newer versions of firefly / mt-daapd this behaviour can be disabled, resulting in vastly improved startup times.

    #12016
    pietc
    Participant

    Well, today was quite a rollercoaster on the learning curve! Very many thanks to those who helped. I took the advice and upgraded to the latest nightly and, once I’d messed up the config file, uninstalled mt-daapd and reinstalled from scratch, what a difference in speed and performance – it’s really impressive.

    Oh, I’m now a black belt in PuTTY and SSH as well (well, at least a yellow belt!).

    Please may I ask a supplementary without starting a new thread? I don’t use i-Tunes, so could someone please advise me on the best way to create my own playlists using Cleative MediaSource, Windows Media or similar, and in what format I need to save them? Also, any other clever tips would be appreciated.

    Again, many thanks.

    Regards,

    Piet c.

    #12017
    rpedde
    Participant

    @pietc wrote:

    Well, today was quite a rollercoaster on the learning curve! Very many thanks to those who helped. I took the advice and upgraded to the latest nightly and, once I’d messed up the config file, uninstalled mt-daapd and reinstalled from scratch, what a difference in speed and performance – it’s really impressive.

    Oh, I’m now a black belt in PuTTY and SSH as well (well, at least a yellow belt!).

    Please may I ask a supplementary without starting a new thread? I don’t use i-Tunes, so could someone please advise me on the best way to create my own playlists using Cleative MediaSource, Windows Media or similar, and in what format I need to save them? Also, any other clever tips would be appreciated.

    Again, many thanks.

    Regards,

    Piet c.

    There are lots of playlists threads around here, but the bottom line is:

    1. Use m3u format. make sure to save them in “relative” as opposed to “absolute” format

    2. save them from your playlist editor directly into the music directory of your server.

    3. Make sure you have “process playlists” and “process m3u” turned on in your advanced web config.

    If you get all three of those, you should be rewarded with playlists you can see on your soundbridge.

    Oh, and don’t forget to scan after doing that. 🙂

    — Ron

Viewing 7 posts - 1 through 7 (of 7 total)
  • The forum ‘Setup Issues’ is closed to new topics and replies.