You are here: Home » Topic » Bug report – file scanner

Bug report – file scanner

This topic contains 2 replies, has 2 voices, and was last updated by  DylanMuir 11 years, 1 month ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #444

    DylanMuir
    Participant

    Hi,

    I’m running svn-1274 on a Suse-10 linux box:
    Linux 2.6.13-15.10-default #1 Fri May 12 16:27:12 UTC 2006 i686 i686 i386 GNU/Linux

    I’m using an sqlite-3 DB.

    Config flags:
    –enable-sqlite3 –enable-mdns –enable-oggvorbis –enable-flac –enable-static –enable-shared –sysconfdir=/etc

    Ok, now the problem:
    The file scanner skips a directory called “…they all look the same to me”. I guess it’s probably because the directory name starts with “.”. I think it should be a bug… When I rename the directory with “_” instead of “.”, the files inside get scanned with no problems.

    I can provide any debug logs that may be required. Sorry it’s not the latest SVN, but I couldn’t find a mention of this anywhere so I assume the latest nightlies will exhibit the same behaviour… I apologise in advance if this has been fixed.

    DRM

    #5555

    rpedde
    Participant

    @dylanmuir wrote:

    Hi,

    I’m running svn-1274 on a Suse-10 linux box:
    Linux 2.6.13-15.10-default #1 Fri May 12 16:27:12 UTC 2006 i686 i686 i386 GNU/Linux

    I’m using an sqlite-3 DB.

    Config flags:
    –enable-sqlite3 –enable-mdns –enable-oggvorbis –enable-flac –enable-static –enable-shared –sysconfdir=/etc

    Ok, now the problem:
    The file scanner skips a directory called “…they all look the same to me”. I guess it’s probably because the directory name starts with “.”. I think it should be a bug… When I rename the directory with “_” instead of “.”, the files inside get scanned with no problems.

    I can provide any debug logs that may be required. Sorry it’s not the latest SVN, but I couldn’t find a mention of this anywhere so I assume the latest nightlies will exhibit the same behaviour… I apologise in advance if this has been fixed.

    DRM

    Check your web config — it’s an advanced option called “Ignore Dotfiles”. You’ll want to set it to “no”.

    — Ron

    #5556

    DylanMuir
    Participant

    Whoops! Thanks for replying.

    DRM

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.