You are here: Home » Topic » Automatic update/scan seems to have stopped working

Automatic update/scan seems to have stopped working

FireFly Media Server (formerly mt-daapd) Firefly Media Server Forums Firefly Media Server Setup Issues Automatic update/scan seems to have stopped working

This topic contains 7 replies, has 2 voices, and was last updated by  Anonymous 8 years, 6 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #2861

    Anonymous

    I’ve had mt-daapd running for over a year most of which has been solid uptime but a power cut the other week resulted in a restart. I did a re-install just to take advantage of the break in uptime and since then my scan interval doesn’t seem to be working – I have to go into the web interface and hit the scan button to update the track lists.

    Vitals:

    * mt-daapd svn-1586
    * Ubuntu 7.10 on an x86 PC

    In my conf file:


    [email protected]:~$ grep scan /usr/local/etc/mt-daapd.conf
    # rescan_interval
    # if not specified, the default is 0, which disables background scanning.
    # If background rescanning is disabled, a scan can still be forced from the
    # Setting a rescan_interval lower than the time it takes to rescan
    #rescan_interval = 300
    # always_scan
    # The default behavior is not not do background rescans of the
    # 24x7. Forcing a scan through the web interface will always work
    # always_scan = 0
    # scan_type
    # This sets how aggressively mp3 files should be scanned to determine
    # Just scan the first mp3 frame to try and calculate size. This will
    # first time you scan a particular file.
    scan_type = 2
    rescan_interval = 3600
    always_scan = 0

    and the same settings are on the web interface config.html screen.

    It’s going to be something dumb and obvious I’m missing, I know…

    #18421

    Anonymous

    OK, dumb obvious solution: rescan interval is minutes not seconds, right?

    facepalm.jpg

    #18422

    stretch
    Participant

    @Strawp wrote:

    OK, dumb obvious solution: rescan interval is minutes not seconds, right?

    Nope. rescan interval is in seconds.

    #18423

    Anonymous

    Odd then. I’m was seeing in my system logs that there were rescans happening there for the last 3 days at around 8.30am, which isn’t me doing it manually as I’m usually in the shower at this point. My soundbridge will have been streaming off the server just prior to this though. I think all the other scans are just me prompting them manually.

    Any ideas?

    #18424

    stretch
    Participant

    Firefly doesn’t do rescans unless there’s a client connected. This allows the server to spin down the HDD’s if it’s been configured to do so.
    With your rescan interval set to 1 hour, I’m guessing that you start playing music at around 7:30am

    #18425

    Anonymous

    Ahh! I did not know that was how it worked. I thought it just scanned after every rescan interval.

    #18426

    stretch
    Participant

    if you set

    always_scan = 1

    then Firefly will scan the library even if no clients are connected

    #18427

    Anonymous

    Cheers! Maybe that’s what I had set originally.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.