You are here: Home » Topic » Anyone have a Kurobox step by step?

Anyone have a Kurobox step by step?

This topic contains 14 replies, has 3 voices, and was last updated by  Digital Larry 10 years, 10 months ago.

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #919

    Digital Larry
    Participant

    Looks like PPC is not supported in the binaries releases, is this true?

    So then I have to set up the development environment, seems like a lot of things to deal with and plenty oppty for error or tripping over known issues.

    E.g. which OS to start with?

    Also, does the Linux OS access anything from the installed hard drive, or do all apps have to be on flash?

    #8095

    Digital Larry
    Participant

    I found what looks like a good place to start, will come back if this doesn’t work out.

    http://homepage.mac.com/cudmore/KuroBox/Menu42.html

    #8096

    rpedde
    Participant

    @Digital Larry wrote:

    I found what looks like a good place to start, will come back if this doesn’t work out.

    http://homepage.mac.com/cudmore/KuroBox/Menu42.html

    I know some people that used that for a while, seems to work okay, although last I read, alan stopped updating it in favor of a mac mini solution.

    If you were to install gentoo on the machine, you can just emerge mt-daapd. If you install debian, there are already relatively recent nightlies in testing and unstable, and if you were to run stable, there are binaries on the nightlies pages for powerpc for sarge.

    So if that doesn’t work out, there’s plenty of other alternatives.

    — Ron

    #8097

    CCRDude
    Participant

    I have Debian installed on my Kurobox for some months now, and am quite happy with it (it’s on the harddisk, not in the flash, the flash contains just a boot loader and an emergency system).

    Since I do install nightlies through compiling, I had to set up the development environment. Either on the Kurobox- or Terastation-Wiki there’s a list somewhere of what is usually needed. I must really say that it was much less things to deal with than anticipated (even though I did compile with ogg, flac and musepack support). In case of problems, use apt-cache search often to find the missing packages πŸ˜€

    #8098

    rpedde
    Participant

    @ccrdude wrote:

    I have Debian installed on my Kurobox for some months now, and am quite happy with it (it’s on the harddisk, not in the flash, the flash contains just a boot loader and an emergency system).

    I’ll second that… I helped a buddy install debian on his Kuro. Worked nice, and who doesn’t like the convenience of a full debian install. I was pretty impressed.

    So much so that I got the linkstation HG and promptly debianized it. (Kuro website was down for several months when I was wanting to get the Kuro).

    — Ron

    #8099

    Digital Larry
    Participant

    I got the Sylver 5.00 (which is apparently a Debian 2.6 variant) and after a couple of hitches got it running just fine on my KuroBox-HG. Even has the mt-daapd installer built-in (not sure of the version) and my Roku found the Kurobox just fine (even though there are no files to serve yet).

    That’s a bit of a thrill! (after spending about a week banging my head about the Debian install which I could NOT get to work).

    Now I need to proceed to move some files over to the Kuro (HG) and index them. I don’t (or wasn’t) running iTunes so I am not sure how to do this. Basically I have a stack of MP3 files that were just ripped from my CDs using Real Player and various other sources – would like to ftp the whole shebang onto the Kuro from my Windows drive and take it from there.

    I didn’t yet find the Web admin for the mt-daapd but I’m sure it’s around here somewhere.

    Thx,

    DL

    #8100

    CCRDude
    Participant

    Just use http://a.b.c.d:3689/ in your browser, where a.b.c.d is the IP address of the Kuro, and you’ll see the web interface.

    The Debian following some Wiki I did has created /mnt for all the data (not really perfect, but well…), so I did create a folder /mnt/media and put all my files in there (I did install Samba and copied them from Windows and Mac through the smb share though, not through ftp). Then I just added that path in mt-daapds web admin, and voila… without any iTunes involved πŸ˜‰

    #8101

    Digital Larry
    Participant

    I made the folder /mnt/iTunes and copied some folders over there. Background Scan doesn’t seem to find anything. When I was using Firefly on my Windows PC it scanned fine and served everything to my Roku.

    I am using the default install of mt-daapd supplied in the Sylver 5.00 build for Kurobox-HG, and the Web interface doesn’t allow me to configure anything so I am thinking I really need to start from step one to manually configure the server for this box.

    Where to start? I know that I will find the info eventually but am a little apprehensive just because of getting into some dead ends following various wikis (mostly due to outdated info I’d imagine).

    Thanx for any help.

    DL

    #8102

    CCRDude
    Participant

    The web interface doesnt allow you to configure anything? What exactly do you mean by that?

    I’ve made you a screenshot:

    * Open your browser
    * Navigate to http://192.168.x.y:3689/ (use the IP of your server here)
    * Enter any name and your password (not sure what the default is πŸ˜‰ )
    * Click on “Configuration” at the left,
    * then enter /mnt/iTunes where I have /mnt/media . Make sure about the case – on Linux, “itunes” is NOT the same as “iTunes”, for example.
    * Click on Server Status,
    * then on Start Scan.
    * Wait until then scan is finished.
    * In your iTunes, disconnect from the server if you’re still connected (since ti won’t recognize changes once connected)…
    * And connect to the server.

    the Web interface doesn’t allow me to configure anything” isn’t really a helpful description of what is going wrong, so why don’t you tell us which of the above steps fail πŸ˜‰

    #8103

    Digital Larry
    Participant

    First problem appears to be that I am using a quite old version of mt-daapd:

    Version cvs-20050815

    Which was just what came with this Sylver distro for KuroBox.

    Maybe I should get something more up to date!

    Is there some automated way to do this?

    Thx, DL

    #8104

    Digital Larry
    Participant

    Was gonna put up a screenshot but don’t have handy hosting service available. Anyway what it says is:
    ========================================
    Configuration

    Note that the following fields will only be editable if the configuration file itself is writable by the mt-daapd server. If you make changes to these settings, they will not be reflected in the running server. The server must be restarted for these values to take effect.
    ========================================
    So I cannot change any of the settings in this screen is what I meant.

    Anyway I need to get more current on the server, then let’s proceed.

    Thx so much.

    DL

    #8105

    CCRDude
    Participant

    Yeah, you should definitively get a newer version πŸ™‚
    Take a look at nightlies.mt-daapd.org, the version ending in …powerpc.deb should be the right one (powerpc for the processor thats in the Kurobox, deb for standard debian package).

    Not sure how the old one was made part of that image, you may be able to use aptitude remove mt-daapd to remove the old one, then install the new one (aptitude install mt-daapd_0.9-svn-1489_sarge_powerpc.deb). I’m not quite sure about those two commands from memory though πŸ˜‰

    An alternative would be to download the tar.gz package, then do in its folder:

    tar -xzvf mt-daapd-svn-1489.tar.gz
    cd mt-daapd-svn-1489
    ./configure --enable-oggvorbis --enable-flac --enable-musepack --enable-sqlite3
    make
    make install

    The parameters behind configure are my preferences, not necessary if you don’t have oggs, flacs or musepack audio files, or are satisfied with whatever the default database is πŸ˜‰

    To the problem you have though, you can fix that even with the old version, just do a

    chmod +w /etc/mt-daapd.conf

    Would probably be better to give only the user that runs mt-daapd write access, but I don’t know which one that is in the Sylver version πŸ˜‰

    Finally, about screenshots: ImageShack does that for free, I use a plugin named ImageBot for Firefox, which is able to upload any image from the clipboard to ImageShack, and give you the links needed to post that on forums etc.

    #8106

    Digital Larry
    Participant

    OK, well I had to take out flac support, and used sqlite instead of sqlite3, and ran these commands you gave me, and a whole bunch of stuff happened…

    So how do I know if it worked or not?

    PS my existing mt-daapd was running at the time, I did shut it down, but of course now it’s shut down and nobody home at port 3689.

    Rebooted box, and… it’s gone. Old one isn’t working any more.

    ps -aux shows no mt-daapd processes.

    README indicates need for distro-specific startup scripts.

    I tried running “mt-daapd start” in /etc/init.d, but nothing happened. No console feedback nor any mt-daapd processes showing up.

    Here’s what’s in the log:

    2007-01-22 08:08:03 (00000400): Firefly Version svn-1489: Starting with debuglevel 2
    2007-01-22 08:08:03 (00000400): Starting rendezvous daemon
    2007-01-22 08:08:03 (00000400): Starting signal handler
    2007-01-22 08:08:03 (00000400): Old database version: 6, expecting 13
    2007-01-22 08:08:03 (00000400): Upgrading db: 6 –> 7
    2007-01-22 08:08:03 (00000400): Upgrading db: 7 –> 8
    2007-01-22 08:08:03 (00000400): Query: create index idx_songid on playlistitems(songid)
    create index idx_playlistid on playlistitems(playlistid)
    update config set value=8 where term=’version’;

    2007-01-22 08:08:03 (00000400): Error: near “create”: syntax error
    2007-01-22 08:08:03 (00000400): Error upgrading db: Misc SQL Error: near “create”: syntax error
    2007-01-22 08:08:03 (00000400): Error opening db: Misc SQL Error: near “create”: syntax error

    (which is at least something)

    Any clue?

    #8107

    CCRDude
    Participant

    No answer yet? Damn πŸ˜€
    Well, yesterday I wasn’t too sure since this looked like a problem with converting an old database format to a new one, and I have no real insight into that…
    But this morning I remembered that you have nothing important in the database yet, right? No special playlists etc., so: just delete the playlist file! It’s probably at /var/cache/mt-daapd/songs.db . If you delete that, Firefly can create a fresh new database instead of trying to do half a dozen update steps to get from the old format to the new one.

    #8108

    Digital Larry
    Participant

    I did get an answer, but I’ve adopted a new strategy of starting a new thread when the topic changes enough from the original! So it’s off somewhere else.

    Apparently deleting the old songs.db will force the creation of a new one. Also I had the ancient mt-daapd.conf file still around and just need to go thru the steps of getting that right. I’ll probably have time for that in a few days.

Viewing 15 posts - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.