You are here: Home » Topic » aiff files not recognised on OSXpage 2

aiff files not recognised on OSX

Viewing 15 posts - 16 through 30 (of 34 total)
  • Author
    Posts
  • #5758
    rpedde
    Participant

    @andyg wrote:

    This is pretty weird given that they appear in itunes with all the accompanying information. Seems as if somewhere down the line the metadata has gone awol which is why they end up at the bottom of the server essentially unclassified…

    Aha! Where is your iTunes Music Library.xml file? Still in ~/Music?

    If so, go into the web interface and add /Users/you/Music to your mp3_dir paths. (so it has *both* paths).

    Then tell it to rescan, and it should merge the metadata.

    Oh. And make sure the “process m3u” setting is set to “yes” also.

    — Ron

    #5759
    mjt5282
    Guest

    I am currently running SlimServer 6.5b1 and iTunes on my Win2K server, and trying to run firefly nightly on my new NSLU2 . Everything installed fine(thanks!) and it runs OK. FLAC and MP3 work perfectly , but my AIFF files are not showing the metadata.

    I’d like to import my ITunes XML to my NSLU but will I have to regex my file paths in the XML file in order to have the proper tags on the AIFF on the NSLU ? Obviously the paths to the music files are slightly different on Win2K and Linux on my NSLU2 🙂

    Mike

    #5760
    rpedde
    Participant
    mjt5282 wrote:
    I’d like to import my ITunes XML to my NSLU but will I have to regex my file paths in the XML file in order to have the proper tags on the AIFF on the NSLU ? Obviously the paths to the music files are slightly different on Win2K and Linux on my NSLU2 🙂

    Nope, just dump it somewhere inside the mp3_dir, but above the folders that have the aiff files. For example, on my slug, I dump my xml file in the folder that has all the artist folders.

    The server should make a good effort to figure out where everything is.

    #5761
    mjt5282
    Guest

    well, I finally got it to work. The XML file has to be named : “iTunes Music Library.xml” . My file was originally named something else.

    #5762
    rpedde
    Participant

    @mjt5282 wrote:

    well, I finally got it to work. The XML file has to be named : “iTunes Music Library.xml” . My file was originally named something else.

    Ahh, yes. Sorry.. It used to try and parse anything that was a .xml file, but then it picked up backup copies of .xml files from itunes upgrades, and it really messed things up.

    So I “fixed” that. Sorry…. should have said something.

    — Ron

    #5763
    Anonymous
    Inactive

    Ron,

    thanks for the advice on adding that location to the mp3_dir path, it seems to have done the trick.

    Just one other thing though is that now it takes an absolute age – like several minutes – for firefly to load on the itunes interface on the mac. Any idea why that would be? I have about 50gb of music stored.

    Cheers, Andy

    #5764
    rpedde
    Participant

    @andyg wrote:

    Ron,

    thanks for the advice on adding that location to the mp3_dir path, it seems to have done the trick.

    Just one other thing though is that now it takes an absolute age – like several minutes – for firefly to load on the itunes interface on the mac. Any idea why that would be? I have about 50gb of music stored.

    Cheers, Andy

    Bug. Tonights nightly should fix that.

    — Ron

    #5765
    paulparker
    Guest

    I have the same problems with flac files i.e. they appear without the metadata in the itunes firefly directory

    however the xml file appears to be correctly named and is in a sub-directory within the ‘music directory’

    i am running svn-1315 on a mac powerbook osx 10.3.9

    #5766
    rpedde
    Participant

    @paulparker wrote:

    I have the same problems with flac files i.e. they appear without the metadata in the itunes firefly directory

    however the xml file appears to be correctly named and is in a sub-directory within the ‘music directory’

    i am running svn-1315 on a mac powerbook osx 10.3.9

    flac doesn’t get metadata from itunes (your flac files aren’t *in* iTunes, are they?) it reads them using libvorbisfile. How are you flac files tagged if not with regular flac tags?

    Is it possible you can send me on at ron at pedde.com?

    Oh.. duh.. nevermind… did you run configure with “–enable-flac”?

    #5767
    osmos97
    Participant

    Hi Folks

    This forum is exactly what I needed, and mt-daap is a very nice development.

    I have tried to follow this post to make my aiff file showned with content infromation but so far my itunes client still showing only the file name.

    My question is the following… I’m running mt-daap 0.2.1.1 and since this is a old release I wanted to know if this could be the issue ?

    Thanks in advance
    Chrys

    #5768
    rpedde
    Participant

    @osmos97 wrote:

    Hi Folks

    This forum is exactly what I needed, and mt-daap is a very nice development.

    I have tried to follow this post to make my aiff file showned with content infromation but so far my itunes client still showing only the file name.

    My question is the following… I’m running mt-daap 0.2.1.1 and since this is a old release I wanted to know if this could be the issue ?

    Thanks in advance
    Chrys

    Yup, only nightlies do the metadata reading for other file types.

    — Ron

    #5769
    osmos97
    Participant

    Thnals for your fast reply.. .Where can I find a tutorial or something that would help me to deploy it on my NSLU2 ?

    Thanks again for your help…

    Chrys…

    #5770
    osmos97
    Participant

    Forget my previous post… I have found everything on this forum… It is installed and so far so good

    #5771
    rpedde
    Participant

    @osmos97 wrote:

    Forget my previous post… I have found everything on this forum… It is installed and so far so good

    Glad to hear. Good luck.

    — Ron

    #5772
    osmos97
    Participant

    Great Ron…
    Everything is up and all my tags are there.. I have aiff and wav files and using the itune playlist for consolidation I have everything…

    Beside some issue with French caracteres..

    <25>Sep 10 01:13:25 mt-daapd[563]: Invalid UTF-8 in /public/MEDIA/MYMUSIC/Compilations/Best of Serge Gainsbourg – Vol.1/14 La chanson de prévert.wav

    Again thanks for you great job…

    Best regards
    Chrys

Viewing 15 posts - 16 through 30 (of 34 total)
  • The forum ‘Setup Issues’ is closed to new topics and replies.